Every CVE Search/ Get API key

CVE-2015-3991

strongSwan 5.2.2 and 5.3.0 allows remote attackers to cause a denial of service (daemon crash) or...

9.8 CriticalFix available

strongSwan 5.2.2 and 5.3.0 allows remote attackers to cause a denial of service (daemon crash) or execute arbitrary code.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

4.56%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

strongSwan 5.2.2 and 5.3.0 allows remote attackers to cause a denial of service (daemon crash) or execute arbitrary code.

Record
CVE-2015-3991
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-19
Updated
2026-11-02
CVE List No score

strongSwan 5.2.2 and 5.3.0 allows remote attackers to cause a denial of service (daemon crash) or execute arbitrary code.

Record
CVE-2015-3991
Updated
2026-11-02
EUVDEUVD-2015-4021 No score

strongSwan 5.2.2 and 5.3.0 allows remote attackers to cause a denial of service (daemon crash) or execute arbitrary code.

Record
EUVD-2015-4021
Updated
2026-11-03
GitHub AdvisoriesGHSA-23jq-mpmp-prmf 9.8

strongSwan 5.2.2 and 5.3.0 allows remote attackers to cause a denial of service (daemon crash) or...

strongSwan 5.2.2 and 5.3.0 allows remote attackers to cause a denial of service (daemon crash) or execute arbitrary code.

Record
GHSA-23jq-mpmp-prmf
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 9.8

strongSwan 5.2.2 and 5.3.0 allows remote attackers to cause a denial of service (daemon crash) or execute arbitrary code.

Record
CVE-2015-3991
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2015-3991 9.8

strongSwan 5.2.2 and 5.3.0 allows remote attackers to cause a denial of service (daemon crash) or execute arbitrary code.

Record
DEBIAN-CVE-2015-3991
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:10579-1 No score

strongswan-5.3.5-1.1 on GA media

These are all security issues fixed in the strongswan-5.3.5-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10579-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
strongswan
Debian:12
before 5.3.0-2
5.3.0-2
strongswan
Debian:13
before 5.3.0-2
5.3.0-2
strongswan
Debian:14
before 5.3.0-2
5.3.0-2
strongswan
openSUSE:Tumbleweed
From an advisory covering 11 CVEs
before 5.3.5-1.1
5.3.5-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-3991 is a critical vulnerability (CVSS 9.8) in Strongswan, published September 7, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.56%, the 91st percentile. Fixed in strongswan 5.3.0-2.

References

Show 14 moreShow less
MoveEnter Open