Every CVE Search/ Get API key

CVE-2015-4047

racoon/gssapi.c in IPsec-Tools 0.8.2 allows remote attackers to cause a denial of service (NULL...

7.8 HighFix available

CVE-2015-4047 is a high vulnerability (CVSS 7.8) in Ipsec-tools, published May 22, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 9.73%, the 95th percentile. Fixed in ipsec-tools 1:0.7.3-12+deb6u1.

racoon/gssapi.c in IPsec-Tools 0.8.2 allows remote attackers to cause a denial of service (NULL pointer dereference and IKE daemon crash) via a series of crafted UDP requests.

Exploit likelihood

9.73%Up 3.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.8

racoon/gssapi.c in IPsec-Tools 0.8.2 allows remote attackers to cause a denial of service (NULL pointer dereference and IKE daemon crash) via a series of crafted UDP requests.

Record
CVE-2015-4047
CVSS 2.0
7.8 HighAV:N/AC:L/Au:N/C:N/I:N/A:C
Weakness
CWE-476
Updated
2026-11-02
CVE List No score

racoon/gssapi.c in IPsec-Tools 0.8.2 allows remote attackers to cause a denial of service (NULL pointer dereference and IKE daemon crash) via a series of crafted UDP requests.

Record
CVE-2015-4047
Updated
2026-11-02
EUVDEUVD-2015-4075 No score

racoon/gssapi.c in IPsec-Tools 0.8.2 allows remote attackers to cause a denial of service (NULL pointer dereference and IKE daemon crash) via a series of crafted UDP requests.

Record
EUVD-2015-4075
Updated
2026-11-03
GitHub AdvisoriesGHSA-47jj-2hp6-grww No score

racoon/gssapi.c in IPsec-Tools 0.8.2 allows remote attackers to cause a denial of service (NULL...

racoon/gssapi.c in IPsec-Tools 0.8.2 allows remote attackers to cause a denial of service (NULL pointer dereference and IKE daemon crash) via a series of crafted UDP requests.

Record
GHSA-47jj-2hp6-grww
Weakness
CWE-476
Updated
2026-11-02
OSVMGASA-2015-0243 No score

Updated ipsec-tools packages fix CVE-2015-4047

Updated ipsec-tools packages fix security vulnerability:

Javantea discovered a NULL pointer dereference flaw in racoon, the Internet Key Exchange daemon of ipsec-tools. A remote attacker can use this flaw to cause the IKE daemon to crash via specially crafted UDP packets, resulting in a denial of service (CVE-2015-4047).

Record
MGASA-2015-0243
Updated
2026-11-02
OSVSUSE-SU-2015:1367-1 No score

Security update for ipsec-tools

ipsec-tools was updated to fix one security issue and a bug.

This security issue was fixed:

  • CVE-2015-4047: racoon/gssapi.c in ipsec-tools allowed remote attackers to cause a denial of service (NULL pointer dereference and IKE daemon crash) via a series of crafted UDP requests (bsc#931989).

Due to a packaging error, the racoonf.conf config file was symlinked to /usr/share/doc/packages/ipsec-tools/examples/racoon/samples/racoon.conf on some processor platforms, edits might have happened only in this example file.

Before upgrading, please check if /etc/racoon/racoon.conf is a symlink to this example file and backup the content. (bsc#939810)

Record
SUSE-SU-2015:1367-1
Updated
2026-11-02
OSVUBUNTU-CVE-2015-4047 No score

racoon/gssapi.c in IPsec-Tools 0.8.2 allows remote attackers to cause a denial of service (NULL pointer dereference and IKE daemon crash) via a series of crafted UDP requests.

Record
UBUNTU-CVE-2015-4047
Updated
2026-11-02

Affected products

Show 13 moreShow less

Affected packages

Affected packages
PackageAffectedFixed
ipsec-tools
Debian:6.0
before 1:0.7.3-12+deb6u1, plus listed versions
1:0.7.3-12
1:0.7.3-12+deb6u1
ipsec-tools
Debian:7
before 1:0.8.0-14+deb7u1, plus listed versions
1:0.8.0-14
1:0.8.0-14+deb7u1
ipsec-tools
Debian:8
before 1:0.8.2+20140711-2+deb8u1, plus listed versions
1:0.8.2+20140711-2
1:0.8.2+20140711-2+deb8u1
ipsec-tools
Mageia:4
before 0.8.1-2.1.mga4
0.8.1-2.1.mga4
ipsec-tools
SUSE:Linux Enterprise Server 11 SP3
before 0.7.3-1.13.1
0.7.3-1.13.1
ipsec-tools
SUSE:Linux Enterprise Server 11 SP3-TERADATA
before 0.7.3-1.13.1
0.7.3-1.13.1
ipsec-tools
SUSE:Linux Enterprise Server for SAP Applications 11 SP3
before 0.7.3-1.13.1
0.7.3-1.13.1
ipsec-tools
SUSE:Linux Enterprise Server 11 SP4
before 0.7.3-1.13.1
0.7.3-1.13.1
ipsec-tools
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
before 0.7.3-1.13.1
0.7.3-1.13.1
ipsec-tools
Ubuntu:14.04:LTS
before 1:0.8.0-14+deb7u1ubuntu0.1, plus listed versions
1:0.8.0-14ubuntu31:0.8.0-14ubuntu4
1:0.8.0-14+deb7u1ubuntu0.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 18 moreShow less
MoveEnter Open