Every CVE Search/ Get API key

CVE-2015-5175

Apache CXF Fediz application plugins are vulnerable to Denial of Service (DoS) attacks

7.5 HighFix available

Application plugins in Apache CXF Fediz before 1.1.3 and 1.2.x before 1.2.1 allow remote attackers to cause a denial of service.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

10.9%Up 7.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Application plugins in Apache CXF Fediz before 1.1.3 and 1.2.x before 1.2.1 allow remote attackers to cause a denial of service.

Record
CVE-2015-5175
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Application plugins in Apache CXF Fediz before 1.1.3 and 1.2.x before 1.2.1 allow remote attackers to cause a denial of service.

Record
CVE-2015-5175
Updated
2026-11-02
EUVDEUVD-2018-0481 No score

Application plugins in Apache CXF Fediz before 1.1.3 and 1.2.x before 1.2.1 allow remote attackers to cause a denial of service.

Record
EUVD-2018-0481
Updated
2026-11-03
GitHub AdvisoriesGHSA-3357-829x-m9pr 7.5

Apache CXF Fediz application plugins are vulnerable to Denial of Service (DoS) attacks

Application plugins in Apache CXF Fediz prior to version 1.1.3 and 1.2.x prior to 1.2.1 allow remote attackers to create a denial of service.

Record
GHSA-3357-829x-m9pr
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-3357-829x-m9pr 7.5

Apache CXF Fediz application plugins are vulnerable to Denial of Service (DoS) attacks

Application plugins in Apache CXF Fediz prior to version 1.1.3 and 1.2.x prior to 1.2.1 allow remote attackers to create a denial of service.

Record
GHSA-3357-829x-m9pr
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.cxf.fediz:fediz-idp
Maven
before 1.1.3
1.1.3
org.apache.cxf.fediz:fediz-idp
Maven
1.2 up to 1.2.1
1.2.1
org.apache.cxf.fediz:fediz-core
Maven
before 1.1.3
1.1.3
org.apache.cxf.fediz:fediz-core
Maven
1.2 up to 1.2.1
1.2.1
org.apache.cxf.fediz:fediz-idp
Maven
before 1.1.3, plus listed versions
1.0.01.0.11.0.21.0.31.0.41.1.01.1.11.1.2
1.1.3
org.apache.cxf.fediz:fediz-idp
Maven
1.2 up to 1.2.1, plus listed versions
1.2.0
1.2.1
org.apache.cxf.fediz:fediz-core
Maven
before 1.1.3, plus listed versions
1.0.01.0.11.0.21.0.31.0.41.1.01.1.11.1.2
1.1.3
org.apache.cxf.fediz:fediz-core
Maven
1.2 up to 1.2.1, plus listed versions
1.2.0
1.2.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-5175 is a high vulnerability (CVSS 7.5) in Apache Cxf Fediz, published June 7, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 10.9%, the 95th percentile. Fixed in org.apache.cxf.fediz:fediz-idp 1.1.3.

References

Show 16 moreShow less
MoveEnter Open