CVE-2015-5177
Double free vulnerability in the SLPDKnownDAAdd function in slpd/slpd_knownda.c in OpenSLP 1.2.1...
Double free vulnerability in the SLPDKnownDAAdd function in slpd/slpd_knownda.c in OpenSLP 1.2.1 allows remote attackers to cause a denial of service (crash) via a crafted package.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
Double free vulnerability in the SLPDKnownDAAdd function in slpd/slpd_knownda.c in OpenSLP 1.2.1 allows remote attackers to cause a denial of service (crash) via a crafted package.
- Record
CVE-2015-5177- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-415
- Updated
- 2026-11-02
CVE List No score
Double free vulnerability in the SLPDKnownDAAdd function in slpd/slpd_knownda.c in OpenSLP 1.2.1 allows remote attackers to cause a denial of service (crash) via a crafted package.
- Record
CVE-2015-5177- Updated
- 2026-11-02
EUVDEUVD-2015-5178 No score
Double free vulnerability in the SLPDKnownDAAdd function in slpd/slpd_knownda.c in OpenSLP 1.2.1 allows remote attackers to cause a denial of service (crash) via a crafted package.
- Record
EUVD-2015-5178- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3pvr-5fcv-fj5r
7.5
Double free vulnerability in the SLPDKnownDAAdd function in slpd/slpd_knownda.c in OpenSLP 1.2.1...
Double free vulnerability in the SLPDKnownDAAdd function in slpd/slpd_knownda.c in OpenSLP 1.2.1 allows remote attackers to cause a denial of service (crash) via a crafted package.
- Record
GHSA-3pvr-5fcv-fj5r- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-415
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-5177
7.5
Double free vulnerability in the SLPDKnownDAAdd function in slpd/slpd_knownda.c in OpenSLP 1.2.1 allows remote attackers to cause a denial of service (crash) via a crafted package.
- Record
UBUNTU-CVE-2015-5177- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-2730-1 No score
openslp-dfsg vulnerabilities
Georgi Geshev discovered that OpenSLP incorrectly handled processing certain service requests. A remote attacker could possibly use this issue to cause OpenSLP to crash, resulting in a denial of service. This issue only affected Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. (CVE-2012-4428)
Qinghao Tang discovered that OpenSLP incorrectly handled processing certain messages. A remote attacker could possibly use this issue to cause OpenSLP to crash, resulting in a denial of service. (CVE-2015-5177)
- Record
USN-2730-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
openslp-dfsgDebian:6.0 From an advisory covering 3 CVEs |
before 1.2.1-7.8+deb6u1, plus listed versions 1.2.1-7.8 |
1.2.1-7.8+deb6u1 |
openslp-dfsgDebian:7 |
before 1.2.1-9+deb7u1, plus listed versions 1.2.1-9 |
1.2.1-9+deb7u1 |
openslp-dfsgDebian:8 |
before 1.2.1-10+deb8u1, plus listed versions 1.2.1-10 |
1.2.1-10+deb8u1 |
openslp-dfsgUbuntu:14.04:LTS |
before 1.2.1-9ubuntu0.2, plus listed versions 1.2.1-9 |
1.2.1-9ubuntu0.2 |
openslp-dfsgUbuntu:14.04:LTS From an advisory covering 2 CVEs |
before 1.2.1-9ubuntu0.2, plus listed versions 1.2.1-9 |
1.2.1-9ubuntu0.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-5177 is a high vulnerability (CVSS 7.5) in Openslp, published August 7, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.31%, the 93rd percentile. Fixed in openslp-dfsg 1.2.1-9+deb7u1.