Every CVE Search/ Get API key

CVE-2015-5309

Integer overflow in the terminal emulator in PuTTY before 0.66 allows remote attackers to cause a...

4.3 MediumFix available

Integer overflow in the terminal emulator in PuTTY before 0.66 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via an ECH (erase characters) escape sequence with a large parameter value, which triggers a buffer underflow.

Exploit likelihood

3.47%Down 1.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Integer overflow in the terminal emulator in PuTTY before 0.66 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via an ECH (erase characters) escape sequence with a large parameter value, which triggers a buffer underflow.

Record
CVE-2015-5309
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Integer overflow in the terminal emulator in PuTTY before 0.66 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via an ECH (erase characters) escape sequence with a large parameter value, which triggers a buffer underflow.

Record
CVE-2015-5309
Updated
2026-11-02
EUVDEUVD-2015-5281 No score

Integer overflow in the terminal emulator in PuTTY before 0.66 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via an ECH (erase characters) escape sequence with a large parameter value, which triggers a buffer underflow.

Record
EUVD-2015-5281
Updated
2026-11-03
GitHub AdvisoriesGHSA-xf6h-8pvx-cg8q No score

Integer overflow in the terminal emulator in PuTTY before 0.66 allows remote attackers to cause a...

Integer overflow in the terminal emulator in PuTTY before 0.66 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via an ECH (erase characters) escape sequence with a large parameter value, which triggers a buffer underflow.

Record
GHSA-xf6h-8pvx-cg8q
Updated
2026-11-02
OSV No score

Integer overflow in the terminal emulator in PuTTY before 0.66 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via an ECH (erase characters) escape sequence with a large parameter value, which triggers a buffer underflow.

Record
CVE-2015-5309
Updated
2026-11-02
OSVDEBIAN-CVE-2015-5309 No score

Integer overflow in the terminal emulator in PuTTY before 0.66 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via an ECH (erase characters) escape sequence with a large parameter value, which triggers a buffer underflow.

Record
DEBIAN-CVE-2015-5309
Updated
2026-11-02
OSVMGASA-2015-0442 No score

Updated putty packages fix security vulnerability

Versions of PuTTY 0.54 and 0.65 inclusive have a potentially memory-corrupting integer overflow in the handling of the ECH (erase characters) control sequence in the terminal emulator (CVE-2015-5309).

Record
MGASA-2015-0442
Updated
2026-11-02
OSVopenSUSE-SU-2024:10374-1 No score

putty-0.67-1.5 on GA media

These are all security issues fixed in the putty-0.67-1.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10374-1
Updated
2026-11-02
OSVUBUNTU-CVE-2015-5309 No score

Integer overflow in the terminal emulator in PuTTY before 0.66 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via an ECH (erase characters) escape sequence with a large parameter value, which triggers a buffer underflow.

Record
UBUNTU-CVE-2015-5309
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
putty
Debian:12
before 0.66-1
0.66-1
putty
Debian:13
before 0.66-1
0.66-1
putty
Debian:14
before 0.66-1
0.66-1
putty
Debian:6.0
before 0.60+2010-02-20-1+squeeze4, plus listed versions
0.60+2010-02-20-10.60+2010-02-20-1+squeeze10.60+2010-02-20-1+squeeze20.60+2010-02-20-1+squeeze3
0.60+2010-02-20-1+squeeze4
putty
Debian:7
before 0.62-9+deb7u3, plus listed versions
0.62-90.62-9+deb7u10.62-9+deb7u2
0.62-9+deb7u3
putty
Debian:8
before 0.63-10+deb8u1, plus listed versions
0.63-10
0.63-10+deb8u1
putty
Mageia:5
before 0.66-1.mga5
0.66-1.mga5
putty
openSUSE:Tumbleweed
before 0.67-1.5
0.67-1.5

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-5309 is a medium vulnerability (CVSS 4.3) in Simon Tatham Putty, published November 10, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.47%, the 89th percentile. Fixed in putty 0.66-1.

References

Show 12 moreShow less
MoveEnter Open