CVE-2015-5341
Moodle allows attackers to read SCORM contents
mod_scorm in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 mishandles availability dates, which allows remote authenticated users to bypass intended access restrictions and read SCORM contents via unspecified vectors.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
4.3
mod_scorm in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 mishandles availability dates, which allows remote authenticated users to bypass intended access restrictions and read SCORM contents via unspecified vectors.
- Record
CVE-2015-5341- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:P/I:N/A:N - Weakness
- CWE-200, CWE-264
- Updated
- 2026-11-02
CVE List No score
mod_scorm in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 mishandles availability dates, which allows remote authenticated users to bypass intended access restrictions and read SCORM contents via unspecified vectors.
- Record
CVE-2015-5341- Updated
- 2026-11-02
EUVDEUVD-2022-3479 No score
mod_scorm in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 mishandles availability dates, which allows remote authenticated users to bypass intended access restrictions and read SCORM contents via unspecified vectors.
- Record
EUVD-2022-3479- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-c2r4-f8qv-2v7v
4.3
Moodle allows attackers to read SCORM contents
mod_scorm in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 mishandles availability dates, which allows remote authenticated users to bypass intended access restrictions and read SCORM contents via unspecified vectors.
- Record
GHSA-c2r4-f8qv-2v7v- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-c2r4-f8qv-2v7v
4.3
Moodle allows attackers to read SCORM contents
mod_scorm in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 mishandles availability dates, which allows remote authenticated users to bypass intended access restrictions and read SCORM contents via unspecified vectors.
- Record
GHSA-c2r4-f8qv-2v7v- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-5341
4.3
mod_scorm in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 mishandles availability dates, which allows remote authenticated users to bypass intended access restrictions and read SCORM contents via unspecified vectors.
- Record
UBUNTU-CVE-2015-5341- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVMGASA-2015-0464 No score
Updated moodle packages fix security vulnerability
In Moodle before 2.8.9, if guest access is open on the site, unauthenticated users can store Atto draft data through the editor autosave area, which could be exploited in a denial of service attack (CVE-2015-5332).
In Moodle before 2.8.9, due to a CSRF issue in the site registration form, it is possible to trick a site admin into sending aggregate stats to an arbitrary domain. The attacker can send the admin a link to a site registration form that will display the correct URL but, if submitted, will register with another hub (CVE-2015-5335).
In Moodle before 2.8.9, the standard survey module is vulnerable to XSS attack by students who fill the survey (CVE-2015-5336).
In Moodle before 2.8.9, there was a reflected XSS vulnerability in the Flowplayer flash video player (CVE-2015-5337).
In Moodle before 2.8.9, password-protected lesson modules are subject to a CSRF vulnerability in the lesson login form (CVE-2015-5338).
In Moodle before 2.8.9, through web service core_enrol_get_enrolled_users it is possible to retrieve list of course participants who would not be visible when using web site (CVE-2015-5339).
In Moodle before 2.8.9, logged in users who do not have capability 'View available badges without earning them' can still access the full list of badges (CVE-2015-5340).
In Moodle before 2.8.9, the SCORM module allows to bypass access restrictions based on date and lets users view the SCORM contents (CVE-2015-5341).
In Moodle before 2.8.9, the choice module closing date can be bypassed, allowing users to delete or submit new responses after the choice module was closed (CVE-2015-5342).
- Record
MGASA-2015-0464- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
before 2.7.11 | 2.7.11 |
moodle/moodlePackagist |
2.8.0 up to 2.8.9 | 2.8.9 |
moodle/moodlePackagist |
2.9.0 up to 2.9.3 | 2.9.3 |
moodle/moodlePackagist |
before 2.7.11, plus listed versions v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6 Show 45 moreShow lessv2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1 |
2.7.11 |
moodle/moodlePackagist |
2.8.0 up to 2.8.9, plus listed versions v2.8.0v2.8.1v2.8.2v2.8.3v2.8.4 Show 4 moreShow lessv2.8.5v2.8.6v2.8.7v2.8.8 |
2.8.9 |
moodle/moodlePackagist |
2.9.0 up to 2.9.3, plus listed versions v2.9.0v2.9.1v2.9.2 |
2.9.3 |
moodleMageia:5 |
before 2.8.9-1.mga5 | 2.8.9-1.mga5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-5341 is a medium vulnerability (CVSS 4.3) in Moodle, published December 5, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.31%, the 70th percentile. Fixed in moodle/moodle 2.7.11.
References
moodle.org/mod/forum/discuss.php?d=323236
git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-50837
nvd.nist.gov/vuln/detail/CVE-2015-5341
github.com/moodle/moodle/commit/03b1f63d40d09c206f641b246110c2371d3068a2
github.com/moodle/moodle/commit/3d58fd5841308018b32ca78206c74f27c4d4b9c3
github.com/moodle/moodle/commit/5f65bb2e436620f9026b363484294299c2327740
Show 20 moreShow less
github.com/moodle/moodle/commit/d01512e36c449f52ddc5e41db567d8f375fc153d
github.com/moodle/moodle/commit/d28eedd5363b4f081f9e66d0c9014d84792a89d7
github.com/moodle/moodle/commit/f1178ebcd9cf1c149892335c52f6ccad066e3e05
github.com/moodle/moodle/commit/fe9bd2b8bb73e958067f2bdb227a8d0e7cffbcda
github.com/advisories/GHSA-c2r4-f8qv-2v7v
github.com/moodle/moodle
advisories.mageia.org/MGASA-2015-0464.html
bugs.mageia.org/show_bug.cgi?id=17280
moodle.org/mod/forum/discuss.php?d=323229
moodle.org/mod/forum/discuss.php?d=323230
moodle.org/mod/forum/discuss.php?d=323231
moodle.org/mod/forum/discuss.php?d=323232
moodle.org/mod/forum/discuss.php?d=323233
moodle.org/mod/forum/discuss.php?d=323234
moodle.org/mod/forum/discuss.php?d=323235
moodle.org/mod/forum/discuss.php?d=323237
docs.moodle.org/dev/Moodle_2.8.9_release_notes
moodle.org/mod/forum/discuss.php?d=322852
ubuntu.com/security/CVE-2015-5341
cve.org/CVERecord?id=CVE-2015-5341
Left out here: 11 versions. The JSON record has them.