Every CVE Search/ Get API key

CVE-2015-5531

Improper Limitation of a Pathname to a Restricted Directory in Elasticsearch

5.0 MediumPublic exploitFix available

Directory traversal vulnerability in Elasticsearch before 1.6.1 allows remote attackers to read arbitrary files via unspecified vectors related to snapshot API calls.

Exploit likelihood

94.8%Up 17.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Directory traversal vulnerability in Elasticsearch before 1.6.1 allows remote attackers to read arbitrary files via unspecified vectors related to snapshot API calls.

Record
CVE-2015-5531
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

Directory traversal vulnerability in Elasticsearch before 1.6.1 allows remote attackers to read arbitrary files via unspecified vectors related to snapshot API calls.

Record
CVE-2015-5531
Updated
2026-11-02
EUVDEUVD-2022-4392 No score

Directory traversal vulnerability in Elasticsearch before 1.6.1 allows remote attackers to read arbitrary files via unspecified vectors related to snapshot API calls.

Record
EUVD-2022-4392
Updated
2026-11-03
GitHub AdvisoriesGHSA-jjq8-vfjq-j6v4 No score

Improper Limitation of a Pathname to a Restricted Directory in Elasticsearch

Directory traversal vulnerability in Elasticsearch before 1.6.1 allows remote attackers to read arbitrary files via unspecified vectors related to snapshot API calls.

Record
GHSA-jjq8-vfjq-j6v4
Weakness
CWE-22
Updated
2026-11-02
OSVGHSA-jjq8-vfjq-j6v4 No score

Improper Limitation of a Pathname to a Restricted Directory in Elasticsearch

Directory traversal vulnerability in Elasticsearch before 1.6.1 allows remote attackers to read arbitrary files via unspecified vectors related to snapshot API calls.

Record
GHSA-jjq8-vfjq-j6v4
Weakness
CWE-22
Updated
2026-11-02
OSVUBUNTU-CVE-2015-5531 No score

Directory traversal vulnerability in Elasticsearch before 1.6.1 allows remote attackers to read arbitrary files via unspecified vectors related to snapshot API calls.

Record
UBUNTU-CVE-2015-5531
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.elasticsearch:elasticsearch
Maven
through 1.6.0
1.6.1
org.elasticsearch:elasticsearch
Maven
before 1.6.1, plus listed versions
0.10.00.11.00.12.00.12.10.13.0
Show 45 moreShow less
0.13.10.14.00.14.10.14.20.14.30.14.40.15.00.15.10.15.20.16.00.16.10.16.20.16.30.16.40.16.50.17.00.17.10.17.100.17.20.17.30.17.40.17.50.17.60.17.70.17.80.17.90.18.00.18.10.18.20.18.30.18.40.18.50.18.60.18.70.19.00.19.0.RC10.19.0.RC20.19.0.RC30.19.10.19.100.19.110.19.120.19.20.19.30.19.4
1.6.1

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
affected, exploits
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, Metasploit, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-5531 is a medium vulnerability (CVSS 5.0) in Elasticsearch, published August 17, 2015. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 94.8%, the 99th percentile. Fixed in org.elasticsearch:elasticsearch 1.6.1.

References

Show 6 moreShow less
This page doesn't list everything

Left out here: 72 versions. The JSON record has them.

MoveEnter Open