CVE-2015-5730
The sanitize_widget_instance function in wp-includes/class-wp-customize-widgets.php in WordPress...
The sanitize_widget_instance function in wp-includes/class-wp-customize-widgets.php in WordPress before 4.2.4 does not use a constant-time comparison for widgets, which allows remote attackers to conduct a timing side-channel attack by measuring the delay before inequality is calculated.
Exploit likelihood
What each source reports
NVD Score used
5.0
The sanitize_widget_instance function in wp-includes/class-wp-customize-widgets.php in WordPress before 4.2.4 does not use a constant-time comparison for widgets, which allows remote attackers to conduct a timing side-channel attack by measuring the delay before inequality is calculated.
- Record
CVE-2015-5730- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
CVE List No score
The sanitize_widget_instance function in wp-includes/class-wp-customize-widgets.php in WordPress before 4.2.4 does not use a constant-time comparison for widgets, which allows remote attackers to conduct a timing side-channel attack by measuring the delay before inequality is calculated.
- Record
CVE-2015-5730- Updated
- 2026-11-02
EUVDEUVD-2015-5676 No score
The sanitize_widget_instance function in wp-includes/class-wp-customize-widgets.php in WordPress before 4.2.4 does not use a constant-time comparison for widgets, which allows remote attackers to conduct a timing side-channel attack by measuring the delay before inequality is calculated.
- Record
EUVD-2015-5676- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g4h2-wpj9-vf75 No score
The sanitize_widget_instance function in wp-includes/class-wp-customize-widgets.php in WordPress...
The sanitize_widget_instance function in wp-includes/class-wp-customize-widgets.php in WordPress before 4.2.4 does not use a constant-time comparison for widgets, which allows remote attackers to conduct a timing side-channel attack by measuring the delay before inequality is calculated.
- Record
GHSA-g4h2-wpj9-vf75- Weakness
- CWE-200
- Updated
- 2026-11-02
OSV No score
The sanitize_widget_instance function in wp-includes/class-wp-customize-widgets.php in WordPress before 4.2.4 does not use a constant-time comparison for widgets, which allows remote attackers to conduct a timing side-channel attack by measuring the delay before inequality is calculated.
- Record
CVE-2015-5730- Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-5730 No score
The sanitize_widget_instance function in wp-includes/class-wp-customize-widgets.php in WordPress before 4.2.4 does not use a constant-time comparison for widgets, which allows remote attackers to conduct a timing side-channel attack by measuring the delay before inequality is calculated.
- Record
DEBIAN-CVE-2015-5730- Updated
- 2026-11-02
OSVMGASA-2015-0309 No score
Updated wordpress package fixes security vulnerability
The wordpress package has been updated to version 3.9.8, fixing three cross-site scripting issues (CVE-2015-5732, CVE-2015-5733, CVE-2015-5734), a potential timing side-channel attack in Customizer (CVe-2015-5730), an issue in Heartbeat where an attacker could lock a post from being edited (CVE-2015-5731), and an SQL injection issue (CVE-2015-2213), as well as other bugs. See the upstream announcement and release notes for more details.
- Record
MGASA-2015-0309- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wordpressDebian:12 |
before 4.2.4+dfsg-1 | 4.2.4+dfsg-1 |
wordpressDebian:13 |
before 4.2.4+dfsg-1 | 4.2.4+dfsg-1 |
wordpressDebian:14 |
before 4.2.4+dfsg-1 | 4.2.4+dfsg-1 |
wordpressDebian:8 From an advisory covering 6 CVEs |
before 4.1+dfsg-1+deb8u4, plus listed versions 4.1+dfsg-14.1+dfsg-1+deb8u14.1+dfsg-1+deb8u24.1+dfsg-1+deb8u3 |
4.1+dfsg-1+deb8u4 |
wordpressMageia:4 From an advisory covering 6 CVEs |
before 3.9.8-1.mga4 | 3.9.8-1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-5730 is a medium vulnerability (CVSS 5.0) in Wordpress, published August 10, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.34%, the 94th percentile. Fixed in wordpress 4.2.4+dfsg-1.
References
wordpress.org/news/2015/08/wordpress-4-2-4-security-and-maintenance-release
core.trac.wordpress.org/changeset/33535
securityfocus.com/bid/76160
openwall.com/lists/oss-security/2015/08/04/7
securitytracker.com/id/1033178
debian.org/security/2015/dsa-3332
Show 9 moreShow less
wpvulndb.com/vulnerabilities/8130
core.trac.wordpress.org/changeset/33536
codex.wordpress.org/Version_4.2.4
nvd.nist.gov/vuln/detail/CVE-2015-5730
github.com/advisories/GHSA-g4h2-wpj9-vf75
security-tracker.debian.org/tracker/CVE-2015-5730
advisories.mageia.org/MGASA-2015-0309.html
bugs.mageia.org/show_bug.cgi?id=16531
codex.wordpress.org/Version_3.9.8