CVE-2015-7294
LDAP Injection in ldapauth
ldapauth-fork before 2.3.3 allows remote attackers to perform LDAP injection attacks via a crafted username.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
ldapauth-fork before 2.3.3 allows remote attackers to perform LDAP injection attacks via a crafted username.
- Record
CVE-2015-7294- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-90
- Updated
- 2026-11-02
CVE List No score
ldapauth-fork before 2.3.3 allows remote attackers to perform LDAP injection attacks via a crafted username.
- Record
CVE-2015-7294- Updated
- 2026-11-02
EUVDEUVD-2020-0603 No score
ldapauth-fork before 2.3.3 allows remote attackers to perform LDAP injection attacks via a crafted username.
- Record
EUVD-2020-0603- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-82mg-x548-gq3j
7.5
LDAP Injection in ldapauth
Versions 2.2.4 and earlier of ldapauth-fork are affected by an LDAP injection vulnerability. This allows an attacker to inject and run arbitrary LDAP commands via the username parameter.
Recommendation
ldapauth is not actively maintained, having not seen a publish since 2014. As a result, there is no patch available. Consider updating to use ldapauth-fork 2.3.3 or greater.
- Record
GHSA-82mg-x548-gq3j- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-90
- Updated
- 2026-11-02
OSVGHSA-82mg-x548-gq3j
7.5
LDAP Injection in ldapauth
Versions 2.2.4 and earlier of ldapauth-fork are affected by an LDAP injection vulnerability. This allows an attacker to inject and run arbitrary LDAP commands via the username parameter.
Recommendation
ldapauth is not actively maintained, having not seen a publish since 2014. As a result, there is no patch available. Consider updating to use ldapauth-fork 2.3.3 or greater.
- Record
GHSA-82mg-x548-gq3j- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-90
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ldapauth-forknpm |
before 2.3.3 | 2.3.3 |
ldapauthnpm |
before 2.2.4 | 2.2.4 |
ldapauthnpm |
All versions | None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-7294 is a high vulnerability (CVSS 7.5) in Ldapauth-fork Project Ldapauth-fork, published September 6, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.14%, the 82nd percentile. Fixed in ldapauth-fork 2.3.3.