Every CVE Search/ Get API key

CVE-2015-7318

Plone Header Injection

7.5 HighFix available

Plone 3.3.0 through 3.3.6 allows remote attackers to inject headers into HTTP responses.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.75%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Plone 3.3.0 through 3.3.6 allows remote attackers to inject headers into HTTP responses.

Record
CVE-2015-7318
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Plone 3.3.0 through 3.3.6 allows remote attackers to inject headers into HTTP responses.

Record
CVE-2015-7318
Updated
2026-11-02
EUVDEUVD-2017-0087 No score

Plone 3.3.0 through 3.3.6 allows remote attackers to inject headers into HTTP responses.

Record
EUVD-2017-0087
Updated
2026-11-03
GitHub AdvisoriesGHSA-fq9r-8jpm-2222 8.7

Plone Header Injection

Plone 3.3.0 through 3.3.6 allows remote attackers to inject headers into HTTP responses.

Record
GHSA-fq9r-8jpm-2222
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-fq9r-8jpm-2222 8.7

Plone Header Injection

Plone 3.3.0 through 3.3.6 allows remote attackers to inject headers into HTTP responses.

Record
GHSA-fq9r-8jpm-2222
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-20
Updated
2026-11-02
OSVPYSEC-2017-54 No score

Plone 3.3.0 through 3.3.6 allows remote attackers to inject headers into HTTP responses.

Record
PYSEC-2017-54
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
plone
PyPI
3.3 up to 4.0a1
4.0a1
plone
PyPI
3.3 up to 4.0a1, plus listed versions
3.3.13.3.23.3.33.3.43.3.53.3.6
4.0a1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-7318 is a high vulnerability (CVSS 7.5) in Plone, published September 25, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.75%, the 77th percentile. Fixed in plone 4.0a1.

References

MoveEnter Open