CVE-2015-8076
The index_urlfetch function in index.c in Cyrus IMAP 2.3.x before 2.3.19, 2.4.x before 2.4.18, 2...
The index_urlfetch function in index.c in Cyrus IMAP 2.3.x before 2.3.19, 2.4.x before 2.4.18, 2.5.x before 2.5.4 allows remote attackers to obtain sensitive information or possibly have unspecified other impact via vectors related to the urlfetch range, which triggers an out-of-bounds heap read.
Exploit likelihood
What each source reports
NVD Score used
7.5
The index_urlfetch function in index.c in Cyrus IMAP 2.3.x before 2.3.19, 2.4.x before 2.4.18, 2.5.x before 2.5.4 allows remote attackers to obtain sensitive information or possibly have unspecified other impact via vectors related to the urlfetch range, which triggers an out-of-bounds heap read.
- Record
CVE-2015-8076- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119, CWE-200
- Updated
- 2026-11-02
CVE List No score
The index_urlfetch function in index.c in Cyrus IMAP 2.3.x before 2.3.19, 2.4.x before 2.4.18, 2.5.x before 2.5.4 allows remote attackers to obtain sensitive information or possibly have unspecified other impact via vectors related to the urlfetch range, which triggers an out-of-bounds heap read.
- Record
CVE-2015-8076- Updated
- 2026-11-02
EUVDEUVD-2015-7969 No score
The index_urlfetch function in index.c in Cyrus IMAP 2.3.x before 2.3.19, 2.4.x before 2.4.18, 2.5.x before 2.5.4 allows remote attackers to obtain sensitive information or possibly have unspecified other impact via vectors related to the urlfetch range, which triggers an out-of-bounds heap read.
- Record
EUVD-2015-7969- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fxwg-gpw8-9wrp No score
The index_urlfetch function in index.c in Cyrus IMAP 2.3.x before 2.3.19, 2.4.x before 2.4.18, 2...
The index_urlfetch function in index.c in Cyrus IMAP 2.3.x before 2.3.19, 2.4.x before 2.4.18, 2.5.x before 2.5.4 allows remote attackers to obtain sensitive information or possibly have unspecified other impact via vectors related to the urlfetch range, which triggers an out-of-bounds heap read.
- Record
GHSA-fxwg-gpw8-9wrp- Weakness
- CWE-119
- Updated
- 2026-11-02
OSVSUSE-SU-2016:1457-1 No score
Security update for cyrus-imapd
-
Previous versions of cyrus-imapd would not allow its users to disable old protocols like SSLv1 and SSLv2 that are unsafe due to various known attacks like BEAST and POODLE. https://bugzilla.cyrusimap.org/show_bug.cgi?id=3867 remedies this issue by adding the configuration option 'tls_versions' to the imapd.conf file. Note that users who upgrade existing installation of this package will not have their imapd.conf file overwritten, i.e. their IMAP server will continue to support SSLv1 and SSLv2 like before. To disable support for those protocols, it's necessary to edit imapd.conf manually to state 'tls_versions: tls1_0 tls1_1 tls1_2'. New installations, however, will have an imapd.conf file that contains these settings already, i.e. newly installed IMAP servers do not support SSLv1 and SSLv2 unless that support is explicitly enabled by the user. (bsc#901748)
-
An integer overflow vulnerability in cyrus-imapd's urlfetch range checking code was fixed. (CVE-2015-8076, CVE-2015-8077, CVE-2015-8078, bsc#981670, bsc#954200, bsc#954201)
-
Support for Elliptic Curve Diffie–Hellman (ECDH) has been added to cyrus-imapd. (bsc#860611)
- Record
SUSE-SU-2016:1457-1- Updated
- 2026-11-02
OSVSUSE-SU-2016:1459-1 No score
Security update for cyrus-imapd
This update for cyrus-imapd fixes the following issues:
-
Previous versions of cyrus-imapd would not allow its users to disable old SSL variants that are vulnerable to attacks like BEAST and POODLE. This patch adds the configuration option 'tls_versions' to remedy that issue. Note that users who upgrade an existing installation will not have their imapd.conf file overwritten, i.e. their IMAP server will continue to support SSLv2 and SSLv3 like before. To disable support for those protocols, edit imapd.conf manually to include 'tls_versions: tls1_0 tls1_1 tls1_2'. New installations, however, will have an imapd.conf file that contains these settings already, i.e. newly installed IMAP servers do not support unsafe versions of SSL unless that support is explicitly enabled by the user. (bsc#901748)
-
An integer overflow vulnerability in cyrus-imapd's urlfetch range checking code was fixed. (CVE-2015-8076, CVE-2015-8077, CVE-2015-8078, bsc#981670, bsc#954200, bsc#954201)
-
Support for Elliptic Curve Diffie–Hellman (ECDH) has been added to cyrus-imapd. (bsc#860611)
- Record
SUSE-SU-2016:1459-1- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-8076 No score
The index_urlfetch function in index.c in Cyrus IMAP 2.3.x before 2.3.19, 2.4.x before 2.4.18, 2.5.x before 2.5.4 allows remote attackers to obtain sensitive information or possibly have unspecified other impact via vectors related to the urlfetch range, which triggers an out-of-bounds heap read.
- Record
UBUNTU-CVE-2015-8076- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cyrus-imapdSUSE:Linux Enterprise Server 12 |
before 2.3.18-37.1 | 2.3.18-37.1 |
cyrus-imapdSUSE:Linux Enterprise Server for SAP Applications 12 |
before 2.3.18-37.1 | 2.3.18-37.1 |
cyrus-imapdSUSE:Linux Enterprise Server 12 SP1 |
before 2.3.18-37.1 | 2.3.18-37.1 |
cyrus-imapdSUSE:Linux Enterprise Server for SAP Applications 12 SP1 |
before 2.3.18-37.1 | 2.3.18-37.1 |
cyrus-imapdSUSE:Linux Enterprise Software Development Kit 11 SP4 |
before 2.3.11-60.65.67.1 | 2.3.11-60.65.67.1 |
cyrus-imapdSUSE:Linux Enterprise Server 11 SP4 |
before 2.3.11-60.65.67.1 | 2.3.11-60.65.67.1 |
cyrus-imapdSUSE:Linux Enterprise Server for SAP Applications 11 SP4 |
before 2.3.11-60.65.67.1 | 2.3.11-60.65.67.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-8076 is a high vulnerability (CVSS 7.5) in Cyrus Imap, published December 3, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.26%, the 88th percentile. Fixed in cyrus-imapd 2.3.18-37.1.
References
docs.cyrus.foundation/imap/release-notes/2.3/x/2.3.19.html
docs.cyrus.foundation/imap/release-notes/2.4/x/2.4.18.html
lists.opensuse.org/opensuse-updates/2015-09/msg00038.html
docs.cyrus.foundation/imap/release-notes/2.5/x/2.5.4.html
openwall.com/lists/oss-security/2015/11/04/3
lists.opensuse.org/opensuse-updates/2015-09/msg00037.html
Show 21 moreShow less
cyrus.foundation/cyrus-imapd/commit?id=07de4ff1bf2fa340b9d77b8e7de8d43d47a33921
openwall.com/lists/oss-security/2015/09/30/3
lists.opensuse.org/opensuse-security-announce/2016-06/msg00000.html
lists.opensuse.org/opensuse-security-announce/2016-05/msg00066.html
openwall.com/lists/oss-security/2015/09/29/2
cyrus.foundation/cyrus-imapd/commit?id=c21e179c1f6b968fe69bebe079176714e511587b
nvd.nist.gov/vuln/detail/CVE-2015-8076
github.com/advisories/GHSA-fxwg-gpw8-9wrp
suse.com/support/update/announcement/2016/suse-su-20161457-1
bugzilla.suse.com/860611
bugzilla.suse.com/901748
bugzilla.suse.com/954200
bugzilla.suse.com/954201
bugzilla.suse.com/981670
suse.com/security/cve/CVE-2014-3566
suse.com/security/cve/CVE-2015-8076
suse.com/security/cve/CVE-2015-8077
suse.com/security/cve/CVE-2015-8078
suse.com/support/update/announcement/2016/suse-su-20161459-1
ubuntu.com/security/CVE-2015-8076
cve.org/CVERecord?id=CVE-2015-8076