Every CVE Search/ Get API key

CVE-2015-8124

Symfony Session Fixation Vulnerability

6.8 MediumFix available

Session fixation vulnerability in the "Remember Me" login feature in Symfony 2.3.x before 2.3.35, 2.6.x before 2.6.12, and 2.7.x before 2.7.7 allows remote attackers to hijack web sessions via a session id.

Exploit likelihood

2.71%Up 1.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Session fixation vulnerability in the "Remember Me" login feature in Symfony 2.3.x before 2.3.35, 2.6.x before 2.6.12, and 2.7.x before 2.7.7 allows remote attackers to hijack web sessions via a session id.

Record
CVE-2015-8124
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Session fixation vulnerability in the "Remember Me" login feature in Symfony 2.3.x before 2.3.35, 2.6.x before 2.6.12, and 2.7.x before 2.7.7 allows remote attackers to hijack web sessions via a session id.

Record
CVE-2015-8124
Updated
2026-11-02
EUVDEUVD-2022-4284 No score

Session fixation vulnerability in the "Remember Me" login feature in Symfony 2.3.x before 2.3.35, 2.6.x before 2.6.12, and 2.7.x before 2.7.7 allows remote attackers to hijack web sessions via a session id.

Record
EUVD-2022-4284
Updated
2026-11-03
GitHub AdvisoriesGHSA-j5jh-hpr4-h332 3.1

Symfony Session Fixation Vulnerability

A session fixation vulnerability within the "Remember Me" login feature allows an attacker to impersonate the victim towards the web application if the session id value was previously known to the attacker. This issue has been fixed in Symfony 2.3.35, 2.6.12, and 2.7.7. Note that no fixes are provided for Symfony 2.4 and 2.5 as they are not maintained anymore. Symfony 2.8 and 3.0 haven't been released yet and the fix will be included in their first stable releases.

Record
GHSA-j5jh-hpr4-h332
CVSS 3.1
3.1 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
Weakness
CWE-384
Updated
2026-11-02
OSVGHSA-j5jh-hpr4-h332 3.1

Symfony Session Fixation Vulnerability

A session fixation vulnerability within the "Remember Me" login feature allows an attacker to impersonate the victim towards the web application if the session id value was previously known to the attacker. This issue has been fixed in Symfony 2.3.35, 2.6.12, and 2.7.7. Note that no fixes are provided for Symfony 2.4 and 2.5 as they are not maintained anymore. Symfony 2.8 and 3.0 haven't been released yet and the fix will be included in their first stable releases.

Record
GHSA-j5jh-hpr4-h332
CVSS 3.1
3.1 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
Weakness
CWE-384
Updated
2026-11-02
OSV No score

Session fixation vulnerability in the "Remember Me" login feature in Symfony 2.3.x before 2.3.35, 2.6.x before 2.6.12, and 2.7.x before 2.7.7 allows remote attackers to hijack web sessions via a session id.

Record
CVE-2015-8124
Updated
2026-11-02
OSVDEBIAN-CVE-2015-8124 No score

Session fixation vulnerability in the "Remember Me" login feature in Symfony 2.3.x before 2.3.35, 2.6.x before 2.6.12, and 2.7.x before 2.7.7 allows remote attackers to hijack web sessions via a session id.

Record
DEBIAN-CVE-2015-8124
Updated
2026-11-02
OSVUBUNTU-CVE-2015-8124 No score

Session fixation vulnerability in the "Remember Me" login feature in Symfony 2.3.x before 2.3.35, 2.6.x before 2.6.12, and 2.7.x before 2.7.7 allows remote attackers to hijack web sessions via a session id.

Record
UBUNTU-CVE-2015-8124
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
symfony/symfony
Packagist
2.3.0 up to 2.3.35
2.3.35
symfony/symfony
Packagist
2.4.0 up to 2.6.12
2.6.12
symfony/symfony
Packagist
2.7.0 up to 2.7.7
2.7.7
symfony/security-http
Packagist
2.4.0 up to 2.6.12
2.6.12
symfony/security-http
Packagist
2.7.0 up to 2.7.7
2.7.7
symfony/security
Packagist
2.3.0 up to 2.3.35
2.3.35
symfony/security
Packagist
2.4.0 up to 2.6.12
2.6.12
symfony/security
Packagist
2.7.0 up to 2.7.7
2.7.7
symfony
Debian:12
before 2.7.7+dfsg-1
2.7.7+dfsg-1
symfony
Debian:13
before 2.7.7+dfsg-1
2.7.7+dfsg-1
Show 10 moreShow less
Affected packages
PackageAffectedFixed
symfony
Debian:14
before 2.7.7+dfsg-1
2.7.7+dfsg-1
symfony
Debian:8
From an advisory covering 2 CVEs
before 2.3.21+dfsg-4+deb8u2, plus listed versions
2.3.21+dfsg-42.3.21+dfsg-4+deb8u1
2.3.21+dfsg-4+deb8u2
symfony/symfony
Packagist
2.3.0 up to 2.3.35, plus listed versions
v2.3.0v2.3.1v2.3.10v2.3.11v2.3.12
Show 30 moreShow less
v2.3.13v2.3.14v2.3.15v2.3.16v2.3.17v2.3.18v2.3.19v2.3.2v2.3.20v2.3.21v2.3.22v2.3.23v2.3.24v2.3.25v2.3.26v2.3.27v2.3.28v2.3.29v2.3.3v2.3.30v2.3.31v2.3.32v2.3.33v2.3.34v2.3.4v2.3.5v2.3.6v2.3.7v2.3.8v2.3.9
2.3.35
symfony/symfony
Packagist
2.4.0 up to 2.6.12, plus listed versions
v2.4.0v2.4.1v2.4.10v2.4.2v2.4.3
Show 36 moreShow less
v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-BETA1v2.5.0-BETA2v2.5.0-RC1v2.5.1v2.5.10v2.5.11v2.5.12v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-BETA1v2.6.0-BETA2v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9
2.6.12
symfony/symfony
Packagist
2.7.0 up to 2.7.7, plus listed versions
v2.7.0v2.7.1v2.7.2v2.7.3v2.7.4v2.7.5v2.7.6
2.7.7
symfony/security-http
Packagist
2.4.0 up to 2.6.12, plus listed versions
v2.4.0v2.4.1v2.4.10v2.4.2v2.4.3
Show 36 moreShow less
v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-BETA1v2.5.0-BETA2v2.5.0-RC1v2.5.1v2.5.10v2.5.11v2.5.12v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-BETA1v2.6.0-BETA2v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9
2.6.12
symfony/security-http
Packagist
2.7.0 up to 2.7.7, plus listed versions
v2.7.0v2.7.1v2.7.2v2.7.3v2.7.4v2.7.5v2.7.6
2.7.7
symfony/security
Packagist
2.3.0 up to 2.3.35, plus listed versions
v2.3.0v2.3.1v2.3.10v2.3.11v2.3.12
Show 30 moreShow less
v2.3.13v2.3.14v2.3.15v2.3.16v2.3.17v2.3.18v2.3.19v2.3.2v2.3.20v2.3.21v2.3.22v2.3.23v2.3.24v2.3.25v2.3.26v2.3.27v2.3.28v2.3.29v2.3.3v2.3.30v2.3.31v2.3.32v2.3.33v2.3.34v2.3.4v2.3.5v2.3.6v2.3.7v2.3.8v2.3.9
2.3.35
symfony/security
Packagist
2.4.0 up to 2.6.12, plus listed versions
v2.4.0v2.4.1v2.4.10v2.4.2v2.4.3
Show 36 moreShow less
v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-BETA1v2.5.0-BETA2v2.5.0-RC1v2.5.1v2.5.10v2.5.11v2.5.12v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-BETA1v2.6.0-BETA2v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9
2.6.12
symfony/security
Packagist
2.7.0 up to 2.7.7, plus listed versions
v2.7.0v2.7.1v2.7.2v2.7.3v2.7.4v2.7.5v2.7.6
2.7.7

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-8124 is a medium vulnerability (CVSS 6.8) in Sensiolabs Symfony, published November 24, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.71%, the 86th percentile. Fixed in symfony/symfony 2.3.35.

References

Show 13 moreShow less
MoveEnter Open