CVE-2015-8547
The CoreUserInputHandler::doMode function in core/coreuserinputhandler.cpp in Quassel 0.10.0...
The CoreUserInputHandler::doMode function in core/coreuserinputhandler.cpp in Quassel 0.10.0 allows remote attackers to cause a denial of service (application crash) via the "/op *" command in a query.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
The CoreUserInputHandler::doMode function in core/coreuserinputhandler.cpp in Quassel 0.10.0 allows remote attackers to cause a denial of service (application crash) via the "/op *" command in a query.
- Record
CVE-2015-8547- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-17
- Updated
- 2026-11-02
CVE List No score
The CoreUserInputHandler::doMode function in core/coreuserinputhandler.cpp in Quassel 0.10.0 allows remote attackers to cause a denial of service (application crash) via the "/op *" command in a query.
- Record
CVE-2015-8547- Updated
- 2026-11-02
EUVDEUVD-2015-8428 No score
The CoreUserInputHandler::doMode function in core/coreuserinputhandler.cpp in Quassel 0.10.0 allows remote attackers to cause a denial of service (application crash) via the "/op *" command in a query.
- Record
EUVD-2015-8428- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3c22-99pq-qjv4
7.5
The CoreUserInputHandler::doMode function in core/coreuserinputhandler.cpp in Quassel 0.10.0...
The CoreUserInputHandler::doMode function in core/coreuserinputhandler.cpp in Quassel 0.10.0 allows remote attackers to cause a denial of service (application crash) via the "/op *" command in a query.
- Record
GHSA-3c22-99pq-qjv4- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSV
7.5
The CoreUserInputHandler::doMode function in core/coreuserinputhandler.cpp in Quassel 0.10.0 allows remote attackers to cause a denial of service (application crash) via the "/op *" command in a query.
- Record
CVE-2015-8547- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-8547
7.5
The CoreUserInputHandler::doMode function in core/coreuserinputhandler.cpp in Quassel 0.10.0 allows remote attackers to cause a denial of service (application crash) via the "/op *" command in a query.
- Record
DEBIAN-CVE-2015-8547- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-8547
7.5
The CoreUserInputHandler::doMode function in core/coreuserinputhandler.cpp in Quassel 0.10.0 allows remote attackers to cause a denial of service (application crash) via the "/op *" command in a query.
- Record
UBUNTU-CVE-2015-8547- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2015-0475 No score
Updated quassel packages fix security vulnerability
The Quassel core could be crashed by a client using the op command, causing a denial of service (CVE-2015-8547).
- Record
MGASA-2015-0475- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10119-1 No score
quassel-base-0.12.4-3.3 on GA media
These are all security issues fixed in the quassel-base-0.12.4-3.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10119-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
quasselDebian:12 |
before 1:0.12.2-3 | 1:0.12.2-3 |
quasselDebian:13 |
before 1:0.12.2-3 | 1:0.12.2-3 |
quasselDebian:14 |
before 1:0.12.2-3 | 1:0.12.2-3 |
quasselMageia:5 |
before 0.10.1-5.1.mga5 | 0.10.1-5.1.mga5 |
quasselUbuntu:16.04:LTS |
All versions, plus listed versions 0.12.2-0ubuntu10.12.2-0ubuntu1.16.04.2 |
None known |
quasselopenSUSE:Tumbleweed From an advisory covering 3 CVEs |
before 0.12.4-3.3 | 0.12.4-3.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-8547 is a high vulnerability (CVSS 7.5) in Quassel-irc Quassel, published December 16, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.83%, the 86th percentile. Fixed in quassel 1:0.12.2-3.
References
lists.opensuse.org/opensuse-updates/2015-12/msg00099.html
github.com/quassel/quassel/pull/153
github.com/quassel/quassel/commit/b8edbda019eeb99da8663193e224efc9d1265dc7
lists.fedoraproject.org/pipermail/package-announce/2016-January/174976.html
lists.fedoraproject.org/pipermail/package-announce/2016-January/174938.html
openwall.com/lists/oss-security/2015/12/12/1
Show 11 moreShow less
openwall.com/lists/oss-security/2015/12/13/1
nvd.nist.gov/vuln/detail/CVE-2015-8547
github.com/advisories/GHSA-3c22-99pq-qjv4
security-tracker.debian.org/tracker/CVE-2015-8547
advisories.mageia.org/MGASA-2015-0475.html
bugs.mageia.org/show_bug.cgi?id=17328
ubuntu.com/security/CVE-2015-8547
cve.org/CVERecord?id=CVE-2015-8547
suse.com/security/cve/CVE-2013-4422
suse.com/security/cve/CVE-2015-8547
suse.com/security/cve/CVE-2016-4414