Every CVE Search/ Get API key

CVE-2015-8980

The plural form formula in ngettext family of calls in php-gettext before 1.0.12 allows remote...

9.8 CriticalFix available

CVE-2015-8980 is a critical vulnerability (CVSS 9.8) in Php-gettext Project Php-gettext, published February 3, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.38%, the 93rd percentile. Fixed in php-gettext 1.0.12-0.1.

The plural form formula in ngettext family of calls in php-gettext before 1.0.12 allows remote attackers to execute arbitrary code.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

6.38%Down 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

The plural form formula in ngettext family of calls in php-gettext before 1.0.12 allows remote attackers to execute arbitrary code.

Record
CVE-2015-8980
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The plural form formula in ngettext family of calls in php-gettext before 1.0.12 allows remote attackers to execute arbitrary code.

Record
CVE-2015-8980
Updated
2026-11-02
EUVDEUVD-2015-8834 No score

The plural form formula in ngettext family of calls in php-gettext before 1.0.12 allows remote attackers to execute arbitrary code.

Record
EUVD-2015-8834
Updated
2026-11-03
GitHub AdvisoriesGHSA-gxcv-w2wp-7xvm 9.8

The plural form formula in ngettext family of calls in php-gettext before 1.0.12 allows remote...

The plural form formula in ngettext family of calls in php-gettext before 1.0.12 allows remote attackers to execute arbitrary code.

Record
GHSA-gxcv-w2wp-7xvm
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 9.8

The plural form formula in ngettext family of calls in php-gettext before 1.0.12 allows remote attackers to execute arbitrary code.

Record
CVE-2015-8980
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2015-8980 9.8

The plural form formula in ngettext family of calls in php-gettext before 1.0.12 allows remote attackers to execute arbitrary code.

Record
DEBIAN-CVE-2015-8980
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2015-8980 9.8

The plural form formula in ngettext family of calls in php-gettext before 1.0.12 allows remote attackers to execute arbitrary code.

Record
UBUNTU-CVE-2015-8980
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2017-0038 No score

Updated phpmyadmin packages fix security vulnerabilities

Multiple vulnerabilities in setup script (CVE-2016-6621 / PMASA-2016-44).

Open redirect (PMASA-2017-1).

php-gettext code execution (CVE-2015-8980 / PMASA-2017-2).

DOS vulnerability in table editing (PMASA-2017-3).

CSS injection in themes (PMASA-2017-4).

SSRF in replication (PMASA-2017-6).

DOS in replication status (PMASA-2017-7).

Record
MGASA-2017-0038
Updated
2026-11-02
OSVopenSUSE-SU-2024:11171-1 No score

phpMyAdmin-5.1.1-1.2 on GA media

These are all security issues fixed in the phpMyAdmin-5.1.1-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11171-1
Updated
2026-11-02
OSVUSN-4779-1 No score

php-gettext vulnerability

Danilo Segan discovered that Gettext mishandled certain input. An attacker could use this vulnerability to execute arbitrary code.

Record
USN-4779-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php-gettext
Debian:12
before 1.0.12-0.1
1.0.12-0.1
php-gettext
Debian:14
before 1.0.12-0.1, plus listed versions
1.0.10-11.0.11-11.0.11-21.0.11-31.0.11-4
Show 10 moreShow less
1.0.7-11.0.7-21.0.7-31.0.7-41.0.7-51.0.7-61.0.7-71.0.7-81.0.9-11.0.9-2
1.0.12-0.1
phpmyadmin
Debian:12
before 4:4.6.6-1
4:4.6.6-1
phpmyadmin
Debian:13
before 4:4.6.6-1
4:4.6.6-1
phpmyadmin
Debian:14
before 4:4.6.6-1
4:4.6.6-1
phpmyadmin
Mageia:5
before 4.4.15.10-1.mga5
4.4.15.10-1.mga5
php-gettext
Ubuntu:Pro:14.04:LTS
before 1.0.11-1ubuntu0.1~esm1, plus listed versions
1.0.11-1
1.0.11-1ubuntu0.1~esm1
php-gettext
Ubuntu:Pro:16.04:LTS
before 1.0.11-2ubuntu0.1~esm1, plus listed versions
1.0.11-11.0.11-21.0.11-2build1
1.0.11-2ubuntu0.1~esm1
phpMyAdmin
openSUSE:Tumbleweed
before 5.1.1-1.2
5.1.1-1.2

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 49 moreShow less
MoveEnter Open