CVE-2015-9244
SQL Injection in mysql
Keys of objects in mysql node module v2.0.0-alpha7 and earlier are not escaped with mysql.escape() which could lead to SQL Injection.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Keys of objects in mysql node module v2.0.0-alpha7 and earlier are not escaped with mysql.escape() which could lead to SQL Injection.
- Record
CVE-2015-9244- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List No score
Keys of objects in mysql node module v2.0.0-alpha7 and earlier are not escaped with mysql.escape() which could lead to SQL Injection.
- Record
CVE-2015-9244- Weakness
- CWE-89
- Updated
- 2026-11-02
EUVDEUVD-2020-1033 No score
Keys of objects in mysql node module v2.0.0-alpha7 and earlier are not escaped with mysql.escape() which could lead to SQL Injection.
- Record
EUVD-2020-1033- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fvq6-55gv-jx9f No score
SQL Injection in mysql
Versions of mysql prior to 2.0.0-alpha8 are affected by a SQL Injection vulnerability in the mysql.escape() function, which does not properly escape object keys.
Recommendation
Update to version 2.0.0-alpha8 or later.
- Record
GHSA-fvq6-55gv-jx9f- Weakness
- CWE-89
- Updated
- 2026-11-02
OSV
9.8
Keys of objects in mysql node module v2.0.0-alpha7 and earlier are not escaped with mysql.escape() which could lead to SQL Injection.
- Record
CVE-2015-9244- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-9244
9.8
Keys of objects in mysql node module v2.0.0-alpha7 and earlier are not escaped with mysql.escape() which could lead to SQL Injection.
- Record
DEBIAN-CVE-2015-9244- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-9244
9.8
Keys of objects in mysql node module v2.0.0-alpha7 and earlier are not escaped with mysql.escape() which could lead to SQL Injection.
- Record
UBUNTU-CVE-2015-9244- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-fvq6-55gv-jx9f No score
SQL Injection in mysql
Versions of mysql prior to 2.0.0-alpha8 are affected by a SQL Injection vulnerability in the mysql.escape() function, which does not properly escape object keys.
Recommendation
Update to version 2.0.0-alpha8 or later.
- Record
GHSA-fvq6-55gv-jx9f- Weakness
- CWE-89
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mysqlnpm |
through 2.0.0-alpha7 | 2.0.0-alpha8 |
node-mysqlDebian:12 |
before 2.0.0~alpha8-1 | 2.0.0~alpha8-1 |
node-mysqlDebian:13 |
before 2.0.0~alpha8-1 | 2.0.0~alpha8-1 |
node-mysqlDebian:14 |
before 2.0.0~alpha8-1 | 2.0.0~alpha8-1 |
mysqlnpm |
before 2.0.0-alpha8 | 2.0.0-alpha8 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-9244 is a critical vulnerability (CVSS 9.8) in Hackerone Mysql Node Module, published May 29, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.44%, the 84th percentile. Fixed in mysql 2.0.0-alpha8.