CVE-2015-9267
Nullsoft Scriptable Install System (NSIS) before 2.49 uses temporary folder locations that allow...
CVE-2015-9267 is a medium vulnerability (CVSS 5.5) in Nullsoft Scriptable Install System, published October 1, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.39%, the 32nd percentile. Fixed in nsis 2.50-1.
Nullsoft Scriptable Install System (NSIS) before 2.49 uses temporary folder locations that allow unprivileged local users to overwrite files. This allows a local attack in which either a plugin or the uninstaller can be replaced by a Trojan horse program.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.5
Nullsoft Scriptable Install System (NSIS) before 2.49 uses temporary folder locations that allow unprivileged local users to overwrite files. This allows a local attack in which either a plugin or the uninstaller can be replaced by a Trojan horse program.
- Record
CVE-2015-9267- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 3.6 Low
AV:L/AC:L/Au:N/C:N/I:P/A:P - Weakness
- CWE-269
- Updated
- 2026-11-02
CVE List No score
Nullsoft Scriptable Install System (NSIS) before 2.49 uses temporary folder locations that allow unprivileged local users to overwrite files. This allows a local attack in which either a plugin or the uninstaller can be replaced by a Trojan horse program.
- Record
CVE-2015-9267- Updated
- 2026-11-02
EUVDEUVD-2015-9109 No score
Nullsoft Scriptable Install System (NSIS) before 2.49 uses temporary folder locations that allow unprivileged local users to overwrite files. This allows a local attack in which either a plugin or the uninstaller can be replaced by a Trojan horse program.
- Record
EUVD-2015-9109- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q9w8-9j2h-5cw2
5.5
Nullsoft Scriptable Install System (NSIS) before 2.49 uses temporary folder locations that allow...
Nullsoft Scriptable Install System (NSIS) before 2.49 uses temporary folder locations that allow unprivileged local users to overwrite files. This allows a local attack in which either a plugin or the uninstaller can be replaced by a Trojan horse program.
- Record
GHSA-q9w8-9j2h-5cw2- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-269
- Updated
- 2026-11-02
OSV
5.5
Nullsoft Scriptable Install System (NSIS) before 2.49 uses temporary folder locations that allow unprivileged local users to overwrite files. This allows a local attack in which either a plugin or the uninstaller can be replaced by a Trojan horse program.
- Record
CVE-2015-9267- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-9267
5.5
Nullsoft Scriptable Install System (NSIS) before 2.49 uses temporary folder locations that allow unprivileged local users to overwrite files. This allows a local attack in which either a plugin or the uninstaller can be replaced by a Trojan horse program.
- Record
DEBIAN-CVE-2015-9267- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-9267
5.5
Nullsoft Scriptable Install System (NSIS) before 2.49 uses temporary folder locations that allow unprivileged local users to overwrite files. This allows a local attack in which either a plugin or the uninstaller can be replaced by a Trojan horse program.
- Record
UBUNTU-CVE-2015-9267- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
nsisDebian:12 |
before 2.50-1 | 2.50-1 |
nsisDebian:13 |
before 2.50-1 | 2.50-1 |
nsisDebian:14 |
before 2.50-1 | 2.50-1 |
nsisDebian:8 |
before 2.46-10+deb8u1, plus listed versions 2.46-10 |
2.46-10+deb8u1 |
nsisUbuntu:Pro:14.04:LTS |
before 2.46-7ubuntu0.1~esm1, plus listed versions 2.46-7 |
2.46-7ubuntu0.1~esm1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
lists.debian.org/debian-lts-announce/2018/11/msg00041.html
sourceforge.net/p/nsis/bugs/1125
jvn.jp/en/jp/JVN68418039/index.html
nvd.nist.gov/vuln/detail/CVE-2015-9267
github.com/advisories/GHSA-q9w8-9j2h-5cw2
security-tracker.debian.org/tracker/CVE-2015-9267
ubuntu.com/security/CVE-2015-9267
cve.org/CVERecord?id=CVE-2015-9267