Every CVE Search/ Get API key

CVE-2016-0767

PostgreSQL PL/Java Improper Privilege Management

6.5 MediumFix available

CVE-2016-0767 is a medium vulnerability (CVSS 6.5) in Pl\/java Project Pl\/java, published June 6, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.93%, the 60th percentile. Fixed in postgresql:pljava-public 1.5.0.

PostgreSQL PL/Java before 1.5.0 allows remote authenticated users with USAGE permission on the public schema to alter the public schema classpath.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

0.93%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.5

PostgreSQL PL/Java before 1.5.0 allows remote authenticated users with USAGE permission on the public schema to alter the public schema classpath.

Record
CVE-2016-0767
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:P/A:N
Weakness
CWE-269
Updated
2026-11-02
CVE List No score

PostgreSQL PL/Java before 1.5.0 allows remote authenticated users with USAGE permission on the public schema to alter the public schema classpath.

Record
CVE-2016-0767
Updated
2026-11-02
EUVDEUVD-2022-3091 No score

PostgreSQL PL/Java before 1.5.0 allows remote authenticated users with USAGE permission on the public schema to alter the public schema classpath.

Record
EUVD-2022-3091
Updated
2026-11-03
GitHub AdvisoriesGHSA-837x-xww6-7jqm 6.5

PostgreSQL PL/Java Improper Privilege Management

PostgreSQL PL/Java before 1.5.0 allows remote authenticated users with USAGE permission on the public schema to alter the public schema classpath.

Record
GHSA-837x-xww6-7jqm
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-269
Updated
2026-11-02
OSV 6.5

PostgreSQL PL/Java before 1.5.0 allows remote authenticated users with USAGE permission on the public schema to alter the public schema classpath.

Record
CVE-2016-0767
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVGHSA-837x-xww6-7jqm 6.5

PostgreSQL PL/Java Improper Privilege Management

PostgreSQL PL/Java before 1.5.0 allows remote authenticated users with USAGE permission on the public schema to alter the public schema classpath.

Record
GHSA-837x-xww6-7jqm
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-269
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
postgresql:pljava-public
Maven
before 1.5.0
1.5.0
postgresql:pljava-public
Maven
before 1.5.0, plus listed versions
1.0.0b4
1.5.0

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open