Every CVE Search/ Get API key

CVE-2016-0785

Apache Struts RCE Vulnerability

8.8 HighFix available

Apache Struts 2.x before 2.3.28 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced double OGNL evaluation.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

8.88%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

Apache Struts 2.x before 2.3.28 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced double OGNL evaluation.

Record
CVE-2016-0785
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
9.0 HighAV:N/AC:L/Au:S/C:C/I:C/A:C
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Apache Struts 2.x before 2.3.28 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced double OGNL evaluation.

Record
CVE-2016-0785
Updated
2026-11-02
EUVDEUVD-2022-3133 No score

Apache Struts 2.x before 2.3.28 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced double OGNL evaluation.

Record
EUVD-2022-3133
Updated
2026-11-03
GitHub AdvisoriesGHSA-876p-4wgc-75rx 8.8

Apache Struts RCE Vulnerability

Apache Struts 2.x before 2.3.20.3, 2.3.24.3, and 2.3.28 allows remote attackers to execute arbitrary code via a %{} sequence in a tag attribute, aka forced double OGNL evaluation.

Record
GHSA-876p-4wgc-75rx
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 8.8

Apache Struts 2.x before 2.3.28 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced double OGNL evaluation.

Record
CVE-2016-0785
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-876p-4wgc-75rx 8.8

Apache Struts RCE Vulnerability

Apache Struts 2.x before 2.3.20.3, 2.3.24.3, and 2.3.28 allows remote attackers to execute arbitrary code via a %{} sequence in a tag attribute, aka forced double OGNL evaluation.

Record
GHSA-876p-4wgc-75rx
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.struts:struts2-core
Maven
2.0.0 up to 2.3.20.3
2.3.20.3
org.apache.struts:struts2-core
Maven
2.3.24 up to 2.3.24.3
2.3.24.3
org.apache.struts:struts2-core
Maven
2.0.0 up to 2.3.20.3, plus listed versions
2.0.112.0.11.12.0.11.22.0.122.0.14
Show 35 moreShow less
2.0.52.0.62.0.82.0.92.1.22.1.62.1.82.1.8.12.2.12.2.1.12.2.32.2.3.12.3.12.3.1.12.3.1.22.3.122.3.142.3.14.12.3.14.22.3.14.32.3.152.3.15.12.3.15.22.3.15.32.3.162.3.16.12.3.16.22.3.16.32.3.202.3.20.12.3.32.3.42.3.4.12.3.72.3.8
2.3.20.3
org.apache.struts:struts2-core
Maven
2.3.24 up to 2.3.24.3, plus listed versions
2.3.24.1
2.3.24.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-0785 is a high vulnerability (CVSS 8.8) in Apache Struts, published April 12, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 8.88%, the 95th percentile. Fixed in org.apache.struts:struts2-core 2.3.20.3.

References

MoveEnter Open