Every CVE Search/ Get API key

CVE-2016-1000104

A security Bypass vulnerability exists in mod_fcgid through 2016-07-07 in the FcgidPassHeader Proxy.

8.8 HighFix available

A security Bypass vulnerability exists in the FcgidPassHeader Proxy in mod_fcgid through 2016-07-07.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.23%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

A security Bypass vulnerability exists in the FcgidPassHeader Proxy in mod_fcgid through 2016-07-07.

Record
CVE-2016-1000104
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

A security Bypass vulnerability exists in the FcgidPassHeader Proxy in mod_fcgid through 2016-07-07.

Record
CVE-2016-1000104
Updated
2026-11-02
EUVDEUVD-2016-1049 No score

A security Bypass vulnerability exists in the FcgidPassHeader Proxy in mod_fcgid through 2016-07-07.

Record
EUVD-2016-1049
Updated
2026-11-03
GitHub AdvisoriesGHSA-3qww-55h8-4xjp 8.8

A security Bypass vulnerability exists in mod_fcgid through 2016-07-07 in the FcgidPassHeader Proxy.

A security Bypass vulnerability exists in mod_fcgid through 2016-07-07 in the FcgidPassHeader Proxy.

Record
GHSA-3qww-55h8-4xjp
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVAZL-36963 8.8

CVE-2016-1000104 affecting package mod_fcgid 2.3.9-21

A security Bypass vulnerability exists in the FcgidPassHeader Proxy in mod_fcgid through 2016-07-07.

Record
AZL-36963
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-05
OSVAZL-7290 8.8

CVE-2016-1000104 affecting package mod_fcgid 2.3.9-21

A security Bypass vulnerability exists in the FcgidPassHeader Proxy in mod_fcgid through 2016-07-07.

Record
AZL-7290
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVOESA-2022-1758 8.8

mod_fcgid security update

Mod_fcgid is an Apache module providing a FastCGI interface. It's an alternative to mod_fastcgi that is specifically tuned for the dynamic FastCGI configuration used on DreamHost servers.

Security Fix(es):

A security Bypass vulnerability exists in the FcgidPassHeader Proxy in mod_fcgid through 2016-07-07.(CVE-2016-1000104)

Record
OESA-2022-1758
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-1000104 8.8

A security Bypass vulnerability exists in the FcgidPassHeader Proxy in mod_fcgid through 2016-07-07.

Record
UBUNTU-CVE-2016-1000104
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2017-0203 No score

Updated apache-mod_fcgid packages fix security vulnerability

A remote attacker could have set the HTTP_PROXY environment variable of CGI scripts (CVE-2016-1000104).

Record
MGASA-2017-0203
Updated
2026-11-02
OSVopenSUSE-SU-2024:10564-1 No score

apache2-mod_fcgid-2.3.9-7.3 on GA media

These are all security issues fixed in the apache2-mod_fcgid-2.3.9-7.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10564-1
Updated
2026-11-02
OSVSUSE-SU-2016:1820-1 No score

Security update for apache2-mod_fcgid

This update for apache2-mod_fcgid fixes the following issues:

  • It used to be possible to set an arbitrary $HTTP_PROXY environment variable for request handlers -- like CGI scripts -- by including a specially crafted HTTP header in the request (CVE-2016-1000104). As a result, these server components would potentially direct all their outgoing HTTP traffic through a malicious proxy server. This patch fixes the issue: the updated Apache server ignores such HTTP headers and never sets $HTTP_PROXY for sub-processes (unless a value has been explicitly configured by the administrator in the configuration file). (bsc#988492)
Record
SUSE-SU-2016:1820-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mod_fcgid
Azure Linux:3
through 2.3.9-21 None known
mod_fcgid
Azure Linux:2
through 2.3.9-21 None known
apache-mod_fcgid
Mageia:5
before 2.3.9-4.1.mga5
2.3.9-4.1.mga5
mod_fcgid
openEuler:20.03-LTS-SP1
before 2.3.9-20.oe1
2.3.9-20.oe1
mod_fcgid
openEuler:20.03-LTS-SP3
before 2.3.9-20.oe1
2.3.9-20.oe1
mod_fcgid
openEuler:22.03-LTS
before 2.3.9-21.oe2203
2.3.9-21.oe2203
apache2-mod_fcgid
SUSE:Linux Enterprise Software Development Kit 11 SP4
before 2.2-31.29.1
2.2-31.29.1
libapache2-mod-fcgid
Ubuntu:16.04:LTS
All versions, plus listed versions
1:2.3.9-1
None known
libapache2-mod-fcgid
Ubuntu:18.04:LTS
All versions, plus listed versions
1:2.3.9-1
None known
libapache2-mod-fcgid
Ubuntu:20.04:LTS
All versions, plus listed versions
1:2.3.9-4
None known
Show 6 moreShow less
Affected packages
PackageAffectedFixed
libapache2-mod-fcgid
Ubuntu:22.04:LTS
All versions, plus listed versions
1:2.3.9-4
None known
libapache2-mod-fcgid
Ubuntu:24.04:LTS
All versions, plus listed versions
1:2.3.9-4
None known
libapache2-mod-fcgid
Ubuntu:25.10
All versions, plus listed versions
1:2.3.9-4
None known
libapache2-mod-fcgid
Ubuntu:26.10
All versions, plus listed versions
1:2.3.9-4build1
None known
libapache2-mod-fcgid
Ubuntu:26.04:LTS
All versions, plus listed versions
1:2.3.9-41:2.3.9-4build1
None known
apache2-mod_fcgid
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 2.3.9-7.3
2.3.9-7.3

History

History
RecordedChangedSources
affected
factsOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-1000104 is a high vulnerability (CVSS 8.8) in Apache Mod Fcgid, published July 18, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.23%, the 82nd percentile. Fixed in apache-mod_fcgid 2.3.9-4.1.mga5.

References

Show 15 moreShow less
MoveEnter Open