Every CVE Search/ Get API key

CVE-2016-1000221

Logstash Logs Sensitive Information

7.5 HighFix available

Logstash prior to version 2.3.4, Elasticsearch Output plugin would log to file HTTP authorization headers which could contain sensitive information.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.78%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Logstash prior to version 2.3.4, Elasticsearch Output plugin would log to file HTTP authorization headers which could contain sensitive information.

Record
CVE-2016-1000221
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
CVE List No score

Logstash prior to version 2.3.4, Elasticsearch Output plugin would log to file HTTP authorization headers which could contain sensitive information.

Record
CVE-2016-1000221
Updated
2026-11-02
EUVDEUVD-2022-5343 No score

Logstash prior to version 2.3.4, Elasticsearch Output plugin would log to file HTTP authorization headers which could contain sensitive information.

Record
EUVD-2022-5343
Updated
2026-11-03
GitHub AdvisoriesGHSA-vcmm-ppqx-95ch 7.5

Logstash Logs Sensitive Information

Logstash prior to version 2.3.4, Elasticsearch Output plugin would log to file HTTP authorization headers which could contain sensitive information.

Record
GHSA-vcmm-ppqx-95ch
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSV 7.5

Logstash prior to version 2.3.4, Elasticsearch Output plugin would log to file HTTP authorization headers which could contain sensitive information.

Record
CVE-2016-1000221
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVGHSA-vcmm-ppqx-95ch 7.5

Logstash Logs Sensitive Information

Logstash prior to version 2.3.4, Elasticsearch Output plugin would log to file HTTP authorization headers which could contain sensitive information.

Record
GHSA-vcmm-ppqx-95ch
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
logstash-core
RubyGems
before 2.3.4
2.3.4
logstash-core
RubyGems
before 2.3.4, plus listed versions
1.5.01.5.0.beta21.5.0.rc11.5.0.rc1.11.5.0.rc2
Show 45 moreShow less
1.5.0.rc2.snapshot1.5.0.rc31.5.0.rc3.snapshot11.5.0.rc3.snapshot21.5.0.rc3.snapshot31.5.0.rc3.snapshot41.5.0.rc3.snapshot51.5.0.rc3.snapshot61.5.0.rc41.5.0.rc4.snapshot11.5.0.rc4.snapshot21.5.0.snapshot11.5.11.5.1.snapshot11.5.21.5.2.11.5.2.21.5.2.snapshot11.5.2.snapshot21.5.31.5.3.snapshot11.5.3.snapshot21.5.41.5.4.snapshot11.5.4.snapshot21.5.4.snapshot31.5.51.5.62.0.02.0.0.beta12.0.0.beta22.0.0.beta32.0.0.rc12.0.12.0.1.snapshot12.1.02.1.0.snapshot12.1.0.snapshot22.1.0.snapshot32.1.0.snapshot42.1.12.1.22.1.2.snapshot12.1.32.2.0
2.3.4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-1000221 is a high vulnerability (CVSS 7.5) in Elastic Logstash, published June 16, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.78%, the 78th percentile. Fixed in logstash-core 2.3.4.

References

This page doesn't list everything

Left out here: 23 versions. The JSON record has them.

MoveEnter Open