CVE-2016-1000237
Cross-Site Scripting in sanitize-html
CVE-2016-1000237 is a medium vulnerability (CVSS 6.1) in Apostrophecms Sanitize-html, published January 23, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.84%, the 57th percentile. Fixed in sanitize-html 1.4.3.
sanitize-html before 1.4.3 has XSS.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
sanitize-html before 1.4.3 has XSS.
- Record
CVE-2016-1000237- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
sanitize-html before 1.4.3 has XSS.
- Record
CVE-2016-1000237- Updated
- 2026-11-02
EUVDEUVD-2020-0361 No score
sanitize-html before 1.4.3 has XSS.
- Record
EUVD-2020-0361- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3j7m-hmh3-9jmp
6.1
Cross-Site Scripting in sanitize-html
Affected versions of sanitize-html do not sanitize input recursively, which may allow an attacker to execute arbitrary Javascript.
Recommendation
Update to version 1.4.3 or later.
- Record
GHSA-3j7m-hmh3-9jmp- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-3j7m-hmh3-9jmp
6.1
Cross-Site Scripting in sanitize-html
Affected versions of sanitize-html do not sanitize input recursively, which may allow an attacker to execute arbitrary Javascript.
Recommendation
Update to version 1.4.3 or later.
- Record
GHSA-3j7m-hmh3-9jmp- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVROOT-APP-NPM-CVE-2016-1000237 No score
CVE-2016-1000237 in @rootio/sanitize-html - Patched by Root
Root has patched CVE-2016-1000237 in the @rootio/sanitize-html package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-CVE-2016-1000237- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
sanitize-htmlnpm |
before 1.4.3 | 1.4.3 |
@rootio/sanitize-htmlRoot:npm |
before 1.4.2-root.io.4 | 1.4.2-root.io.41.4.2-root.io.51.4.2-root.io.61.4.2-root.io.71.4.2-root.io.81.4.2-root.io.9 |
sanitize-htmlRoot:npm |
before 1.4.2-aikido.9 | 1.4.2-aikido.9 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
raw.githubusercontent.com/distributedweaknessfiling/cvelist/master/2016/1000xxx/CVE-2016-1000237.json
nodesecurity.io/advisories/135
nvd.nist.gov/vuln/detail/CVE-2016-1000237
github.com/apostrophecms/sanitize-html/issues/29
github.com/apostrophecms/sanitize-html/commit/762fbc7bba389f3f789cc291c1eb2b64f60f2caf
github.com/punkave/sanitize-html/issues/29
npmjs.com/advisories/135
github.com/advisories/GHSA-3j7m-hmh3-9jmp