CVE-2016-1000242
Denial of Service in mqtt
Affected versions of mqtt will cause the node process to crash when receiving specially crafted MQTT packets, making the application vulnerable to a denial of service condition.
Recommendation
Update to v1.0.0 or later
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
What each source reports
GitHub Advisories Score usedGHSA-hg78-c92r-hvwr
7.5
Denial of Service in mqtt
Affected versions of mqtt will cause the node process to crash when receiving specially crafted MQTT packets, making the application vulnerable to a denial of service condition.
Recommendation
Update to v1.0.0 or later
- Record
GHSA-hg78-c92r-hvwr- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-248
- Updated
- 2026-11-02
OSVGHSA-hg78-c92r-hvwr
7.5
Denial of Service in mqtt
Affected versions of mqtt will cause the node process to crash when receiving specially crafted MQTT packets, making the application vulnerable to a denial of service condition.
Recommendation
Update to v1.0.0 or later
- Record
GHSA-hg78-c92r-hvwr- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-248
- Updated
- 2026-11-02
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | GitHub Advisories, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-1000242 is a high vulnerability (CVSS 7.5) in mqtt, published September 1, 2020. No source lists public exploit code. Fixed in mqtt 1.0.0.