Every CVE Search/ Get API key

CVE-2016-10006

OWASP AntiSamy vulnerable to Cross-site Scripting

6.1 MediumPublic exploitFix available

In OWASP AntiSamy before 1.5.5, by submitting a specially crafted input (a tag that supports style with active content), you could bypass the library protections and supply executable code. The impact is XSS.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

2.35%Up 1.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

In OWASP AntiSamy before 1.5.5, by submitting a specially crafted input (a tag that supports style with active content), you could bypass the library protections and supply executable code. The impact is XSS.

Record
CVE-2016-10006
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

In OWASP AntiSamy before 1.5.5, by submitting a specially crafted input (a tag that supports style with active content), you could bypass the library protections and supply executable code. The impact is XSS.

Record
CVE-2016-10006
Updated
2026-11-02
EUVDEUVD-2018-0515 No score

In OWASP AntiSamy before 1.5.5, by submitting a specially crafted input (a tag that supports style with active content), you could bypass the library protections and supply executable code. The impact is XSS.

Record
EUVD-2018-0515
Updated
2026-11-03
GitHub AdvisoriesGHSA-683w-6h9j-57wq 6.1

OWASP AntiSamy vulnerable to Cross-site Scripting

In OWASP AntiSamy before 1.5.5, by submitting a specially crafted input (a tag that supports style with active content), you could bypass the library protections and supply executable code. The impact is XSS.

Record
GHSA-683w-6h9j-57wq
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

In OWASP AntiSamy before 1.5.5, by submitting a specially crafted input (a tag that supports style with active content), you could bypass the library protections and supply executable code. The impact is XSS.

Record
CVE-2016-10006
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2016-10006 6.1

In OWASP AntiSamy before 1.5.5, by submitting a specially crafted input (a tag that supports style with active content), you could bypass the library protections and supply executable code. The impact is XSS.

Record
DEBIAN-CVE-2016-10006
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-683w-6h9j-57wq 6.1

OWASP AntiSamy vulnerable to Cross-site Scripting

In OWASP AntiSamy before 1.5.5, by submitting a specially crafted input (a tag that supports style with active content), you could bypass the library protections and supply executable code. The impact is XSS.

Record
GHSA-683w-6h9j-57wq
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2016-10006 6.1

In OWASP AntiSamy before 1.5.5, by submitting a specially crafted input (a tag that supports style with active content), you could bypass the library protections and supply executable code. The impact is XSS.

Record
UBUNTU-CVE-2016-10006
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.owasp.antisamy:antisamy
Maven
before 1.5.5
1.5.5
libowasp-antisamy-java
Debian:12
All versions, plus listed versions
1.5.3+dfsg-1.11.7.4-1
None known
libowasp-antisamy-java
Debian:13
before 1.7.4-1
1.7.4-1
libowasp-antisamy-java
Debian:14
before 1.7.4-1
1.7.4-1
org.owasp.antisamy:antisamy
Maven
before 1.5.5, plus listed versions
1.4.21.4.31.4.41.4.51.51.5.11.5.21.5.3
1.5.5
libowasp-antisamy-java
Ubuntu:16.04:LTS
All versions, plus listed versions
1.5.3+dfsg-1
None known
libowasp-antisamy-java
Ubuntu:18.04:LTS
All versions, plus listed versions
1.5.3+dfsg-1
None known
libowasp-antisamy-java
Ubuntu:20.04:LTS
All versions, plus listed versions
1.5.3+dfsg-1
None known
libowasp-antisamy-java
Ubuntu:22.04:LTS
All versions, plus listed versions
1.5.3+dfsg-1.1
None known
libowasp-antisamy-java
Ubuntu:24.04:LTS
All versions, plus listed versions
1.5.3+dfsg-1.11.7.4-1
None known
libowasp-antisamy-java
Ubuntu:25.10
All versions, plus listed versions
1.7.4-1
None known
libowasp-antisamy-java
Ubuntu:26.10
All versions, plus listed versions
1.7.4-1
None known
libowasp-antisamy-java
Ubuntu:26.04:LTS
All versions, plus listed versions
1.7.4-1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubepicosy/VUL4J-602024-05-31
PoC in GitHubshoucheng3/nahsra__antisamy_CVE-2016-10006_1-5-32025-08-18

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-10006 is a medium vulnerability (CVSS 6.1) in Antisamy Project Antisamy, published December 24, 2016. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 2.35%, the 83rd percentile. Fixed in org.owasp.antisamy:antisamy 1.5.5.

References

Show 5 moreShow less
MoveEnter Open