CVE-2016-10131
CodeIgniter arbitrary code execution
CVE-2016-10131 is a critical vulnerability (CVSS 9.8) in Codeigniter, published January 12, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.11%, the 87th percentile. Fixed in bcit-ci/codeigniter 3.1.3.
system/libraries/Email.php in CodeIgniter before 3.1.3 allows remote attackers to execute arbitrary code by leveraging control over the email->from field to insert sendmail command-line arguments.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
system/libraries/Email.php in CodeIgniter before 3.1.3 allows remote attackers to execute arbitrary code by leveraging control over the email->from field to insert sendmail command-line arguments.
- Record
CVE-2016-10131- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-74
- Updated
- 2026-11-02
CVE List No score
system/libraries/Email.php in CodeIgniter before 3.1.3 allows remote attackers to execute arbitrary code by leveraging control over the email->from field to insert sendmail command-line arguments.
- Record
CVE-2016-10131- Updated
- 2026-11-02
EUVDEUVD-2022-2023 No score
system/libraries/Email.php in CodeIgniter before 3.1.3 allows remote attackers to execute arbitrary code by leveraging control over the email->from field to insert sendmail command-line arguments.
- Record
EUVD-2022-2023- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2pcj-76hj-xqhm
9.8
CodeIgniter arbitrary code execution
system/libraries/Email.php in CodeIgniter before 3.1.3 allows remote attackers to execute arbitrary code by leveraging control over the email->from field to insert sendmail command-line arguments.
- Record
GHSA-2pcj-76hj-xqhm- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-74
- Updated
- 2026-11-02
OSV
9.8
system/libraries/Email.php in CodeIgniter before 3.1.3 allows remote attackers to execute arbitrary code by leveraging control over the email->from field to insert sendmail command-line arguments.
- Record
CVE-2016-10131- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-2pcj-76hj-xqhm
9.8
CodeIgniter arbitrary code execution
system/libraries/Email.php in CodeIgniter before 3.1.3 allows remote attackers to execute arbitrary code by leveraging control over the email->from field to insert sendmail command-line arguments.
- Record
GHSA-2pcj-76hj-xqhm- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-74
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
bcit-ci/codeigniterPackagist |
before 3.1.3 | 3.1.3 |
bcit-ci/codeigniterPackagist |
before 3.1.3, plus listed versions 3.0.03.0.13.0.1rc3.0.1rc23.0.2 Show 10 moreShow less3.0.33.0.43.0.53.0.63.0rc3.0rc23.0rc33.1.03.1.13.1.2 |
3.1.3 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |