Every CVE Search/ Get API key

CVE-2016-10142

An issue was discovered in the IPv6 protocol specification, related to ICMP Packet Too Big (PTB)...

8.6 HighFix available

CVE-2016-10142 is a high vulnerability (CVSS 8.6) in Ietf Ipv6, published January 14, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.80%, the 86th percentile. Fixed in kernel-debug-debuginfo 0:2.6.32-696.el6.

An issue was discovered in the IPv6 protocol specification, related to ICMP Packet Too Big (PTB) messages. (The scope of this CVE is all affected IPv6 implementations from all vendors.) The security implications of IP fragmentation have been discussed at length in [RFC6274] and [RFC7739]. An attacker can leverage the generation of IPv6 atomic fragments to trigger the use of fragmentation in an arbitrary IPv6 flow (in scenarios in which actual fragmentation of packets is not needed) and can subsequently perform any type of fragmentation-based attack against legacy IPv6 nodes that do not implement [RFC6946]. That is, employing fragmentation where not actually needed allows for fragmentation-based attack vectors to be employed, unnecessarily. We note that, unfortunately, even nodes that already implement [RFC6946] can be subject to DoS attacks as a result of the generation of IPv6 atomic fragments. Let us assume that Host A is communicating with Host B and that, as a result of the widespread dropping of IPv6 packets that contain extension headers (including fragmentation) [RFC7872], some intermediate node filters fragments between Host B and Host A. If an attacker sends a forged ICMPv6 PTB error message to Host B, reporting an MTU smaller than 1280, this will trigger the generation of IPv6 atomic fragments from that moment on (as required by [RFC2460]). When Host B starts sending IPv6 atomic fragments (in response to the received ICMPv6 PTB error message), these packets will be dropped, since we previously noted that IPv6 packets with extension headers were being dropped between Host B and Host A. Thus, this situation will result in a DoS scenario. Another possible scenario is that in which two BGP peers are employing IPv6 transport and they implement Access Control Lists (ACLs) to drop IPv6 fragments (to avoid control-plane attacks). If the aforementioned BGP peers drop IPv6 fragments but still honor received ICMPv6 PTB error messages, an attacker could easily attack the corresponding peering session by simply sending an ICMPv6 PTB message with a reported MTU smaller than 1280 bytes. Once the attack packet has been sent, the aforementioned routers will themselves be the ones dropping their own traffic.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.80%Up 1.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.6

An issue was discovered in the IPv6 protocol specification, related to ICMP Packet Too Big (PTB) messages. (The scope of this CVE is all affected IPv6 implementations from all vendors.) The security implications of IP fragmentation have been discussed at length in [RFC6274] and [RFC7739]. An attacker can leverage the generation of IPv6 atomic fragments to trigger the use of fragmentation in an arbitrary IPv6 flow (in scenarios in which actual fragmentation of packets is not needed) and can subsequently perform any type of fragmentation-based attack against legacy IPv6 nodes that do not implement [RFC6946]. That is, employing fragmentation where not actually needed allows for fragmentation-based attack vectors to be employed, unnecessarily. We note that, unfortunately, even nodes that already implement [RFC6946] can be subject to DoS attacks as a result of the generation of IPv6 atomic fragments. Let us assume that Host A is communicating with Host B and that, as a result of the widespread dropping of IPv6 packets that contain extension headers (including fragmentation) [RFC7872], some intermediate node filters fragments between Host B and Host A. If an attacker sends a forged ICMPv6 PTB error message to Host B, reporting an MTU smaller than 1280, this will trigger the generation of IPv6 atomic fragments from that moment on (as required by [RFC2460]). When Host B starts sending IPv6 atomic fragments (in response to the received ICMPv6 PTB error message), these packets will be dropped, since we previously noted that IPv6 packets with extension headers were being dropped between Host B and Host A. Thus, this situation will result in a DoS scenario. Another possible scenario is that in which two BGP peers are employing IPv6 transport and they implement Access Control Lists (ACLs) to drop IPv6 fragments (to avoid control-plane attacks). If the aforementioned BGP peers drop IPv6 fragments but still honor received ICMPv6 PTB error messages, an attacker could easily attack the corresponding peering session by simply sending an ICMPv6 PTB message with a reported MTU smaller than 1280 bytes. Once the attack packet has been sent, the aforementioned routers will themselves be the ones dropping their own traffic.

Record
CVE-2016-10142
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-17
Updated
2026-11-02
CVE List No score

An issue was discovered in the IPv6 protocol specification, related to ICMP Packet Too Big (PTB) messages. (The scope of this CVE is all affected IPv6 implementations from all vendors.) The security implications of IP fragmentation have been discussed at length in [RFC6274] and [RFC7739]. An attacker can leverage the generation of IPv6 atomic fragments to trigger the use of fragmentation in an arbitrary IPv6 flow (in scenarios in which actual fragmentation of packets is not needed) and can subsequently perform any type of fragmentation-based attack against legacy IPv6 nodes that do not implement [RFC6946]. That is, employing fragmentation where not actually needed allows for fragmentation-based attack vectors to be employed, unnecessarily. We note that, unfortunately, even nodes that already implement [RFC6946] can be subject to DoS attacks as a result of the generation of IPv6 atomic fragments. Let us assume that Host A is communicating with Host B and that, as a result of the widespread dropping of IPv6 packets that contain extension headers (including fragmentation) [RFC7872], some intermediate node filters fragments between Host B and Host A. If an attacker sends a forged ICMPv6 PTB error message to Host B, reporting an MTU smaller than 1280, this will trigger the generation of IPv6 atomic fragments from that moment on (as required by [RFC2460]). When Host B starts sending IPv6 atomic fragments (in response to the received ICMPv6 PTB error message), these packets will be dropped, since we previously noted that IPv6 packets with extension headers were being dropped between Host B and Host A. Thus, this situation will result in a DoS scenario. Another possible scenario is that in which two BGP peers are employing IPv6 transport and they implement Access Control Lists (ACLs) to drop IPv6 fragments (to avoid control-plane attacks). If the aforementioned BGP peers drop IPv6 fragments but still honor received ICMPv6 PTB error messages, an attacker could easily attack the corresponding peering session by simply sending an ICMPv6 PTB message with a reported MTU smaller than 1280 bytes. Once the attack packet has been sent, the aforementioned routers will themselves be the ones dropping their own traffic.

Record
CVE-2016-10142
Updated
2026-11-02
EUVDEUVD-2016-1331 No score

An issue was discovered in the IPv6 protocol specification, related to ICMP Packet Too Big (PTB) messages. (The scope of this CVE is all affected IPv6 implementations from all vendors.) The security implications of IP fragmentation have been discussed at length in [RFC6274] and [RFC7739]. An attacker can leverage the generation of IPv6 atomic fragments to trigger the use of fragmentation in an arbitrary IPv6 flow (in scenarios in which actual fragmentation of packets is not needed) and can subsequently perform any type of fragmentation-based attack against legacy IPv6 nodes that do not implement [RFC6946]. That is, employing fragmentation where not actually needed allows for fragmentation-based attack vectors to be employed, unnecessarily. We note that, unfortunately, even nodes that already implement [RFC6946] can be subject to DoS attacks as a result of the generation of IPv6 atomic fragments. Let us assume that Host A is communicating with Host B and that, as a result of the widespread dropping of IPv6 packets that contain extension headers (including fragmentation) [RFC7872], some intermediate node filters fragments between Host B and Host A. If an attacker sends a forged ICMPv6 PTB error message to Host B, reporting an MTU smaller than 1280, this will trigger the generation of IPv6 atomic fragments from that moment on (as required by [RFC2460]). When Host B starts sending IPv6 atomic fragments (in response to the received ICMPv6 PTB error message), these packets will be dropped, since we previously noted that IPv6 packets with extension headers were being dropped between Host B and Host A. Thus, this situation will result in a DoS scenario. Another possible scenario is that in which two BGP peers are employing IPv6 transport and they implement Access Control Lists (ACLs) to drop IPv6 fragments (to avoid control-plane attacks). If the aforementioned BGP peers drop IPv6 fragments but still honor received ICMPv6 PTB error messages, an attacker could easily attack the corresponding peering session by simply sending an ICMPv6 PTB message with a reported MTU smaller than 1280 bytes. Once the attack packet has been sent, the aforementioned routers will themselves be the ones dropping their own traffic.

Record
EUVD-2016-1331
Updated
2026-11-03
GitHub AdvisoriesGHSA-4jqq-7wwq-485f 8.6

An issue was discovered in the IPv6 protocol specification, related to ICMP Packet Too Big (PTB)...

An issue was discovered in the IPv6 protocol specification, related to ICMP Packet Too Big (PTB) messages. (The scope of this CVE is all affected IPv6 implementations from all vendors.) The security implications of IP fragmentation have been discussed at length in [RFC6274] and [RFC7739]. An attacker can leverage the generation of IPv6 atomic fragments to trigger the use of fragmentation in an arbitrary IPv6 flow (in scenarios in which actual fragmentation of packets is not needed) and can subsequently perform any type of fragmentation-based attack against legacy IPv6 nodes that do not implement [RFC6946]. That is, employing fragmentation where not actually needed allows for fragmentation-based attack vectors to be employed, unnecessarily. We note that, unfortunately, even nodes that already implement [RFC6946] can be subject to DoS attacks as a result of the generation of IPv6 atomic fragments. Let us assume that Host A is communicating with Host B and that, as a result of the widespread dropping of IPv6 packets that contain extension headers (including fragmentation) [RFC7872], some intermediate node filters fragments between Host B and Host A. If an attacker sends a forged ICMPv6 PTB error message to Host B, reporting an MTU smaller than 1280, this will trigger the generation of IPv6 atomic fragments from that moment on (as required by [RFC2460]). When Host B starts sending IPv6 atomic fragments (in response to the received ICMPv6 PTB error message), these packets will be dropped, since we previously noted that IPv6 packets with extension headers were being dropped between Host B and Host A. Thus, this situation will result in a DoS scenario. Another possible scenario is that in which two BGP peers are employing IPv6 transport and they implement Access Control Lists (ACLs) to drop IPv6 fragments (to avoid control-plane attacks). If the aforementioned BGP peers drop IPv6 fragments but still honor received ICMPv6 PTB error messages, an attacker could easily attack the corresponding peering session by simply sending an ICMPv6 PTB message with a reported MTU smaller than 1280 bytes. Once the attack packet has been sent, the aforementioned routers will themselves be the ones dropping their own traffic.

Record
GHSA-4jqq-7wwq-485f
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
Updated
2026-11-02
OSVBELL-CVE-2016-10142 8.6

CVE-2016-10142 does not affect BellSoft software

Record
BELL-CVE-2016-10142
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
Updated
2026-11-02
OSVRHSA-2017:0817 7.8

Red Hat Security Advisory: kernel security, bug fix, and enhancement update

Record
RHSA-2017:0817
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-10142 8.6

An issue was discovered in the IPv6 protocol specification, related to ICMP Packet Too Big (PTB) messages. (The scope of this CVE is all affected IPv6 implementations from all vendors.) The security implications of IP fragmentation have been discussed at length in [RFC6274] and [RFC7739]. An attacker can leverage the generation of IPv6 atomic fragments to trigger the use of fragmentation in an arbitrary IPv6 flow (in scenarios in which actual fragmentation of packets is not needed) and can subsequently perform any type of fragmentation-based attack against legacy IPv6 nodes that do not implement [RFC6946]. That is, employing fragmentation where not actually needed allows for fragmentation-based attack vectors to be employed, unnecessarily. We note that, unfortunately, even nodes that already implement [RFC6946] can be subject to DoS attacks as a result of the generation of IPv6 atomic fragments. Let us assume that Host A is communicating with Host B and that, as a result of the widespread dropping of IPv6 packets that contain extension headers (including fragmentation) [RFC7872], some intermediate node filters fragments between Host B and Host A. If an attacker sends a forged ICMPv6 PTB error message to Host B, reporting an MTU smaller than 1280, this will trigger the generation of IPv6 atomic fragments from that moment on (as required by [RFC2460]). When Host B starts sending IPv6 atomic fragments (in response to the received ICMPv6 PTB error message), these packets will be dropped, since we previously noted that IPv6 packets with extension headers were being dropped between Host B and Host A. Thus, this situation will result in a DoS scenario. Another possible scenario is that in which two BGP peers are employing IPv6 transport and they implement Access Control Lists (ACLs) to drop IPv6 fragments (to avoid control-plane attacks). If the aforementioned BGP peers drop IPv6 fragments but still honor received ICMPv6 PTB error messages, an attacker could easily attack the corresponding peering session by simply sending an ICMPv6 PTB message with a reported MTU smaller than 1280 bytes. Once the attack packet has been sent, the aforementioned routers will themselves be the ones dropping their own traffic.

Record
UBUNTU-CVE-2016-10142
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
kernel-debug-debuginfo
Red Hat:enterprise_linux:6::client
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debuginfo
Red Hat:enterprise_linux:6::client
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debuginfo-common-i686
Red Hat:enterprise_linux:6::client
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debuginfo-common-x86_64
Red Hat:enterprise_linux:6::client
before 0:2.6.32-696.el6
0:2.6.32-696.el6
perf-debuginfo
Red Hat:enterprise_linux:6::client
before 0:2.6.32-696.el6
0:2.6.32-696.el6
python-perf
Red Hat:enterprise_linux:6::client
before 0:2.6.32-696.el6
0:2.6.32-696.el6
python-perf-debuginfo
Red Hat:enterprise_linux:6::client
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel
Red Hat:enterprise_linux:6::client
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-abi-whitelists
Red Hat:enterprise_linux:6::client
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debug
Red Hat:enterprise_linux:6::client
before 0:2.6.32-696.el6
0:2.6.32-696.el6
Show 81 moreShow less
Affected packages
PackageAffectedFixed
kernel-debug-devel
Red Hat:enterprise_linux:6::client
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-devel
Red Hat:enterprise_linux:6::client
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-doc
Red Hat:enterprise_linux:6::client
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-firmware
Red Hat:enterprise_linux:6::client
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-headers
Red Hat:enterprise_linux:6::client
before 0:2.6.32-696.el6
0:2.6.32-696.el6
perf
Red Hat:enterprise_linux:6::client
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debug-debuginfo
Red Hat:enterprise_linux:6::computenode
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debuginfo
Red Hat:enterprise_linux:6::computenode
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debuginfo-common-x86_64
Red Hat:enterprise_linux:6::computenode
before 0:2.6.32-696.el6
0:2.6.32-696.el6
perf-debuginfo
Red Hat:enterprise_linux:6::computenode
before 0:2.6.32-696.el6
0:2.6.32-696.el6
python-perf
Red Hat:enterprise_linux:6::computenode
before 0:2.6.32-696.el6
0:2.6.32-696.el6
python-perf-debuginfo
Red Hat:enterprise_linux:6::computenode
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel
Red Hat:enterprise_linux:6::computenode
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-abi-whitelists
Red Hat:enterprise_linux:6::computenode
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debug
Red Hat:enterprise_linux:6::computenode
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debug-devel
Red Hat:enterprise_linux:6::computenode
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debuginfo-common-i686
Red Hat:enterprise_linux:6::computenode
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-devel
Red Hat:enterprise_linux:6::computenode
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-doc
Red Hat:enterprise_linux:6::computenode
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-firmware
Red Hat:enterprise_linux:6::computenode
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-headers
Red Hat:enterprise_linux:6::computenode
before 0:2.6.32-696.el6
0:2.6.32-696.el6
perf
Red Hat:enterprise_linux:6::computenode
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debug-debuginfo
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debuginfo
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debuginfo-common-i686
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debuginfo-common-ppc64
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debuginfo-common-s390x
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debuginfo-common-x86_64
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-kdump-debuginfo
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
perf-debuginfo
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
python-perf
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
python-perf-debuginfo
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-abi-whitelists
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-bootwrapper
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debug
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debug-devel
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-devel
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-doc
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-firmware
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-headers
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-kdump
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-kdump-devel
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
perf
Red Hat:enterprise_linux:6::server
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debug-debuginfo
Red Hat:enterprise_linux:6::workstation
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debuginfo
Red Hat:enterprise_linux:6::workstation
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debuginfo-common-i686
Red Hat:enterprise_linux:6::workstation
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debuginfo-common-x86_64
Red Hat:enterprise_linux:6::workstation
before 0:2.6.32-696.el6
0:2.6.32-696.el6
perf-debuginfo
Red Hat:enterprise_linux:6::workstation
before 0:2.6.32-696.el6
0:2.6.32-696.el6
python-perf
Red Hat:enterprise_linux:6::workstation
before 0:2.6.32-696.el6
0:2.6.32-696.el6
python-perf-debuginfo
Red Hat:enterprise_linux:6::workstation
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel
Red Hat:enterprise_linux:6::workstation
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-abi-whitelists
Red Hat:enterprise_linux:6::workstation
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debug
Red Hat:enterprise_linux:6::workstation
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-debug-devel
Red Hat:enterprise_linux:6::workstation
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-devel
Red Hat:enterprise_linux:6::workstation
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-doc
Red Hat:enterprise_linux:6::workstation
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-firmware
Red Hat:enterprise_linux:6::workstation
before 0:2.6.32-696.el6
0:2.6.32-696.el6
kernel-headers
Red Hat:enterprise_linux:6::workstation
before 0:2.6.32-696.el6
0:2.6.32-696.el6
perf
Red Hat:enterprise_linux:6::workstation
before 0:2.6.32-696.el6
0:2.6.32-696.el6
linux
Ubuntu:14.04:LTS
before 3.13.0-51.84, plus listed versions
3.11.0-12.193.12.0-1.33.12.0-2.53.12.0-2.73.12.0-3.8
Show 45 moreShow less
3.12.0-3.93.12.0-4.103.12.0-4.123.12.0-5.133.12.0-7.153.13.0-1.163.13.0-2.173.13.0-3.183.13.0-4.193.13.0-5.203.13.0-6.233.13.0-7.253.13.0-7.263.13.0-8.273.13.0-8.283.13.0-10.303.13.0-11.313.13.0-12.323.13.0-13.333.13.0-14.343.13.0-15.353.13.0-16.363.13.0-17.373.13.0-18.383.13.0-19.393.13.0-19.403.13.0-20.423.13.0-21.433.13.0-22.443.13.0-23.453.13.0-24.463.13.0-24.473.13.0-27.503.13.0-29.533.13.0-30.543.13.0-30.553.13.0-32.573.13.0-33.583.13.0-34.603.13.0-35.623.13.0-36.633.13.0-37.643.13.0-39.663.13.0-40.693.13.0-41.70
3.13.0-51.84
linux-azure
Ubuntu:18.04:LTS
All versions, plus listed versions
4.15.0-1002.24.15.0-1003.34.15.0-1004.44.15.0-1008.84.15.0-1009.9
Show 39 moreShow less
4.15.0-1012.124.15.0-1013.134.15.0-1014.144.15.0-1018.184.15.0-1019.194.15.0-1021.214.15.0-1022.234.15.0-1023.244.15.0-1025.264.15.0-1028.294.15.0-1030.314.15.0-1031.324.15.0-1032.334.15.0-1035.364.15.0-1036.384.15.0-1037.394.18.0-1011.11~18.04.14.18.0-1013.13~18.04.14.18.0-1014.14~18.04.14.18.0-1018.18~18.04.14.18.0-1019.19~18.04.14.18.0-1020.20~18.04.14.18.0-1023.24~18.04.14.18.0-1024.25~18.04.14.18.0-1025.27~18.04.15.0.0-1014.14~18.04.15.0.0-1016.17~18.04.15.0.0-1018.19~18.04.15.0.0-1020.21~18.04.15.0.0-1022.23~18.04.15.0.0-1023.24~18.04.15.0.0-1025.27~18.04.15.0.0-1027.29~18.04.15.0.0-1028.30~18.04.15.0.0-1029.31~18.04.15.0.0-1031.335.0.0-1032.345.0.0-1035.375.0.0-1036.38
None known
linux-gcp
Ubuntu:18.04:LTS
All versions, plus listed versions
4.15.0-1001.14.15.0-1003.34.15.0-1005.54.15.0-1006.64.15.0-1008.8
Show 33 moreShow less
4.15.0-1009.94.15.0-1010.104.15.0-1014.144.15.0-1015.154.15.0-1017.184.15.0-1018.194.15.0-1019.204.15.0-1021.224.15.0-1023.244.15.0-1024.254.15.0-1025.264.15.0-1026.274.15.0-1027.284.15.0-1028.294.15.0-1029.314.15.0-1030.324.15.0-1032.344.15.0-1033.354.15.0-1034.364.15.0-1036.384.15.0-1037.394.15.0-1040.424.15.0-1042.454.15.0-1044.705.0.0-1020.20~18.04.15.0.0-1021.21~18.04.15.0.0-1025.26~18.04.15.0.0-1026.27~18.04.15.0.0-1028.29~18.04.15.0.0-1029.30~18.04.15.0.0-1031.325.0.0-1033.345.0.0-1034.35
None known
linux-hwe
Ubuntu:18.04:LTS
All versions, plus listed versions
4.18.0-13.14~18.04.14.18.0-14.15~18.04.14.18.0-15.16~18.04.14.18.0-16.17~18.04.14.18.0-17.18~18.04.1
Show 38 moreShow less
4.18.0-18.19~18.04.14.18.0-20.21~18.04.14.18.0-21.22~18.04.14.18.0-22.23~18.04.14.18.0-24.25~18.04.14.18.0-25.26~18.04.15.0.0-23.24~18.04.15.0.0-25.26~18.04.15.0.0-27.28~18.04.15.0.0-29.31~18.04.15.0.0-31.33~18.04.15.0.0-32.34~18.04.25.0.0-35.38~18.04.15.0.0-36.39~18.04.15.0.0-37.40~18.04.15.3.0-26.28~18.04.15.3.0-28.30~18.04.15.3.0-40.32~18.04.15.3.0-42.34~18.04.15.3.0-45.37~18.04.15.3.0-46.38~18.04.15.3.0-51.44~18.04.25.3.0-53.47~18.04.15.3.0-59.53~18.04.15.3.0-61.55~18.04.15.3.0-62.56~18.04.15.3.0-64.58~18.04.15.3.0-65.595.3.0-66.605.3.0-67.615.3.0-68.635.3.0-69.655.3.0-70.665.3.0-72.685.3.0-73.695.3.0-74.705.3.0-75.715.3.0-76.72
None known
linux-hwe-edge
Ubuntu:18.04:LTS
All versions, plus listed versions
5.0.0-15.16~18.04.15.0.0-16.17~18.04.15.0.0-17.18~18.04.15.0.0-19.20~18.04.15.0.0-20.21~18.04.1
Show 5 moreShow less
5.3.0-19.20~18.04.25.3.0-22.24~18.04.15.3.0-23.25~18.04.15.3.0-23.25~18.04.25.3.0-24.26~18.04.2
None known
linux-azure-fde
Ubuntu:20.04:LTS
All versions, plus listed versions
5.4.0-1063.66+cvm2.25.4.0-1063.66+cvm3.25.4.0-1064.67+cvm1.15.4.0-1065.68+cvm2.15.4.0-1067.70+cvm1.1
Show 21 moreShow less
5.4.0-1068.71+cvm1.15.4.0-1069.72+cvm1.15.4.0-1070.73+cvm1.15.4.0-1072.75+cvm1.15.4.0-1073.76+cvm1.15.4.0-1074.77+cvm1.15.4.0-1076.79+cvm1.15.4.0-1078.81+cvm1.15.4.0-1080.83+cvm1.15.4.0-1083.87+cvm1.15.4.0-1085.90+cvm1.15.4.0-1085.90+cvm2.15.4.0-1086.91+cvm1.15.4.0-1089.94+cvm1.25.4.0-1090.95+cvm1.15.4.0-1091.96+cvm1.15.4.0-1092.97+cvm1.15.4.0-1095.101+cvm1.15.4.0-1098.104+cvm1.15.4.0-1100.106+cvm1.15.4.0-1103.109+cvm1.1
None known
linux-azure-fde-5.15
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
5.15.0-1019.24~20.04.1.15.15.0-1020.25~20.04.1.15.15.0-1021.26~20.04.1.15.15.0-1029.36~20.04.1.15.15.0-1030.37~20.04.1.1
Show 45 moreShow less
5.15.0-1031.38~20.04.1.15.15.0-1033.40~20.04.1.15.15.0-1034.41~20.04.1.25.15.0-1035.42~20.04.1.15.15.0-1036.43~20.04.1.15.15.0-1037.44~20.04.1.15.15.0-1038.45~20.04.1.15.15.0-1039.46~20.04.1.15.15.0-1040.47~20.04.1.15.15.0-1041.48~20.04.1.15.15.0-1042.49~20.04.1.15.15.0-1043.50~20.04.1.15.15.0-1046.53~20.04.1.15.15.0-1047.54~20.04.1.15.15.0-1049.56~20.04.1.15.15.0-1050.57~20.04.1.15.15.0-1051.59~20.04.1.15.15.0-1052.60~20.04.1.15.15.0-1053.61~20.04.1.15.15.0-1054.62~20.04.1.15.15.0-1056.64~20.04.1.15.15.0-1057.65~20.04.1.15.15.0-1058.66~20.04.2.15.15.0-1059.67~20.04.1.15.15.0-1060.69~20.04.1.15.15.0-1061.70~20.04.1.15.15.0-1063.72~20.04.1.15.15.0-1064.73~20.04.1.15.15.0-1065.74~20.04.1.15.15.0-1067.76~20.04.1.15.15.0-1068.77~20.04.1.15.15.0-1070.79~20.04.1.15.15.0-1071.80~20.04.1.15.15.0-1072.81~20.04.1.15.15.0-1073.82~20.04.1.15.15.0-1074.83~20.04.1.15.15.0-1076.85~20.04.1.15.15.0-1078.87~20.04.1.15.15.0-1081.90~20.04.1.15.15.0-1082.91~20.04.1.15.15.0-1086.95~20.04.1.15.15.0-1087.96~20.04.1.15.15.0-1088.97~20.04.1.15.15.0-1089.98~20.04.1.15.15.0-1091.100~20.04.1.1
None known
linux-gke
Ubuntu:20.04:LTS
All versions, plus listed versions
5.4.0-1033.355.4.0-1035.375.4.0-1036.385.4.0-1037.395.4.0-1039.41
Show 45 moreShow less
5.4.0-1041.435.4.0-1042.445.4.0-1043.455.4.0-1044.465.4.0-1046.485.4.0-1049.525.4.0-1051.545.4.0-1052.555.4.0-1053.565.4.0-1054.575.4.0-1055.585.4.0-1056.595.4.0-1057.605.4.0-1059.625.4.0-1061.645.4.0-1062.655.4.0-1063.665.4.0-1065.685.4.0-1066.695.4.0-1067.705.4.0-1068.715.4.0-1071.765.4.0-1072.775.4.0-1074.795.4.0-1076.825.4.0-1078.845.4.0-1080.865.4.0-1081.875.4.0-1083.895.4.0-1084.905.4.0-1086.935.4.0-1087.945.4.0-1090.975.4.0-1091.985.4.0-1094.1015.4.0-1095.1025.4.0-1096.1035.4.0-1097.1045.4.0-1098.1055.4.0-1099.1065.4.0-1100.1075.4.0-1101.1085.4.0-1102.1095.4.0-1103.1105.4.0-1104.111
None known
linux-gkeop
Ubuntu:20.04:LTS
All versions, plus listed versions
5.4.0-1008.95.4.0-1009.105.4.0-1010.115.4.0-1011.125.4.0-1012.13
Show 45 moreShow less
5.4.0-1013.145.4.0-1014.155.4.0-1015.165.4.0-1016.175.4.0-1018.195.4.0-1021.225.4.0-1022.235.4.0-1023.245.4.0-1024.255.4.0-1025.265.4.0-1026.275.4.0-1027.285.4.0-1029.305.4.0-1031.325.4.0-1032.335.4.0-1033.345.4.0-1034.355.4.0-1036.375.4.0-1037.385.4.0-1038.395.4.0-1039.405.4.0-1040.415.4.0-1043.445.4.0-1046.485.4.0-1048.515.4.0-1049.525.4.0-1051.545.4.0-1052.555.4.0-1053.565.4.0-1054.575.4.0-1056.605.4.0-1057.615.4.0-1060.645.4.0-1061.655.4.0-1062.665.4.0-1064.685.4.0-1065.695.4.0-1066.705.4.0-1067.715.4.0-1068.725.4.0-1069.735.4.0-1070.745.4.0-1071.755.4.0-1072.765.4.0-1073.77
None known
linux-raspi2
Ubuntu:20.04:LTS
All versions, plus listed versions
5.3.0-1007.85.3.0-1014.165.3.0-1015.175.3.0-1017.195.4.0-1004.45.4.0-1006.6
None known
linux-riscv
Ubuntu:20.04:LTS
All versions, plus listed versions
5.4.0-24.285.4.0-26.305.4.0-27.315.4.0-28.325.4.0-30.34
Show 7 moreShow less
5.4.0-31.355.4.0-33.375.4.0-34.385.4.0-36.415.4.0-37.425.4.0-39.445.4.0-40.45
None known
linux-intel-iot-realtime
Ubuntu:22.04:LTS
All versions, plus listed versions
5.15.0-1073.75
None known
linux-realtime
Ubuntu:22.04:LTS
All versions, plus listed versions
5.15.0-1032.35
None known
linux-riscv
Ubuntu:22.04:LTS
All versions, plus listed versions
5.13.0-1004.45.13.0-1006.6+22.04.15.13.0-1007.7+22.04.15.13.0-1010.11+22.04.15.15.0-1004.4
Show 18 moreShow less
5.15.0-1005.55.15.0-1006.65.15.0-1007.75.15.0-1008.85.15.0-1011.125.15.0-1012.135.15.0-1014.165.15.0-1015.175.15.0-1016.185.15.0-1017.195.15.0-1018.215.15.0-1019.225.15.0-1020.235.15.0-1022.265.15.0-1023.275.15.0-1026.305.15.0-1027.315.15.0-1028.32
None known
linux-azure-6.11
Ubuntu:24.04:LTS
All versions, plus listed versions
6.11.0-1008.8~24.04.16.11.0-1012.12~24.04.16.11.0-1013.13~24.04.16.11.0-1014.14~24.04.16.11.0-1015.15~24.04.16.11.0-1017.17~24.04.16.11.0-1018.18~24.04.1
None known
linux-gcp-6.11
Ubuntu:24.04:LTS
All versions, plus listed versions
6.11.0-1006.6~24.04.26.11.0-1011.11~24.04.16.11.0-1013.13~24.04.16.11.0-1014.14~24.04.16.11.0-1015.15~24.04.16.11.0-1016.16~24.04.16.11.0-1017.17~24.04.1
None known
linux-hwe-6.11
Ubuntu:24.04:LTS
All versions, plus listed versions
6.11.0-17.17~24.04.26.11.0-19.19~24.04.16.11.0-21.21~24.04.16.11.0-24.24~24.04.16.11.0-25.25~24.04.16.11.0-26.26~24.04.16.11.0-28.28~24.04.16.11.0-29.29~24.04.1
None known
linux-lowlatency-hwe-6.11
Ubuntu:24.04:LTS
All versions, plus listed versions
6.11.0-1009.10~24.04.16.11.0-1011.12~24.04.16.11.0-1012.13~24.04.16.11.0-1013.14~24.04.16.11.0-1014.15~24.04.16.11.0-1015.16~24.04.26.11.0-1016.17~24.04.1
None known
linux-raspi-realtime
Ubuntu:24.04:LTS
All versions, plus listed versions
6.8.0-2019.20
None known
linux-realtime
Ubuntu:24.04:LTS
All versions, plus listed versions
6.8.1-1015.16
None known
linux-riscv
Ubuntu:24.04:LTS
All versions, plus listed versions
6.5.0-9.9.16.8.0-20.20.16.8.0-28.28.16.8.0-31.31.16.8.0-35.35.1
Show 19 moreShow less
6.8.0-36.36.16.8.0-38.38.16.8.0-39.39.16.8.0-40.40.16.8.0-41.41.16.8.0-44.44.16.8.0-47.47.16.8.0-48.48.16.8.0-49.49.16.8.0-50.51.16.8.0-51.52.16.8.0-52.53.16.8.0-53.55.16.8.0-55.57.16.8.0-56.58.16.8.0-57.59.16.8.0-58.60.16.8.0-59.61.16.8.0-60.63.1
None known

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 58 moreShow less
This page doesn't list everything

Left out here: 55 versions. The JSON record has them.

MoveEnter Open