CVE-2016-10188
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a...
CVE-2016-10188 is a critical vulnerability (CVSS 9.8) in Bitlbee, published February 20, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.94%, the 87th percentile. Fixed in bitlbee 3.5-1.
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
- Record
CVE-2016-10188- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-416
- Updated
- 2026-11-02
CVE List No score
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
- Record
CVE-2016-10188- Updated
- 2026-11-02
EUVDEUVD-2016-1375 No score
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
- Record
EUVD-2016-1375- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5m6p-94pg-48mf
9.8
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a...
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
- Record
GHSA-5m6p-94pg-48mf- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
OSV
9.8
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
- Record
CVE-2016-10188- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSVDEBIAN-CVE-2016-10188
9.8
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
- Record
DEBIAN-CVE-2016-10188- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-10188
9.8
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
- Record
UBUNTU-CVE-2016-10188- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0200 No score
Updated bitlbee packages fix security vulnerability
It was discovered that bitlbee contained issues that allowed a remote attacker to cause a denial of service (via application crash), or potentially execute arbitrary commands (CVE-2016-10188, CVE-2016-10189).
- Record
MGASA-2017-0200- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
bitlbeeDebian:12 |
before 3.5-1 | 3.5-1 |
bitlbeeDebian:13 |
before 3.5-1 | 3.5-1 |
bitlbeeDebian:7 |
before 3.0.5-1.2+deb7u1, plus listed versions 3.0.5-1.2 |
3.0.5-1.2+deb7u1 |
bitlbeeDebian:8 |
before 3.2.2-2+deb8u1, plus listed versions 3.2.2-2 |
3.2.2-2+deb8u1 |
bitlbeeMageia:5 |
before 3.2.2-4.1.mga5 | 3.2.2-4.1.mga5 |
bitlbeeUbuntu:16.04:LTS |
All versions, plus listed versions 3.4.1-13.4.1-1build13.4.2-0ubuntu1 |
None known |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |