Every CVE Search/ Get API key

CVE-2016-10192

Heap-based buffer overflow in ffserver.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x...

9.8 CriticalFix available

Heap-based buffer overflow in ffserver.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote attackers to execute arbitrary code by leveraging failure to check chunk size.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

6.55%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

Heap-based buffer overflow in ffserver.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote attackers to execute arbitrary code by leveraging failure to check chunk size.

Record
CVE-2016-10192
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in ffserver.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote attackers to execute arbitrary code by leveraging failure to check chunk size.

Record
CVE-2016-10192
Updated
2026-11-02
EUVDEUVD-2016-1379 No score

Heap-based buffer overflow in ffserver.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote attackers to execute arbitrary code by leveraging failure to check chunk size.

Record
EUVD-2016-1379
Updated
2026-11-03
GitHub AdvisoriesGHSA-gmhg-h539-229j 9.8

Heap-based buffer overflow in ffserver.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x...

Heap-based buffer overflow in ffserver.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote attackers to execute arbitrary code by leveraging failure to check chunk size.

Record
GHSA-gmhg-h539-229j
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSVALPINE-CVE-2016-10192 9.8

Heap-based buffer overflow in ffserver.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote attackers to execute arbitrary code by leveraging failure to check chunk size.

Record
ALPINE-CVE-2016-10192
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 9.8

Heap-based buffer overflow in ffserver.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote attackers to execute arbitrary code by leveraging failure to check chunk size.

Record
CVE-2016-10192
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-07
Show 5 moreShow less
OSVDEBIAN-CVE-2016-10192 9.8

Heap-based buffer overflow in ffserver.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote attackers to execute arbitrary code by leveraging failure to check chunk size.

Record
DEBIAN-CVE-2016-10192
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-10192 9.8

Heap-based buffer overflow in ffserver.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote attackers to execute arbitrary code by leveraging failure to check chunk size.

Record
UBUNTU-CVE-2016-10192
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0008 No score

Updated ffmpeg packages fix security vulnerability

This update provides ffmpeg version 2.4.14, which fixes several security vulnerabilities and other bugs which were corrected upstream.

Record
MGASA-2018-0008
Updated
2026-11-02
OSVopenSUSE-SU-2017:1531-1 No score

Security update for ffmpeg

This update of ffmpeg to version 3.1.8 fixes the following security issues:

  • CVE-2016-9561: DoS through huge memory allocation (bsc#1015120)
  • CVE-2016-10191: remote code execution vulnerability (bsc#1022921)
  • CVE-2016-10192: remote code execution vulnerability (bsc#1022922)
  • CVE-2017-5024: Heap overflow
  • CVE-2017-5025: Heap overflow
Record
openSUSE-SU-2017:1531-1
Updated
2026-11-02
OSVopenSUSE-SU-2017:1532-1 No score

Security update for ffmpeg

ffmpeg was updated to fix the following security issues:

CVE-2016-10191: remote exploitaion results code execution ((bsc#1022921) CVE-2016-10192: remote exploitaion results code execution bsc#1022922) CVE-2017-7866: stack-based buffer overflow (bsc#1034176) CVE-2017-7865: heap-based buffer overflow (bsc#1034177) CVE-2017-7863: heap-based buffer overflow (bsc#1034179) CVE-2016-9561: Huge amount memory allocated, resulting in DoS (bsc#1015120)

Record
openSUSE-SU-2017:1532-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ffmpeg
Alpine:v3.3
before 2.8.11-r0
2.8.11-r0
ffmpeg
Alpine:v3.4
before 3.0.7-r0
3.0.7-r0
ffmpeg
Debian:12
before 7:3.2.2-1
7:3.2.2-1
ffmpeg
Debian:13
before 7:3.2.2-1
7:3.2.2-1
ffmpeg
Debian:14
before 7:3.2.2-1
7:3.2.2-1
ffmpeg
Mageia:5
From an advisory covering 31 CVEs
before 2.4.14-1.mga5
2.4.14-1.mga5
ffmpeg
Mageia:5
From an advisory covering 31 CVEs
before 2.4.14-1.mga5.tainted
2.4.14-1.mga5.tainted
libav
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
6:0.8.7-1ubuntu26:9.10-1ubuntu16:9.10-1ubuntu26:9.10-1ubuntu56:9.10-1ubuntu6
Show 9 moreShow less
6:9.10-1ubuntu76:9.11-2ubuntu16:9.11-2ubuntu26:9.13-0ubuntu0.14.04.16:9.14-0ubuntu0.14.04.16:9.16-0ubuntu0.14.04.16:9.18-0ubuntu0.14.04.16:9.20-0ubuntu0.14.04.16:9.20-0ubuntu0.14.04.1+esm1
None known
ffmpeg
Ubuntu:16.04:LTS
before 7:2.8.11-0ubuntu0.16.04.1, plus listed versions
7:2.7.2-1build17:2.8.1-1ubuntu17:2.8.2-1ubuntu17:2.8.3-17:2.8.4-1
Show 8 moreShow less
7:2.8.4-1ubuntu17:2.8.4-1ubuntu27:2.8.4-1ubuntu37:2.8.4-1ubuntu47:2.8.6-1ubuntu17:2.8.6-1ubuntu27:2.8.8-0ubuntu0.16.04.17:2.8.10-0ubuntu0.16.04.1
7:2.8.11-0ubuntu0.16.04.1
ffmpeg
SUSE:Package Hub 12 SP2
From an advisory covering 5 CVEs
before 3.1.8-8.1
3.1.8-8.1
ffmpeg2
SUSE:Package Hub 12 SP1
From an advisory covering 6 CVEs
before 2.8.11-12.1
2.8.11-12.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-10192 is a critical vulnerability (CVSS 9.8) in Ffmpeg, published February 9, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.55%, the 93rd percentile. Fixed in ffmpeg 2.8.11-r0.

References

Show 22 moreShow less
MoveEnter Open