CVE-2016-10211
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after...
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted rule that is mishandled in the yr_parser_lookup_loop_variable function.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted rule that is mishandled in the yr_parser_lookup_loop_variable function.
- Record
CVE-2016-10211- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-416
- Updated
- 2026-11-02
CVE List No score
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted rule that is mishandled in the yr_parser_lookup_loop_variable function.
- Record
CVE-2016-10211- Updated
- 2026-11-02
EUVDEUVD-2016-1396 No score
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted rule that is mishandled in the yr_parser_lookup_loop_variable function.
- Record
EUVD-2016-1396- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4c8q-59gf-m24q
7.5
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after...
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted rule that is mishandled in the yr_parser_lookup_loop_variable function.
- Record
GHSA-4c8q-59gf-m24q- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
OSV
7.5
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted rule that is mishandled in the yr_parser_lookup_loop_variable function.
- Record
CVE-2016-10211- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-10211
7.5
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted rule that is mishandled in the yr_parser_lookup_loop_variable function.
- Record
DEBIAN-CVE-2016-10211- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-10211
7.5
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted rule that is mishandled in the yr_parser_lookup_loop_variable function.
- Record
UBUNTU-CVE-2016-10211- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-8080-1 No score
yara vulnerabilities
Kamil Frankowicz discovered that a number of YARA's functions generated memory exceptions when processing specially crafted rules or files. A remote attacker could possibly use these issues to cause YARA to crash, resulting in a denial of service. These issues only affected Ubuntu 16.04 LTS. (CVE-2016-10211, CVE-2017-5923, CVE-2017-5924, CVE-2017-8294, CVE-2017-8929, CVE-2017-9304, CVE-2017-9438, CVE-2017-9465)
Jurriaan Bremer discovered that YARA's yr_object_array_set_limit() function could result in a heap buffer overflow when scanning specially crafted .NET files. A remote attacker could possibly use this issue to cause YARA to crash, resulting in a denial of service. This issue only affected Ubuntu 16.04 LTS. (CVE-2017-11328)
It was discovered that YARA's yr_execute_code() function could cause an out-of-bounds read or write when parsing specially crafted compiled rule files. A remote attacker could possibly use these issues to cause YARA to crash, resulting in a denial of service. These issues only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-2018-12034, CVE-2018-12035)
It was discovered that YARA's virtual machine could be escaped in certain instances. A remote attacker could possibly use these issues to execute arbitrary code. These issues only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-2018-19974, CVE-2018-19975, CVE-2018-19976)
It was discovered that YARA's macho_parse_file() function would generate an out-of-bounds memory access error when parsing a specially crafted Mach-O file. A remote attacker could possibly use this issue to cause YARA to crash, resulting in a denial of service, or execute arbitrary code. This issue only affected Ubuntu 20.04 LTS. (CVE-2019-19648)
It was discovered that YARA's macho.c implementation contained several overflow reads, which could be triggered when parsing specially crafted Mach-O files. A remote attacker could possibly use this issue to cause YARA to crash, resulting in a denial of service, or to learn sensitive information. This issue only affected Ubuntu 20.04 LTS. (CVE-2021-3402)
It was discovered that YARA's yr_set_configuration() function could trigger a buffer overflow when parsing specially crafted rules. A remote attacker could possibly use this issue to cause YARA to crash, resulting in a denial of service. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2021-45429)
- Record
USN-8080-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
yaraDebian:12 |
before 3.5.0+dfsg-9 | 3.5.0+dfsg-9 |
yaraDebian:13 |
before 3.5.0+dfsg-9 | 3.5.0+dfsg-9 |
yaraDebian:14 |
before 3.5.0+dfsg-9 | 3.5.0+dfsg-9 |
yaraUbuntu:Pro:16.04:LTS |
before 3.4.0+dfsg-2ubuntu0.1~esm1, plus listed versions 3.4.0+dfsg-23.4.0+dfsg-2build1 |
3.4.0+dfsg-2ubuntu0.1~esm1 |
yaraUbuntu:Pro:18.04:LTS |
before 3.7.1-1ubuntu2+esm1, plus listed versions 3.6.3+dfsg-1ubuntu13.7.1-1ubuntu13.7.1-1ubuntu2 |
3.7.1-1ubuntu2+esm1 |
yaraUbuntu:Pro:20.04:LTS |
before 3.9.0-1ubuntu0.1~esm1, plus listed versions 3.9.0-1 |
3.9.0-1ubuntu0.1~esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-10211 is a high vulnerability (CVSS 7.5) in Virustotal Yara, published April 3, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.59%, the 75th percentile. Fixed in yara 3.5.0+dfsg-9.
References
securityfocus.com/bid/98078
github.com/VirusTotal/yara/commit/890c3f850293176c0e996a602ffa88b315f4e98f
github.com/VirusTotal/yara/issues/575
nvd.nist.gov/vuln/detail/CVE-2016-10211
github.com/advisories/GHSA-4c8q-59gf-m24q
security-tracker.debian.org/tracker/CVE-2016-10211
Show 19 moreShow less
ubuntu.com/security/CVE-2016-10211
cve.org/CVERecord?id=CVE-2016-10211
ubuntu.com/security/notices/USN-8080-1
ubuntu.com/security/CVE-2017-5923
ubuntu.com/security/CVE-2017-5924
ubuntu.com/security/CVE-2017-8294
ubuntu.com/security/CVE-2017-8929
ubuntu.com/security/CVE-2017-9304
ubuntu.com/security/CVE-2017-9438
ubuntu.com/security/CVE-2017-9465
ubuntu.com/security/CVE-2017-11328
ubuntu.com/security/CVE-2018-12034
ubuntu.com/security/CVE-2018-12035
ubuntu.com/security/CVE-2018-19974
ubuntu.com/security/CVE-2018-19975
ubuntu.com/security/CVE-2018-19976
ubuntu.com/security/CVE-2019-19648
ubuntu.com/security/CVE-2021-3402
ubuntu.com/security/CVE-2021-45429