CVE-2016-10362
Logstash Logs Sensitive Information
Prior to Logstash version 5.0.1, Elasticsearch Output plugin when updating connections after sniffing, would log to file HTTP basic auth credentials.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.5
Prior to Logstash version 5.0.1, Elasticsearch Output plugin when updating connections after sniffing, would log to file HTTP basic auth credentials.
- Record
CVE-2016-10362- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:P/I:N/A:N - Weakness
- CWE-532, CWE-200
- Updated
- 2026-11-02
CVE List No score
Prior to Logstash version 5.0.1, Elasticsearch Output plugin when updating connections after sniffing, would log to file HTTP basic auth credentials.
- Record
CVE-2016-10362- Weakness
- CWE-532
- Updated
- 2026-11-02
EUVDEUVD-2022-2178 No score
Prior to Logstash version 5.0.1, Elasticsearch Output plugin when updating connections after sniffing, would log to file HTTP basic auth credentials.
- Record
EUVD-2022-2178- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3gg4-6hqg-2vjx
6.5
Logstash Logs Sensitive Information
Prior to Logstash version 5.0.1, Elasticsearch Output plugin when updating connections after sniffing, would log to file HTTP basic auth credentials.
- Record
GHSA-3gg4-6hqg-2vjx- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSVGHSA-3gg4-6hqg-2vjx
6.5
Logstash Logs Sensitive Information
Prior to Logstash version 5.0.1, Elasticsearch Output plugin when updating connections after sniffing, would log to file HTTP basic auth credentials.
- Record
GHSA-3gg4-6hqg-2vjx- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
logstash-coreRubyGems |
before 5.0.1 | 5.0.1 |
logstash-coreRubyGems |
before 5.0.1, plus listed versions 1.5.01.5.0.beta21.5.0.rc11.5.0.rc1.11.5.0.rc2 Show 45 moreShow less1.5.0.rc2.snapshot1.5.0.rc31.5.0.rc3.snapshot11.5.0.rc3.snapshot21.5.0.rc3.snapshot31.5.0.rc3.snapshot41.5.0.rc3.snapshot51.5.0.rc3.snapshot61.5.0.rc41.5.0.rc4.snapshot11.5.0.rc4.snapshot21.5.0.snapshot11.5.11.5.1.snapshot11.5.21.5.2.11.5.2.21.5.2.snapshot11.5.2.snapshot21.5.31.5.3.snapshot11.5.3.snapshot21.5.41.5.4.snapshot11.5.4.snapshot21.5.4.snapshot31.5.51.5.62.0.02.0.0.beta12.0.0.beta22.0.0.beta32.0.0.rc12.0.12.0.1.snapshot12.1.02.1.0.snapshot12.1.0.snapshot22.1.0.snapshot32.1.0.snapshot42.1.12.1.22.1.2.snapshot12.1.32.2.0 |
5.0.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-10362 is a medium vulnerability (CVSS 6.5) in Elastic Logstash, published June 16, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.09%, the 65th percentile. Fixed in logstash-core 5.0.1.
References
Left out here: 56 versions. The JSON record has them.