CVE-2016-10376
Gajim through 0.16.7 unconditionally implements the "XEP-0146: Remote Controlling Clients"...
Gajim through 0.16.7 unconditionally implements the "XEP-0146: Remote Controlling Clients" extension. This can be abused by malicious XMPP servers to, for example, extract plaintext from OTR encrypted sessions.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
4.5
Gajim through 0.16.7 unconditionally implements the "XEP-0146: Remote Controlling Clients" extension. This can be abused by malicious XMPP servers to, for example, extract plaintext from OTR encrypted sessions.
- Record
CVE-2016-10376- CVSS 3.0
- 4.5 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:P/I:N/A:N - Weakness
- CWE-310
- Updated
- 2026-11-02
CVE List No score
Gajim through 0.16.7 unconditionally implements the "XEP-0146: Remote Controlling Clients" extension. This can be abused by malicious XMPP servers to, for example, extract plaintext from OTR encrypted sessions.
- Record
CVE-2016-10376- Updated
- 2026-11-02
EUVDEUVD-2016-1558 No score
Gajim through 0.16.7 unconditionally implements the "XEP-0146: Remote Controlling Clients" extension. This can be abused by malicious XMPP servers to, for example, extract plaintext from OTR encrypted sessions.
- Record
EUVD-2016-1558- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5wv2-923f-jxwr
4.5
Gajim through 0.16.7 unconditionally implements the "XEP-0146: Remote Controlling Clients"...
Gajim through 0.16.7 unconditionally implements the "XEP-0146: Remote Controlling Clients" extension. This can be abused by malicious XMPP servers to, for example, extract plaintext from OTR encrypted sessions.
- Record
GHSA-5wv2-923f-jxwr- CVSS 3.0
- 4.5 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSV
4.5
Gajim through 0.16.7 unconditionally implements the "XEP-0146: Remote Controlling Clients" extension. This can be abused by malicious XMPP servers to, for example, extract plaintext from OTR encrypted sessions.
- Record
CVE-2016-10376- CVSS 3.0
- 4.5 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-10376
4.5
Gajim through 0.16.7 unconditionally implements the "XEP-0146: Remote Controlling Clients" extension. This can be abused by malicious XMPP servers to, for example, extract plaintext from OTR encrypted sessions.
- Record
DEBIAN-CVE-2016-10376- CVSS 3.0
- 4.5 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-10376
4.5
Gajim through 0.16.7 unconditionally implements the "XEP-0146: Remote Controlling Clients" extension. This can be abused by malicious XMPP servers to, for example, extract plaintext from OTR encrypted sessions.
- Record
UBUNTU-CVE-2016-10376- CVSS 3.0
- 4.5 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVMGASA-2017-0166 No score
Updated gajim packages fix security vulnerability
Gajim unconditionally implements the "XEP-0146: Remote Controlling Clients" extension, which may be abused by malicious XMPP servers to, for example, extract plaintext from OTR encrypted sessions (CVE-2016-10376).
- Record
MGASA-2017-0166- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10775-1 No score
gajim-1.3.2-1.2 on GA media
These are all security issues fixed in the gajim-1.3.2-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10775-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gajimDebian:12 |
before 0.16.6-1.1 | 0.16.6-1.1 |
gajimDebian:13 |
before 0.16.6-1.1 | 0.16.6-1.1 |
gajimDebian:14 |
before 0.16.6-1.1 | 0.16.6-1.1 |
gajimDebian:7 |
before 0.15.1-4.1+deb7u3, plus listed versions 0.15.1-40.15.1-4.10.15.1-4.1+deb7u10.15.1-4.1+deb7u2 |
0.15.1-4.1+deb7u3 |
gajimDebian:8 |
before 0.16-1+deb8u2, plus listed versions 0.16-10.16-1+deb8u1 |
0.16-1+deb8u2 |
gajimMageia:5 |
before 0.16.5-1.1.mga5 | 0.16.5-1.1.mga5 |
gajimUbuntu:16.04:LTS |
All versions, plus listed versions 0.16-10.16.5-0.1 |
None known |
gajimopenSUSE:Tumbleweed |
before 1.3.2-1.2 | 1.3.2-1.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-10376 is a medium vulnerability (CVSS 4.5) in Gajim, published May 28, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.15%, the 67th percentile. Fixed in gajim 0.16.6-1.1.
References
dev.gajim.org/gajim/gajim/commit/cb65cfc5aed9efe05208ebbb7fb2d41fcf7253cc
mail.jabber.org/pipermail/standards/2016-August/031335.html
security.gentoo.org/glsa/201707-14
debian.org/security/2017/dsa-3943
dev.gajim.org/gajim/gajim/issues/8378
bugs.debian.org/863445
Show 9 moreShow less
nvd.nist.gov/vuln/detail/CVE-2016-10376
github.com/advisories/GHSA-5wv2-923f-jxwr
security-tracker.debian.org/tracker/CVE-2016-10376
advisories.mageia.org/MGASA-2017-0166.html
bugs.mageia.org/show_bug.cgi?id=20962
openwall.com/lists/oss-security/2017/05/28/1
ubuntu.com/security/CVE-2016-10376
cve.org/CVERecord?id=CVE-2016-10376
suse.com/security/cve/CVE-2016-10376