Every CVE Search/ Get API key

CVE-2016-10558

Downloads Resources over HTTP in aerospike

8.1 HighFix available

aerospike is an Aerospike add-on module for Node.js. aerospike versions below 2.4.2 download binary resources over HTTP, which leaves the module vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.69%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.1

aerospike is an Aerospike add-on module for Node.js. aerospike versions below 2.4.2 download binary resources over HTTP, which leaves the module vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Record
CVE-2016-10558
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-311, CWE-310
Updated
2026-11-02
CVE List No score

aerospike is an Aerospike add-on module for Node.js. aerospike versions below 2.4.2 download binary resources over HTTP, which leaves the module vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Record
CVE-2016-10558
Weakness
CWE-311
Updated
2026-11-02
EUVDEUVD-2019-0345 No score

aerospike is an Aerospike add-on module for Node.js. aerospike versions below 2.4.2 download binary resources over HTTP, which leaves the module vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Record
EUVD-2019-0345
Updated
2026-11-03
GitHub AdvisoriesGHSA-v5v3-8jqf-vg27 No score

Downloads Resources over HTTP in aerospike

Affected versions of aerospike insecurely download an executable over an unencrypted HTTP connection.

In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running aerospike.

Recommendation

Update to version 2.4.2 or later

Record
GHSA-v5v3-8jqf-vg27
Weakness
CWE-311
Updated
2026-11-02
OSV 8.1

aerospike is an Aerospike add-on module for Node.js. aerospike versions below 2.4.2 download binary resources over HTTP, which leaves the module vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Record
CVE-2016-10558
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-v5v3-8jqf-vg27 No score

Downloads Resources over HTTP in aerospike

Affected versions of aerospike insecurely download an executable over an unencrypted HTTP connection.

In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running aerospike.

Recommendation

Update to version 2.4.2 or later

Record
GHSA-v5v3-8jqf-vg27
Weakness
CWE-311
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
aerospike
npm
before 2.4.2
2.4.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-10558 is a high vulnerability (CVSS 8.1) in Aerospike, published May 29, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.69%, the 77th percentile. Fixed in aerospike 2.4.2.

References

MoveEnter Open