Every CVE Search/ Get API key

CVE-2016-10560

Downloads Resources over HTTP in galenframework-cli

8.1 HighFix available

galenframework-cli is the node wrapper for the Galen Framework. galenframework-cli below 2.3.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.67%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.1

galenframework-cli is the node wrapper for the Galen Framework. galenframework-cli below 2.3.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Record
CVE-2016-10560
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-311, CWE-310
Updated
2026-11-02
CVE List No score

galenframework-cli is the node wrapper for the Galen Framework. galenframework-cli below 2.3.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Record
CVE-2016-10560
Weakness
CWE-311
Updated
2026-11-02
EUVDEUVD-2019-0362 No score

galenframework-cli is the node wrapper for the Galen Framework. galenframework-cli below 2.3.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Record
EUVD-2019-0362
Updated
2026-11-03
GitHub AdvisoriesGHSA-x5ph-4fr4-g7fw No score

Downloads Resources over HTTP in galenframework-cli

Affected versions of galenframework-cli insecurely download an executable over an unencrypted HTTP connection.

In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running galenframework-cli.

Recommendation

Update to version 2.3.1 or later.

Record
GHSA-x5ph-4fr4-g7fw
Weakness
CWE-311
Updated
2026-11-02
OSV 8.1

galenframework-cli is the node wrapper for the Galen Framework. galenframework-cli below 2.3.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Record
CVE-2016-10560
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-x5ph-4fr4-g7fw No score

Downloads Resources over HTTP in galenframework-cli

Affected versions of galenframework-cli insecurely download an executable over an unencrypted HTTP connection.

In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running galenframework-cli.

Recommendation

Update to version 2.3.1 or later.

Record
GHSA-x5ph-4fr4-g7fw
Weakness
CWE-311
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
galenframework-cli
npm
before 2.3.1
2.3.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-10560 is a high vulnerability (CVSS 8.1) in Galenframework Galenframework-cli, published May 31, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.67%, the 76th percentile. Fixed in galenframework-cli 2.3.1.

References

MoveEnter Open