CVE-2016-10610
Downloads Resources over HTTP in unicode-json
unicode-json is a unicode lookup table. unicode-json before 2.0.0 downloads data resources over HTTP, which leaves it vulnerable to MITM attacks.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.1
unicode-json is a unicode lookup table. unicode-json before 2.0.0 downloads data resources over HTTP, which leaves it vulnerable to MITM attacks.
- Record
CVE-2016-10610- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-311, CWE-310
- Updated
- 2026-11-02
CVE List No score
unicode-json is a unicode lookup table. unicode-json before 2.0.0 downloads data resources over HTTP, which leaves it vulnerable to MITM attacks.
- Record
CVE-2016-10610- Weakness
- CWE-311
- Updated
- 2026-11-02
EUVDEUVD-2019-0305 No score
unicode-json is a unicode lookup table. unicode-json before 2.0.0 downloads data resources over HTTP, which leaves it vulnerable to MITM attacks.
- Record
EUVD-2019-0305- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hw4r-xr38-hm8j No score
Downloads Resources over HTTP in unicode-json
Affected versions of unicode-json insecurely downloads resources over HTTP.
In scenarios where an attacker has a privileged network position, they can modify or read such resources at will. While the exact severity of impact for a vulnerability like this is highly variable and depends on the behavior of the package itself, it ranges from being able to read sensitive information all the way up to and including remote code execution.
Recommendation
Install version 2.0.0 or greater.
- Record
GHSA-hw4r-xr38-hm8j- Weakness
- CWE-311
- Updated
- 2026-11-02
OSVGHSA-hw4r-xr38-hm8j No score
Downloads Resources over HTTP in unicode-json
Affected versions of unicode-json insecurely downloads resources over HTTP.
In scenarios where an attacker has a privileged network position, they can modify or read such resources at will. While the exact severity of impact for a vulnerability like this is highly variable and depends on the behavior of the package itself, it ranges from being able to read sensitive information all the way up to and including remote code execution.
Recommendation
Install version 2.0.0 or greater.
- Record
GHSA-hw4r-xr38-hm8j- Weakness
- CWE-311
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
unicode-jsonnpm |
before 2.0.0 | 2.0.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-10610 is a high vulnerability (CVSS 8.1) in Unicode Unicode-json, published June 1, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.54%, the 45th percentile. Fixed in unicode-json 2.0.0.