CVE-2016-10729
An issue was discovered in Amanda 3.3.1. A user with backup privileges can trivially compromise a...
CVE-2016-10729 is a high vulnerability (CVSS 7.8) in Zmanda Amanda, published October 24, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.28%, the 70th percentile. Fixed in amanda 1:3.3.9-1.
An issue was discovered in Amanda 3.3.1. A user with backup privileges can trivially compromise a client installation. The "runtar" setuid root binary does not check for additional arguments supplied after --create, allowing users to manipulate commands and perform command injection as root.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
An issue was discovered in Amanda 3.3.1. A user with backup privileges can trivially compromise a client installation. The "runtar" setuid root binary does not check for additional arguments supplied after --create, allowing users to manipulate commands and perform command injection as root.
- Record
CVE-2016-10729- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.2 High
AV:L/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-77
- Updated
- 2026-11-02
CVE List No score
An issue was discovered in Amanda 3.3.1. A user with backup privileges can trivially compromise a client installation. The "runtar" setuid root binary does not check for additional arguments supplied after --create, allowing users to manipulate commands and perform command injection as root.
- Record
CVE-2016-10729- Updated
- 2026-11-02
EUVDEUVD-2016-1727 No score
An issue was discovered in Amanda 3.3.1. A user with backup privileges can trivially compromise a client installation. The "runtar" setuid root binary does not check for additional arguments supplied after --create, allowing users to manipulate commands and perform command injection as root.
- Record
EUVD-2016-1727- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-269f-8j25-5mp2
7.8
An issue was discovered in Amanda 3.3.1. A user with backup privileges can trivially compromise a...
An issue was discovered in Amanda 3.3.1. A user with backup privileges can trivially compromise a client installation. The "runtar" setuid root binary does not check for additional arguments supplied after --create, allowing users to manipulate commands and perform command injection as root.
- Record
GHSA-269f-8j25-5mp2- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
OSV
7.8
An issue was discovered in Amanda 3.3.1. A user with backup privileges can trivially compromise a client installation. The "runtar" setuid root binary does not check for additional arguments supplied after --create, allowing users to manipulate commands and perform command injection as root.
- Record
CVE-2016-10729- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-10729
7.8
An issue was discovered in Amanda 3.3.1. A user with backup privileges can trivially compromise a client installation. The "runtar" setuid root binary does not check for additional arguments supplied after --create, allowing users to manipulate commands and perform command injection as root.
- Record
DEBIAN-CVE-2016-10729- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-10729
7.8
An issue was discovered in Amanda 3.3.1. A user with backup privileges can trivially compromise a client installation. The "runtar" setuid root binary does not check for additional arguments supplied after --create, allowing users to manipulate commands and perform command injection as root.
- Record
UBUNTU-CVE-2016-10729- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVSUSE-SU-2018:4121-1 No score
Security update for amanda
This update for amanda fixes the following issues:
Security issue fixed:
- CVE-2016-10729: Fixed a local privilege escalation from amanda to root via unsafe tar command options (bsc#1112916).
- Record
SUSE-SU-2018:4121-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
amandaDebian:12 |
before 1:3.3.9-1 | 1:3.3.9-1 |
amandaDebian:13 |
before 1:3.3.9-1 | 1:3.3.9-1 |
amandaDebian:14 |
before 1:3.3.9-1 | 1:3.3.9-1 |
amandaSUSE:Linux Enterprise Server 11 SP4 |
before 2.5.2.1-188.5.1 | 2.5.2.1-188.5.1 |
amandaSUSE:Linux Enterprise Server for SAP Applications 11 SP4 |
before 2.5.2.1-188.5.1 | 2.5.2.1-188.5.1 |
amandaUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1:3.3.6-41:3.3.6-4.11:3.3.6-4.1ubuntu0.11:3.3.6-4.1ubuntu0.1+actuallyesm21:3.3.6-4.1ubuntu0.1+esm11:3.3.6-4.1ubuntu0.1+esm2 |
None known |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
exploit-db.com/exploits/39217
nvd.nist.gov/vuln/detail/CVE-2016-10729
github.com/advisories/GHSA-269f-8j25-5mp2
security-tracker.debian.org/tracker/CVE-2016-10729
suse.com/support/update/announcement/2018/suse-su-20184121-1
bugzilla.suse.com/1112916
suse.com/security/cve/CVE-2016-10729
ubuntu.com/security/CVE-2016-10729
cve.org/CVERecord?id=CVE-2016-10729