Every CVE Search/ Get API key

CVE-2016-1517

Improper Input Validation in OpenCV

5.5 MediumFix available

OpenCV 3.0.0 allows remote attackers to cause a denial of service (segfault) via vectors involving corrupt chunks.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.08%Unchanged since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.5

OpenCV 3.0.0 allows remote attackers to cause a denial of service (segfault) via vectors involving corrupt chunks.

Record
CVE-2016-1517
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

OpenCV 3.0.0 allows remote attackers to cause a denial of service (segfault) via vectors involving corrupt chunks.

Record
CVE-2016-1517
Updated
2026-11-02
EUVDEUVD-2021-2193 No score

OpenCV 3.0.0 allows remote attackers to cause a denial of service (segfault) via vectors involving corrupt chunks.

Record
EUVD-2021-2193
Updated
2026-11-03
GitHub AdvisoriesGHSA-fffj-9qwg-qmh5 5.5

Improper Input Validation in OpenCV

OpenCV 3.0.0 allows remote attackers to cause a denial of service (segfault) via vectors involving corrupt chunks. This issue was fixed in OpenCV version 3.3.1 (corresponding to OpenCV 3.3.1.11).

Record
GHSA-fffj-9qwg-qmh5
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 5.5

OpenCV 3.0.0 allows remote attackers to cause a denial of service (segfault) via vectors involving corrupt chunks.

Record
CVE-2016-1517
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-1517 5.5

OpenCV 3.0.0 allows remote attackers to cause a denial of service (segfault) via vectors involving corrupt chunks.

Record
DEBIAN-CVE-2016-1517
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVGHSA-fffj-9qwg-qmh5 5.5

Improper Input Validation in OpenCV

OpenCV 3.0.0 allows remote attackers to cause a denial of service (segfault) via vectors involving corrupt chunks. This issue was fixed in OpenCV version 3.3.1 (corresponding to OpenCV 3.3.1.11).

Record
GHSA-fffj-9qwg-qmh5
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVPYSEC-2026-2817 5.5

Improper Input Validation in OpenCV

OpenCV 3.0.0 allows remote attackers to cause a denial of service (segfault) via vectors involving corrupt chunks. This issue was fixed in OpenCV version 3.3.1 (corresponding to OpenCV 3.3.1.11).

Record
PYSEC-2026-2817
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVPYSEC-2026-708 5.5

Improper Input Validation in OpenCV

OpenCV 3.0.0 allows remote attackers to cause a denial of service (segfault) via vectors involving corrupt chunks. This issue was fixed in OpenCV version 3.3.1 (corresponding to OpenCV 3.3.1.11).

Record
PYSEC-2026-708
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-1517 5.5

OpenCV 3.0.0 allows remote attackers to cause a denial of service (segfault) via vectors involving corrupt chunks.

Record
UBUNTU-CVE-2016-1517
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2018:1265-1 No score

Security update for opencv

This update for opencv fixes the following issues:

  • CVE-2016-1517: Fixed a denial of service (segfault) via vectors involving corrupt chunks (boo#1033150)
  • CVE-2016-1516: Fixed a double free issue that allows attackers to execute arbitrary code (boo#1033152).
Record
openSUSE-SU-2018:1265-1
Updated
2026-11-02
OSVopenSUSE-SU-2018:1271-1 No score

Security update for opencv

This update for opencv fixes the following issues:

  • CVE-2016-1517: Fixed a denial of service (segfault) via vectors involving corrupt chunks (boo#1033150)
  • CVE-2016-1516: Fixed a double free issue that allows attackers to execute arbitrary code (boo#1033152).
Record
openSUSE-SU-2018:1271-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
opencv-python
PyPI
through 3.3.0.10
3.3.1.11
opencv-contrib-python
PyPI
through 3.3.0.10
3.3.1.11
opencv
Debian:12
before 3.2.0+dfsg-6
3.2.0+dfsg-6
opencv
Debian:13
before 3.2.0+dfsg-6
3.2.0+dfsg-6
opencv
Debian:14
before 3.2.0+dfsg-6
3.2.0+dfsg-6
opencv-python
PyPI
before 3.3.1.11
3.3.1.11
opencv-contrib-python
PyPI
before 3.3.1.11
3.3.1.11
opencv
Ubuntu:16.04:LTS
before 2.4.9.1+dfsg-1.5ubuntu1.1, plus listed versions
2.4.9+dfsg-1ubuntu62.4.9.1+dfsg-1.2ubuntu12.4.9.1+dfsg-1.3ubuntu12.4.9.1+dfsg-1.5ubuntu1
2.4.9.1+dfsg-1.5ubuntu1.1
opencv
Ubuntu:18.04:LTS
before 3.2.0+dfsg-4ubuntu0.1, plus listed versions
3.1.0+dfsg1-1~exp1ubuntu33.2.0+dfsg-33.2.0+dfsg-43.2.0+dfsg-4build13.2.0+dfsg-4build2
3.2.0+dfsg-4ubuntu0.1
opencv
SUSE:Package Hub 12 SP3
before 3.1.0-5.1
3.1.0-5.1
opencv-qt5
SUSE:Package Hub 12 SP3
before 3.1.0-5.1
3.1.0-5.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-1517 is a medium vulnerability (CVSS 5.5) in Opencv, published April 10, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.08%, the 65th percentile. Fixed in opencv-python 3.3.1.11.

References

Show 11 moreShow less
MoveEnter Open