Every CVE Search/ Get API key

CVE-2016-1544

nghttp2 before 1.7.1 allows remote attackers to cause a denial of service (memory exhaustion).

3.3 LowFix available

nghttp2 before 1.7.1 allows remote attackers to cause a denial of service (memory exhaustion).

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

0.89%Down 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.3

nghttp2 before 1.7.1 allows remote attackers to cause a denial of service (memory exhaustion).

Record
CVE-2016-1544
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-400
Updated
2026-11-02
CVE List No score

nghttp2 before 1.7.1 allows remote attackers to cause a denial of service (memory exhaustion).

Record
CVE-2016-1544
Updated
2026-11-02
EUVDEUVD-2016-2639 No score

nghttp2 before 1.7.1 allows remote attackers to cause a denial of service (memory exhaustion).

Record
EUVD-2016-2639
Updated
2026-11-03
GitHub AdvisoriesGHSA-32wx-5655-89rw No score

nghttp2 before 1.7.1 allows remote attackers to cause a denial of service (memory exhaustion).

nghttp2 before 1.7.1 allows remote attackers to cause a denial of service (memory exhaustion).

Record
GHSA-32wx-5655-89rw
Updated
2026-11-02
OSV 3.3

nghttp2 before 1.7.1 allows remote attackers to cause a denial of service (memory exhaustion).

Record
CVE-2016-1544
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVDEBIAN-CVE-2016-1544 3.3

nghttp2 before 1.7.1 allows remote attackers to cause a denial of service (memory exhaustion).

Record
DEBIAN-CVE-2016-1544
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVUBUNTU-CVE-2016-1544 3.3

nghttp2 before 1.7.1 allows remote attackers to cause a denial of service (memory exhaustion).

Record
UBUNTU-CVE-2016-1544
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVopenSUSE-SU-2024:10164-1 No score

libnghttp2-14-1.17.0-1.1 on GA media

These are all security issues fixed in the libnghttp2-14-1.17.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10164-1
Updated
2026-11-02
OSVSUSE-SU-2021:0932-1 No score

Security update for nghttp2

This update for nghttp2 fixes the following issues:

Security issues fixed:

  • CVE-2020-11080: HTTP/2 Large Settings Frame DoS (bsc#1181358).
  • CVE-2019-9513: Fixed HTTP/2 implementation that is vulnerable to resource loops, potentially leading to a denial of service (bsc#1146184).
  • CVE-2019-9511: Fixed HTTP/2 implementations that are vulnerable to window size manipulation and stream prioritization manipulation, potentially leading to a denial of service (bsc#1146182).
  • CVE-2018-1000168: Fixed ALTSVC frame client side denial of service (bsc#1088639).
  • CVE-2016-1544: Fixed out of memory due to unlimited incoming HTTP header fields (bsc#966514).

Bug fixes and enhancements:

  • Packages must not mark license files as %doc (bsc#1082318)
  • Typo in description of libnghttp2_asio1 (bsc#962914)
  • Fixed mistake in spec file (bsc#1125689)
  • Fixed build issue with boost 1.70.0 (bsc#1134616)
  • Fixed build issue with GCC 6 (bsc#964140)
  • Feature: Add W&S module (FATE#326776, bsc#1112438)
Record
SUSE-SU-2021:0932-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
nghttp2
Debian:12
before 1.7.1-1
1.7.1-1
nghttp2
Debian:13
before 1.7.1-1
1.7.1-1
nghttp2
Debian:14
before 1.7.1-1
1.7.1-1
nghttp2
SUSE:HPE Helion OpenStack 8
From an advisory covering 5 CVEs
before 1.39.2-3.5.1
1.39.2-3.5.1
nghttp2
SUSE:OpenStack Cloud 7
From an advisory covering 5 CVEs
before 1.39.2-3.5.1
1.39.2-3.5.1
nghttp2
SUSE:OpenStack Cloud 8
From an advisory covering 5 CVEs
before 1.39.2-3.5.1
1.39.2-3.5.1
nghttp2
SUSE:OpenStack Cloud 9
From an advisory covering 5 CVEs
before 1.39.2-3.5.1
1.39.2-3.5.1
nghttp2
SUSE:OpenStack Cloud Crowbar 8
From an advisory covering 5 CVEs
before 1.39.2-3.5.1
1.39.2-3.5.1
nghttp2
SUSE:OpenStack Cloud Crowbar 9
From an advisory covering 5 CVEs
before 1.39.2-3.5.1
1.39.2-3.5.1
nghttp2
SUSE:Linux Enterprise Server for SAP Applications 12 SP2
From an advisory covering 5 CVEs
before 1.39.2-3.5.1
1.39.2-3.5.1
Show 10 moreShow less
Affected packages
PackageAffectedFixed
nghttp2
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
From an advisory covering 5 CVEs
before 1.39.2-3.5.1
1.39.2-3.5.1
nghttp2
SUSE:Linux Enterprise Server for SAP Applications 12 SP4
From an advisory covering 5 CVEs
before 1.39.2-3.5.1
1.39.2-3.5.1
nghttp2
SUSE:Linux Enterprise Server 12 SP2-LTSS
From an advisory covering 5 CVEs
before 1.39.2-3.5.1
1.39.2-3.5.1
nghttp2
SUSE:Linux Enterprise Server 12 SP2-BCL
From an advisory covering 5 CVEs
before 1.39.2-3.5.1
1.39.2-3.5.1
nghttp2
SUSE:Linux Enterprise Server 12 SP3-LTSS
From an advisory covering 5 CVEs
before 1.39.2-3.5.1
1.39.2-3.5.1
nghttp2
SUSE:Linux Enterprise Server 12 SP3-BCL
From an advisory covering 5 CVEs
before 1.39.2-3.5.1
1.39.2-3.5.1
nghttp2
SUSE:Linux Enterprise Server 12 SP4-LTSS
From an advisory covering 5 CVEs
before 1.39.2-3.5.1
1.39.2-3.5.1
nghttp2
SUSE:Linux Enterprise Server 12 SP5
From an advisory covering 5 CVEs
before 1.39.2-3.5.1
1.39.2-3.5.1
nghttp2
SUSE:Linux Enterprise Server for SAP Applications 12 SP5
From an advisory covering 5 CVEs
before 1.39.2-3.5.1
1.39.2-3.5.1
nghttp2
openSUSE:Tumbleweed
before 1.17.0-1.1
1.17.0-1.1

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-1544 is a low vulnerability (CVSS 3.3) in Nghttp2, published February 6, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.89%, the 59th percentile. Fixed in nghttp2 1.7.1-1.

References

Show 22 moreShow less
MoveEnter Open