CVE-2016-1601
yast2-users before 3.1.47, as used in SUSE Linux Enterprise 12 SP1, does not properly set empty...
yast2-users before 3.1.47, as used in SUSE Linux Enterprise 12 SP1, does not properly set empty password fields in /etc/shadow during an AutoYaST installation when the profile does not contain inst-sys users, which might allow attackers to have unspecified impact via unknown vectors.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
yast2-users before 3.1.47, as used in SUSE Linux Enterprise 12 SP1, does not properly set empty password fields in /etc/shadow during an AutoYaST installation when the profile does not contain inst-sys users, which might allow attackers to have unspecified impact via unknown vectors.
- Record
CVE-2016-1601- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-255
- Updated
- 2026-11-02
CVE List No score
yast2-users before 3.1.47, as used in SUSE Linux Enterprise 12 SP1, does not properly set empty password fields in /etc/shadow during an AutoYaST installation when the profile does not contain inst-sys users, which might allow attackers to have unspecified impact via unknown vectors.
- Record
CVE-2016-1601- Updated
- 2026-11-02
EUVDEUVD-2016-2696 No score
yast2-users before 3.1.47, as used in SUSE Linux Enterprise 12 SP1, does not properly set empty password fields in /etc/shadow during an AutoYaST installation when the profile does not contain inst-sys users, which might allow attackers to have unspecified impact via unknown vectors.
- Record
EUVD-2016-2696- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m3qr-hrgx-v5ph
9.8
yast2-users before 3.1.47, as used in SUSE Linux Enterprise 12 SP1, does not properly set empty...
yast2-users before 3.1.47, as used in SUSE Linux Enterprise 12 SP1, does not properly set empty password fields in /etc/shadow during an AutoYaST installation when the profile does not contain inst-sys users, which might allow attackers to have unspecified impact via unknown vectors.
- Record
GHSA-m3qr-hrgx-v5ph- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10149-1 No score
yast2-users-3.2.6-1.1 on GA media
These are all security issues fixed in the yast2-users-3.2.6-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10149-1- Updated
- 2026-11-02
OSVSUSE-SU-2016:1138-1 No score
Security update for yast2-users
yast2-users was updated to fix one security issue.
This security issue was fixed:
- CVE-2016-1601: Empty passwords fields in /etc/shadow after SLES 12 SP1 autoyast installation (bsc#974220).
This update includes a script that fixes installations that we're affected by this problem. It is run automatically upon installing the update.
This non-security issue was fixed:
- bsc#971804: Set root password correctly when using a minimal profile
- Record
SUSE-SU-2016:1138-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
yast2-usersSUSE:Linux Enterprise Desktop 12 SP1 |
before 3.1.41.3-9.1 | 3.1.41.3-9.1 |
yast2-usersSUSE:Linux Enterprise Software Development Kit 12 SP1 |
before 3.1.41.3-9.1 | 3.1.41.3-9.1 |
yast2-usersSUSE:Linux Enterprise Server 12 SP1 |
before 3.1.41.3-9.1 | 3.1.41.3-9.1 |
yast2-usersSUSE:Linux Enterprise Server for SAP Applications 12 SP1 |
before 3.1.41.3-9.1 | 3.1.41.3-9.1 |
yast2-usersopenSUSE:Tumbleweed |
before 3.2.6-1.1 | 3.2.6-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-1601 is a critical vulnerability (CVSS 9.8) in Suse Yast2, published April 25, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.46%, the 84th percentile. Fixed in yast2-users 3.1.41.3-9.1.