Every CVE Search/ Get API key

CVE-2016-1696

The extensions subsystem in Google Chrome before 51.0.2704.79 does not properly restrict bindings...

8.8 HighFix available

The extensions subsystem in Google Chrome before 51.0.2704.79 does not properly restrict bindings access, which allows remote attackers to bypass the Same Origin Policy via unspecified vectors.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.23%Down 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

The extensions subsystem in Google Chrome before 51.0.2704.79 does not properly restrict bindings access, which allows remote attackers to bypass the Same Origin Policy via unspecified vectors.

Record
CVE-2016-1696
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-254, CWE-284
Updated
2026-11-02
CVE List No score

The extensions subsystem in Google Chrome before 51.0.2704.79 does not properly restrict bindings access, which allows remote attackers to bypass the Same Origin Policy via unspecified vectors.

Record
CVE-2016-1696
Updated
2026-11-02
EUVDEUVD-2016-2791 No score

The extensions subsystem in Google Chrome before 51.0.2704.79 does not properly restrict bindings access, which allows remote attackers to bypass the Same Origin Policy via unspecified vectors.

Record
EUVD-2016-2791
Updated
2026-11-03
GitHub AdvisoriesGHSA-3r8m-9qvw-p5fw 8.8

The extensions subsystem in Google Chrome before 51.0.2704.79 does not properly restrict bindings...

The extensions subsystem in Google Chrome before 51.0.2704.79 does not properly restrict bindings access, which allows remote attackers to bypass the Same Origin Policy via unspecified vectors.

Record
GHSA-3r8m-9qvw-p5fw
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-1696 8.8

The extensions subsystem in Google Chrome before 51.0.2704.79 does not properly restrict bindings access, which allows remote attackers to bypass the Same Origin Policy via unspecified vectors.

Record
UBUNTU-CVE-2016-1696
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2016-0218 No score

Updated chromium-browser-stable/libpng packages fix security vulnerability

Chromium-browser-stable 51.0.2704.79 fixes security issues: cross-origin bypass problems in extension bindings (CVE-2016-1696) and blink (CVE-2016-1697), an information leak in extension bindings (CVE-2016-1698), a parameter sanitization failure in devtools (CVE-2016-1699), use-after-free bugs in extensions (CVE-2016-1700) and autofill (CVE-2016-1701), an out-of-bounds read in skia (CVE-2016-1702), and various fixes from upstream's internal audits, fuzzing, and other initiatives (CVE-2016-1703).

Record
MGASA-2016-0218
Updated
2026-11-02
OSVopenSUSE-SU-2024:10171-1 No score

chromedriver-55.0.2883.75-3.1 on GA media

These are all security issues fixed in the chromedriver-55.0.2883.75-3.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10171-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:12948-1 No score

ungoogled-chromium-113.0.5672.92-1.1 on GA media

These are all security issues fixed in the ungoogled-chromium-113.0.5672.92-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:12948-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
chromium-browser
Debian:8
From an advisory covering 8 CVEs
before 51.0.2704.79-1~deb8u1, plus listed versions
41.0.2272.118-142.0.2311.135-142.0.2311.135-1~deb8u142.0.2311.135-242.0.2311.90-1
Show 45 moreShow less
42.0.2311.90-1~deb8u142.0.2311.90-243.0.2357.124-143.0.2357.124-243.0.2357.124-343.0.2357.130-143.0.2357.65-143.0.2357.65-1~deb8u143.0.2357.81-144.0.2403.107-144.0.2403.107-244.0.2403.157-144.0.2403.89-144.0.2403.89-1~deb8u145.0.2454.101-145.0.2454.85-145.0.2454.85-1~deb8u146.0.2490.13-146.0.2490.71-146.0.2490.71-1~deb8u147.0.2526.111-147.0.2526.16-147.0.2526.73-147.0.2526.73-1~deb8u147.0.2526.80-147.0.2526.80-1~deb8u147.0.2526.80-247.0.2526.80-348.0.2564.116-148.0.2564.116-1~deb8u148.0.2564.23-148.0.2564.82-148.0.2564.82-1~deb8u148.0.2564.82-249.0.2623.108-149.0.2623.108-1~deb8u149.0.2623.108-249.0.2623.75-149.0.2623.75-1~deb8u149.0.2623.75-249.0.2623.87-149.0.2623.87-1~deb8u150.0.2661.75-150.0.2661.75-1~deb8u150.0.2661.75-2
51.0.2704.79-1~deb8u1
chromium-browser-stable
Mageia:5
From an advisory covering 8 CVEs
before 51.0.2704.79-1.mga5
51.0.2704.79-1.mga5
libpng
Mageia:5
From an advisory covering 8 CVEs
before 1.6.22-1.mga5
1.6.22-1.mga5
chromium-browser
Red Hat:rhel_extras:6
From an advisory covering 8 CVEs
before 0:51.0.2704.79-1.el6
0:51.0.2704.79-1.el6
chromium-browser-debuginfo
Red Hat:rhel_extras:6
From an advisory covering 8 CVEs
before 0:51.0.2704.79-1.el6
0:51.0.2704.79-1.el6
chromium-browser
Ubuntu:14.04:LTS
before 51.0.2704.79-0ubuntu0.14.04.1.1121, plus listed versions
29.0.1547.65-0ubuntu231.0.1650.63-0ubuntu1~20131204.132.0.1700.107-0ubuntu1~20140204.977.133.0.1750.152-0ubuntu1~pkg995.134.0.1847.116-0ubuntu2
Show 20 moreShow less
36.0.1985.125-0ubuntu1.14.04.0~pkg102937.0.2062.94-0ubuntu0.14.04.1~pkg104237.0.2062.120-0ubuntu0.14.04.1~pkg104938.0.2125.111-0ubuntu0.14.04.1.106139.0.2171.65-0ubuntu0.14.04.1.106440.0.2214.94-0ubuntu0.14.04.1.106840.0.2214.111-0ubuntu0.14.04.1.106941.0.2272.76-0ubuntu0.14.04.1.107643.0.2357.81-0ubuntu0.14.04.1.108943.0.2357.130-0ubuntu0.14.04.1.109244.0.2403.89-0ubuntu0.14.04.1.109545.0.2454.85-0ubuntu0.14.04.1.109745.0.2454.101-0ubuntu0.14.04.1.109947.0.2526.73-0ubuntu0.14.04.1.110647.0.2526.106-0ubuntu0.14.04.1.110748.0.2564.82-0ubuntu0.14.04.1.110848.0.2564.116-0ubuntu0.14.04.1.111149.0.2623.87-0ubuntu0.14.04.1.111249.0.2623.108-0ubuntu0.14.04.1.111350.0.2661.102-0ubuntu0.14.04.1.1117
51.0.2704.79-0ubuntu0.14.04.1.1121
chromium-browser
Ubuntu:16.04:LTS
before 51.0.2704.79-0ubuntu0.16.04.1.1242, plus listed versions
45.0.2454.101-0ubuntu1.120147.0.2526.73-0ubuntu1.121847.0.2526.106-0ubuntu1.122148.0.2564.82-0ubuntu1.122248.0.2564.116-0ubuntu1.122949.0.2623.87-0ubuntu1.123249.0.2623.108-0ubuntu1.123350.0.2661.102-0ubuntu0.16.04.1.1237
51.0.2704.79-0ubuntu0.16.04.1.1242
chromium
openSUSE:Tumbleweed
From an advisory covering 719 CVEs
before 55.0.2883.75-3.1
55.0.2883.75-3.1
chromium
openSUSE:Tumbleweed
From an advisory covering 2310 CVEs
before 113.0.5672.92-1.1
113.0.5672.92-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-1696 is a high vulnerability (CVSS 8.8) in Google Chrome, published June 4, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.23%, the 69th percentile. Fixed in chromium-browser 51.0.2704.79-0ubuntu0.14.04.1.1121.

References

Show 194 moreShow less
This page doesn't list everything

Left out here: 5 versions and 2,180 references. The JSON record has them.

MoveEnter Open