CVE-2016-1856
WebKit, as used in Apple iOS before 9.3.2, Safari before 9.1.1, and tvOS before 9.2.1, allows...
WebKit, as used in Apple iOS before 9.3.2, Safari before 9.1.1, and tvOS before 9.2.1, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-1854, CVE-2016-1855, and CVE-2016-1857.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
WebKit, as used in Apple iOS before 9.3.2, Safari before 9.1.1, and tvOS before 9.2.1, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-1854, CVE-2016-1855, and CVE-2016-1857.
- Record
CVE-2016-1856- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
WebKit, as used in Apple iOS before 9.3.2, Safari before 9.1.1, and tvOS before 9.2.1, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-1854, CVE-2016-1855, and CVE-2016-1857.
- Record
CVE-2016-1856- Updated
- 2026-11-02
EUVDEUVD-2016-2951 No score
WebKit, as used in Apple iOS before 9.3.2, Safari before 9.1.1, and tvOS before 9.2.1, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-1854, CVE-2016-1855, and CVE-2016-1857.
- Record
EUVD-2016-2951- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-p26q-77vf-4pcg
8.8
WebKit, as used in Apple iOS before 9.3.2, Safari before 9.1.1, and tvOS before 9.2.1, allows...
WebKit, as used in Apple iOS before 9.3.2, Safari before 9.1.1, and tvOS before 9.2.1, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-1854, CVE-2016-1855, and CVE-2016-1857.
- Record
GHSA-p26q-77vf-4pcg- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-1856
8.8
WebKit, as used in Apple iOS before 9.3.2, Safari before 9.1.1, and tvOS before 9.2.1, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-1854, CVE-2016-1855, and CVE-2016-1857.
- Record
UBUNTU-CVE-2016-1856- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2016-0294 No score
Updated webkit2 packages fix security vulnerability
The webkit2 package has been updated to version 2.12.4, fixing several security issues and other bugs.
- Record
MGASA-2016-0294- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10572-1 No score
libjavascriptcoregtk-4_0-18-2.14.2-2.1 on GA media
These are all security issues fixed in the libjavascriptcoregtk-4_0-18-2.14.2-2.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10572-1- Updated
- 2026-11-02
OSVUSN-3079-1 No score
webkit2gtk vulnerabilities
A large number of security issues were discovered in the WebKitGTK+ Web and JavaScript engines. If a user were tricked into viewing a malicious website, a remote attacker could exploit a variety of issues related to web browser security, including cross-site scripting attacks, denial of service attacks, and arbitrary code execution.
- Record
USN-3079-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
webkit2Mageia:5 |
before 2.12.4-1.mga5 | 2.12.4-1.mga5 |
webkit2gtkUbuntu:16.04:LTS |
before 2.12.5-0ubuntu0.16.04.1, plus listed versions 2.8.5+dfsg1-32.10.3+dfsg1-12.10.4+dfsg1-12.10.5-12.10.6-12.10.6-1ubuntu12.10.8-1ubuntu12.10.9-1ubuntu1 |
2.12.5-0ubuntu0.16.04.1 |
qtwebkit-opensource-srcUbuntu:16.04:LTS |
All versions, plus listed versions 5.4.2+dfsg-1ubuntu2.15.5.1+dfsg-2ubuntu1 |
None known |
qtwebkit-sourceUbuntu:16.04:LTS |
All versions, plus listed versions 2.3.2-0ubuntu102.3.2-0ubuntu11 |
None known |
webkitgtkUbuntu:16.04:LTS |
All versions, plus listed versions 2.4.9-2ubuntu22.4.10-0ubuntu12.4.11-0ubuntu0.1 |
None known |
gtk3openSUSE:Tumbleweed |
before 2.14.2-2.1 | 2.14.2-2.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-1856 is a high vulnerability (CVSS 8.8) in Apple Safari, published May 20, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.59%, the 85th percentile. Fixed in webkit2 2.12.4-1.mga5.
References
lists.apple.com/archives/security-announce/2016/May/msg00005.html
securitytracker.com/id/1035888
packetstormsecurity.com/files/137229/WebKitGTK-Code-Execution-Denial-Of-Service-Memory-Corruption.html
support.apple.com/HT206564
zerodayinitiative.com/advisories/ZDI-16-342
lists.apple.com/archives/security-announce/2016/May/msg00002.html
Show 39 moreShow less
support.apple.com/HT206565
securityfocus.com/archive/1/538522/100/0/threaded
support.apple.com/HT206568
lists.apple.com/archives/security-announce/2016/May/msg00001.html
nvd.nist.gov/vuln/detail/CVE-2016-1856
github.com/advisories/GHSA-p26q-77vf-4pcg
advisories.mageia.org/MGASA-2016-0294.html
bugs.mageia.org/show_bug.cgi?id=18597
webkitgtk.org/security/WSA-2016-0004.html
webkitgtk.org/security/WSA-2016-0005.html
webkitgtk.org/2016/03/22/webkitgtk2.12.0-released.html
webkitgtk.org/2016/04/14/webkitgtk2.12.1-released.html
webkitgtk.org/2016/04/28/webkitgtk2.12.2-released.html
webkitgtk.org/2016/05/24/webkitgtk2.12.3-released.html
webkitgtk.org/2016/05/24/webkitgtk2.12.4-released.html
ubuntu.com/security/CVE-2016-1856
ubuntu.com/security/notices/USN-3079-1
cve.org/CVERecord?id=CVE-2016-1856
ubuntu.com/security/CVE-2016-1854
ubuntu.com/security/CVE-2016-1857
ubuntu.com/security/CVE-2016-1858
ubuntu.com/security/CVE-2016-1859
ubuntu.com/security/CVE-2016-4583
ubuntu.com/security/CVE-2016-4585
ubuntu.com/security/CVE-2016-4586
ubuntu.com/security/CVE-2016-4588
ubuntu.com/security/CVE-2016-4589
ubuntu.com/security/CVE-2016-4590
ubuntu.com/security/CVE-2016-4591
ubuntu.com/security/CVE-2016-4622
ubuntu.com/security/CVE-2016-4623
ubuntu.com/security/CVE-2016-4624
ubuntu.com/security/CVE-2016-4651
suse.com/security/cve/CVE-2016-1856
suse.com/security/cve/CVE-2016-1857
suse.com/security/cve/CVE-2016-4590
suse.com/security/cve/CVE-2016-4591
suse.com/security/cve/CVE-2016-4622
suse.com/security/cve/CVE-2016-4624