CVE-2016-20018
Knex.js has a limited SQL injection vulnerability
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query.
- Record
CVE-2016-20018- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List No score
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query.
- Record
CVE-2016-20018- Updated
- 2026-11-02
EUVDEUVD-2022-7505 No score
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query.
- Record
EUVD-2022-7505- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4jv9-3563-23j3
7.5
Knex.js has a limited SQL injection vulnerability
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query. This vulnerability has been fixed in version 2.4.0.
- Record
GHSA-4jv9-3563-23j3- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-89
- Updated
- 2026-11-02
OSV
7.5
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query.
- Record
CVE-2016-20018- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-4jv9-3563-23j3
7.5
Knex.js has a limited SQL injection vulnerability
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query. This vulnerability has been fixed in version 2.4.0.
- Record
GHSA-4jv9-3563-23j3- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-89
- Updated
- 2026-11-02
OSVCLSA-2026-1774830252 No score
TuxCare security update for knex (1 CVE)
TuxCare rebuilt knex to address 1 CVE. Fixed in 0.95.15-tuxcare.1.
- Record
CLSA-2026-1774830252- Updated
- 2026-11-02
OSVROOT-APP-NPM-CVE-2016-20018 No score
CVE-2016-20018 in knex - Patched by Root
Root has patched CVE-2016-20018 in the knex package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-CVE-2016-20018- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
knexnpm |
before 2.4.0 | 2.4.0 |
knexTuxCare:npm |
0.95.15-tuxcare.0 up to 0.95.15-tuxcare.1, plus listed versions 0.95.15 |
0.95.15-tuxcare.1 |
knexRoot:npm |
before 0.20.15-aikido.2 | 0.20.15-aikido.20.95.15-aikido.10.95.15+aikido.2 |
@rootio/knexRoot:npm |
before 0.20.15-root.io.1 | 0.20.15-root.io.10.20.15-root.io.20.95.15-root.io.10.95.15+aikido.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-20018 is a high vulnerability (CVSS 7.5) in Knexjs Knex, published December 19, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.12%, the 66th percentile. Fixed in knex 2.4.0.