Every CVE Search/ Get API key

CVE-2016-2074

Buffer overflow in lib/flow.c in ovs-vswitchd in Open vSwitch 2.2.x and 2.3.x before 2.3.3 and 2...

9.8 CriticalFix available

Buffer overflow in lib/flow.c in ovs-vswitchd in Open vSwitch 2.2.x and 2.3.x before 2.3.3 and 2.4.x before 2.4.1 allows remote attackers to execute arbitrary code via crafted MPLS packets, as demonstrated by a long string in an ovs-appctl command.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

6.40%Down 3.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

Buffer overflow in lib/flow.c in ovs-vswitchd in Open vSwitch 2.2.x and 2.3.x before 2.3.3 and 2.4.x before 2.4.1 allows remote attackers to execute arbitrary code via crafted MPLS packets, as demonstrated by a long string in an ovs-appctl command.

Record
CVE-2016-2074
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in lib/flow.c in ovs-vswitchd in Open vSwitch 2.2.x and 2.3.x before 2.3.3 and 2.4.x before 2.4.1 allows remote attackers to execute arbitrary code via crafted MPLS packets, as demonstrated by a long string in an ovs-appctl command.

Record
CVE-2016-2074
Updated
2026-11-02
EUVDEUVD-2016-3179 No score

Buffer overflow in lib/flow.c in ovs-vswitchd in Open vSwitch 2.2.x and 2.3.x before 2.3.3 and 2.4.x before 2.4.1 allows remote attackers to execute arbitrary code via crafted MPLS packets, as demonstrated by a long string in an ovs-appctl command.

Record
EUVD-2016-3179
Updated
2026-11-03
GitHub AdvisoriesGHSA-xfh5-4xfg-3g5f 9.8

Buffer overflow in lib/flow.c in ovs-vswitchd in Open vSwitch 2.2.x and 2.3.x before 2.3.3 and 2...

Buffer overflow in lib/flow.c in ovs-vswitchd in Open vSwitch 2.2.x and 2.3.x before 2.3.3 and 2.4.x before 2.4.1 allows remote attackers to execute arbitrary code via crafted MPLS packets, as demonstrated by a long string in an ovs-appctl command.

Record
GHSA-xfh5-4xfg-3g5f
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 9.8

Buffer overflow in lib/flow.c in ovs-vswitchd in Open vSwitch 2.2.x and 2.3.x before 2.3.3 and 2.4.x before 2.4.1 allows remote attackers to execute arbitrary code via crafted MPLS packets, as demonstrated by a long string in an ovs-appctl command.

Record
CVE-2016-2074
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-2074 9.8

Buffer overflow in lib/flow.c in ovs-vswitchd in Open vSwitch 2.2.x and 2.3.x before 2.3.3 and 2.4.x before 2.4.1 allows remote attackers to execute arbitrary code via crafted MPLS packets, as demonstrated by a long string in an ovs-appctl command.

Record
DEBIAN-CVE-2016-2074
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-2074 9.8

Buffer overflow in lib/flow.c in ovs-vswitchd in Open vSwitch 2.2.x and 2.3.x before 2.3.3 and 2.4.x before 2.4.1 allows remote attackers to execute arbitrary code via crafted MPLS packets, as demonstrated by a long string in an ovs-appctl command.

Record
UBUNTU-CVE-2016-2074
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openvswitch
Debian:12
before 2.3.0+git20140819-4
2.3.0+git20140819-4
openvswitch
Debian:13
before 2.3.0+git20140819-4
2.3.0+git20140819-4
openvswitch
Debian:14
before 2.3.0+git20140819-4
2.3.0+git20140819-4
openvswitch
Debian:8
before 2.3.0+git20140819-3+deb8u1, plus listed versions
2.3.0+git20140819-3
2.3.0+git20140819-3+deb8u1
openvswitch
Red Hat:openstack:5::el7
before 0:2.4.0-2.el7_2
0:2.4.0-2.el7_2
openvswitch-debuginfo
Red Hat:openstack:5::el7
before 0:2.4.0-2.el7_2
0:2.4.0-2.el7_2
python-openvswitch
Red Hat:openstack:5::el7
before 0:2.4.0-2.el7_2
0:2.4.0-2.el7_2
openvswitch
Red Hat:openstack:6::el7
before 0:2.4.0-2.el7_2
0:2.4.0-2.el7_2
openvswitch-debuginfo
Red Hat:openstack:6::el7
before 0:2.4.0-2.el7_2
0:2.4.0-2.el7_2
python-openvswitch
Red Hat:openstack:6::el7
before 0:2.4.0-2.el7_2
0:2.4.0-2.el7_2
Show 10 moreShow less
Affected packages
PackageAffectedFixed
openvswitch
Red Hat:openstack:7::el7
before 0:2.4.0-2.el7_2
0:2.4.0-2.el7_2
openvswitch-debuginfo
Red Hat:openstack:7::el7
before 0:2.4.0-2.el7_2
0:2.4.0-2.el7_2
openvswitch-dpdk
Red Hat:openstack:7::el7
before 0:2.4.0-0.10346.git97bab959.3.el7_2
0:2.4.0-0.10346.git97bab959.3.el7_2
openvswitch-dpdk-debuginfo
Red Hat:openstack:7::el7
before 0:2.4.0-0.10346.git97bab959.3.el7_2
0:2.4.0-0.10346.git97bab959.3.el7_2
python-openvswitch
Red Hat:openstack:7::el7
before 0:2.4.0-2.el7_2
0:2.4.0-2.el7_2
openvswitch
Red Hat:openshift:3.1::el7
before 0:2.4.0-2.el7_2
0:2.4.0-2.el7_2
openvswitch-debuginfo
Red Hat:openshift:3.1::el7
before 0:2.4.0-2.el7_2
0:2.4.0-2.el7_2
openvswitch-devel
Red Hat:openshift:3.1::el7
before 0:2.4.0-2.el7_2
0:2.4.0-2.el7_2
openvswitch-test
Red Hat:openshift:3.1::el7
before 0:2.4.0-2.el7_2
0:2.4.0-2.el7_2
python-openvswitch
Red Hat:openshift:3.1::el7
before 0:2.4.0-2.el7_2
0:2.4.0-2.el7_2

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-2074 is a critical vulnerability (CVSS 9.8) in Openvswitch, published March 28, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.40%, the 93rd percentile. Fixed in openvswitch 2.3.0+git20140819-4.

References

Show 19 moreShow less
MoveEnter Open