Every CVE Search/ Get API key

CVE-2016-2155

Moodle allows attackers to modify "Exclude grade" settings

4.3 MediumFix available

CVE-2016-2155 is a medium vulnerability (CVSS 4.3) in Moodle, published March 25, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.61%, the 75th percentile. Fixed in moodle/moodle 2.8.11.

The grade-reporting feature in Singleview (aka Single View) in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/grade:manage capability, which allows remote authenticated users to modify "Exclude grade" settings by leveraging the Non-Editing Instructor role.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

1.61%Up 0.5 points since Aug 1, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

The grade-reporting feature in Singleview (aka Single View) in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/grade:manage capability, which allows remote authenticated users to modify "Exclude grade" settings by leveraging the Non-Editing Instructor role.

Record
CVE-2016-2155
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:P/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

The grade-reporting feature in Singleview (aka Single View) in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/grade:manage capability, which allows remote authenticated users to modify "Exclude grade" settings by leveraging the Non-Editing Instructor role.

Record
CVE-2016-2155
Updated
2026-11-02
EUVDEUVD-2022-2083 No score

The grade-reporting feature in Singleview (aka Single View) in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/grade:manage capability, which allows remote authenticated users to modify "Exclude grade" settings by leveraging the Non-Editing Instructor role.

Record
EUVD-2022-2083
Updated
2026-11-03
GitHub AdvisoriesGHSA-32hg-73hp-vwc8 4.3

Moodle allows attackers to modify "Exclude grade" settings

The grade-reporting feature in Singleview (aka Single View) in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/grade:manage capability, which allows remote authenticated users to modify "Exclude grade" settings by leveraging the Non-Editing Instructor role.

Record
GHSA-32hg-73hp-vwc8
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSV 4.3

The grade-reporting feature in Singleview (aka Single View) in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/grade:manage capability, which allows remote authenticated users to modify "Exclude grade" settings by leveraging the Non-Editing Instructor role.

Record
CVE-2016-2155
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVGHSA-32hg-73hp-vwc8 4.3

Moodle allows attackers to modify "Exclude grade" settings

The grade-reporting feature in Singleview (aka Single View) in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/grade:manage capability, which allows remote authenticated users to modify "Exclude grade" settings by leveraging the Non-Editing Instructor role.

Record
GHSA-32hg-73hp-vwc8
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2016-2155 4.3

The grade-reporting feature in Singleview (aka Single View) in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/grade:manage capability, which allows remote authenticated users to modify "Exclude grade" settings by leveraging the Non-Editing Instructor role.

Record
UBUNTU-CVE-2016-2155
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVMGASA-2016-0122 No score

Updated moodle packages fix security vulnerability

In Moodle before 2.8.11, teachers who otherwise were not supposed to see students' emails could see them in the participants list (CVE-2016-2151).

In Moodle before 2.8.11, Moodle traditionally trusted content from external DB, however it was decided that external datasources may not be aware of web security practices and data could cause problems after importing to Moodle (CVE-2016-2152).

In Moodle before 2.8.11, a user with higher permissions could be tricked into clicking a link which would result in Reflected XSS in mod_data advanced search (CVE-2016-2153).

In Moodle before 2.8.11, users without capability to view hidden courses but with capability to subscribe to Event Monitor rules could see the names of hidden courses (CVE-2016-2154).

In Moodle before 2.8.11, the Non-Editing Instructor role can edit the exclude checkbox in the Single View grade report (CVE-2016-2155).

In Moodle before 2.8.11, users without the capability to view hidden acitivites could still see associated calendar events via web services, via the external function get_calendar_events (CVE-2016-2156).

In Moodle before 2.8.11, CSRF is possible on the Assignment plugin admin page, however an exploit is unlikely to benefit anybody and can easily be reversed (CVE-2016-2157).

In Moodle before 2.8.11, enumeration of course category details is possible without authentication (CVE-2016-2158).

In Moodle before 2.8.11, students were able to add assignment submissions after the due date through web service, via the external function mod_assign_save_submission (CVE-2016-2159).

In Moodle before 2.8.11, when following external links that were added with the _blank target, a referer header would be added (CVE-2016-2190).

Record
MGASA-2016-0122
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
2.8.0 up to 2.8.11
2.8.11
moodle/moodle
Packagist
2.9.0 up to 2.9.5
2.9.5
moodle/moodle
Packagist
3.0.0 up to 3.0.3
3.0.3
moodle/moodle
Packagist
2.8.0 up to 2.8.11, plus listed versions
v2.8.0v2.8.1v2.8.10v2.8.2v2.8.3
Show 6 moreShow less
v2.8.4v2.8.5v2.8.6v2.8.7v2.8.8v2.8.9
2.8.11
moodle/moodle
Packagist
2.9.0 up to 2.9.5, plus listed versions
v2.9.0v2.9.1v2.9.2v2.9.3v2.9.4
2.9.5
moodle/moodle
Packagist
3.0.0 up to 3.0.3, plus listed versions
v3.0.0v3.0.1v3.0.2
3.0.3
moodle
Mageia:5
before 2.8.11-1.mga5
2.8.11-1.mga5
moodle
Ubuntu:16.04:LTS
before 3.0.3+dfsg-0ubuntu1, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-1
3.0.3+dfsg-0ubuntu1
moodle
Ubuntu:18.04:LTS
before 3.0.3+dfsg-0ubuntu1
3.0.3+dfsg-0ubuntu1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 24 moreShow less
MoveEnter Open