CVE-2016-2515
Regular Expression Denial of Service in hawk
Hawk before 3.1.3 and 4.x before 4.1.1 allow remote attackers to cause a denial of service (CPU consumption or partial outage) via a long (1) header or (2) URI that is matched against an improper regular expression.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
Hawk before 3.1.3 and 4.x before 4.1.1 allow remote attackers to cause a denial of service (CPU consumption or partial outage) via a long (1) header or (2) URI that is matched against an improper regular expression.
- Record
CVE-2016-2515- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 7.8 High
AV:N/AC:L/Au:N/C:N/I:N/A:C - Weakness
- CWE-399
- Updated
- 2026-11-02
CVE List No score
Hawk before 3.1.3 and 4.x before 4.1.1 allow remote attackers to cause a denial of service (CPU consumption or partial outage) via a long (1) header or (2) URI that is matched against an improper regular expression.
- Record
CVE-2016-2515- Updated
- 2026-11-02
EUVDEUVD-2018-0286 No score
Hawk before 3.1.3 and 4.x before 4.1.1 allow remote attackers to cause a denial of service (CPU consumption or partial outage) via a long (1) header or (2) URI that is matched against an improper regular expression.
- Record
EUVD-2018-0286- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jcpv-g9rr-qxrc
7.5
Regular Expression Denial of Service in hawk
Versions of hawk prior to 3.1.3, or 4.x prior to 4.1.1 are affected by a regular expression denial of service vulnerability related to excessively long headers and URI's.
Recommendation
Update to hawk version 4.1.1 or later.
- Record
GHSA-jcpv-g9rr-qxrc- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-1333
- Updated
- 2026-11-02
OSV
7.5
Hawk before 3.1.3 and 4.x before 4.1.1 allow remote attackers to cause a denial of service (CPU consumption or partial outage) via a long (1) header or (2) URI that is matched against an improper regular expression.
- Record
CVE-2016-2515- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-jcpv-g9rr-qxrc
7.5
Regular Expression Denial of Service in hawk
Versions of hawk prior to 3.1.3, or 4.x prior to 4.1.1 are affected by a regular expression denial of service vulnerability related to excessively long headers and URI's.
Recommendation
Update to hawk version 4.1.1 or later.
- Record
GHSA-jcpv-g9rr-qxrc- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-1333
- Updated
- 2026-11-02
Show 5 moreShow less
OSVCLSA-2026-1772583205 No score
TuxCare security update for hawk (2 CVEs)
TuxCare rebuilt hawk to address 2 CVEs. Fixed in 2.3.1-tuxcare.1.
- Record
CLSA-2026-1772583205- Updated
- 2026-11-02
OSVCLSA-2026-1773015258 No score
TuxCare security update for hawk (2 CVEs)
TuxCare rebuilt hawk to address 2 CVEs. Fixed in 3.1.0-tuxcare.1.
- Record
CLSA-2026-1773015258- Updated
- 2026-11-02
OSVCLSA-2026-1774743811 No score
TuxCare security update for hawk (2 CVEs)
TuxCare rebuilt hawk to address 2 CVEs. Fixed in 0.13.1-tuxcare.1.
- Record
CLSA-2026-1774743811- Updated
- 2026-11-02
OSVCLSA-2026-1774743812 No score
TuxCare security update for hawk (2 CVEs)
TuxCare rebuilt hawk to address 2 CVEs. Fixed in 1.0.0-tuxcare.1.
- Record
CLSA-2026-1774743812- Updated
- 2026-11-02
OSVCLSA-2026-1774743813 No score
TuxCare security update for hawk (2 CVEs)
TuxCare rebuilt hawk to address 2 CVEs. Fixed in 1.1.1-tuxcare.1.
- Record
CLSA-2026-1774743813- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
hawknpm |
before 3.1.3 | 3.1.3 |
hawknpm |
4.0.0 up to 4.1.1 | 4.1.1 |
hawkTuxCare:npm |
2.3.1-tuxcare.0 up to 2.3.1-tuxcare.1, plus listed versions 2.3.1 |
2.3.1-tuxcare.1 |
hawkTuxCare:npm |
3.1.0-tuxcare.0 up to 3.1.0-tuxcare.1, plus listed versions 3.1.0 |
3.1.0-tuxcare.1 |
hawkTuxCare:npm |
0.13.1-tuxcare.0 up to 0.13.1-tuxcare.1, plus listed versions 0.13.1 |
0.13.1-tuxcare.1 |
hawkTuxCare:npm |
1.0.0-tuxcare.0 up to 1.0.0-tuxcare.1, plus listed versions 1.0.0 |
1.0.0-tuxcare.1 |
hawkTuxCare:npm |
1.1.1-tuxcare.0 up to 1.1.1-tuxcare.1, plus listed versions 1.1.1 |
1.1.1-tuxcare.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-2515 is a high vulnerability (CVSS 7.5) in Hawk Project Hawk, published April 13, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.37%, the 88th percentile. Fixed in hawk 3.1.3.