CVE-2016-2563
Stack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6...
Stack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6.3 and earlier allows remote servers to cause a denial of service (stack memory corruption) or execute arbitrary code via a crafted SCP-SINK file-size response to an SCP download request.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Stack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6.3 and earlier allows remote servers to cause a denial of service (stack memory corruption) or execute arbitrary code via a crafted SCP-SINK file-size response to an SCP download request.
- Record
CVE-2016-2563- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Stack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6.3 and earlier allows remote servers to cause a denial of service (stack memory corruption) or execute arbitrary code via a crafted SCP-SINK file-size response to an SCP download request.
- Record
CVE-2016-2563- Updated
- 2026-11-02
EUVDEUVD-2016-3637 No score
Stack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6.3 and earlier allows remote servers to cause a denial of service (stack memory corruption) or execute arbitrary code via a crafted SCP-SINK file-size response to an SCP download request.
- Record
EUVD-2016-3637- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4hmm-v4j9-3hw2
9.8
Stack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6...
Stack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6.3 and earlier allows remote servers to cause a denial of service (stack memory corruption) or execute arbitrary code via a crafted SCP-SINK file-size response to an SCP download request.
- Record
GHSA-4hmm-v4j9-3hw2- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
9.8
Stack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6.3 and earlier allows remote servers to cause a denial of service (stack memory corruption) or execute arbitrary code via a crafted SCP-SINK file-size response to an SCP download request.
- Record
CVE-2016-2563- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-2563
9.8
Stack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6.3 and earlier allows remote servers to cause a denial of service (stack memory corruption) or execute arbitrary code via a crafted SCP-SINK file-size response to an SCP download request.
- Record
DEBIAN-CVE-2016-2563- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-2563
9.8
Stack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6.3 and earlier allows remote servers to cause a denial of service (stack memory corruption) or execute arbitrary code via a crafted SCP-SINK file-size response to an SCP download request.
- Record
UBUNTU-CVE-2016-2563- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2016-0112 No score
Updated putty packages fix CVE-2016-2563
Updated putty package fixes security vulnerability:
Many versions of PSCP in PuTTY prior to 0.67 have a stack corruption vulnerability in their treatment of the 'sink' direction (i.e. downloading from server to client) of the old-style SCP protocol. In order for this vulnerability to be exploited, the user must connect to a malicious server and attempt to download any file (CVE-2016-2563).
The putty package has been updated to version 0.67 to fix this issue and a few other bugs. The halibut package has been updated to version 1.1 to build the documentation.
- Record
MGASA-2016-0112- Updated
- 2026-11-02
OSVMGASA-2016-0118 No score
Updated filezilla packages fix security vulnerability
Many versions of PSCP in PuTTY prior to 0.67 have a stack corruption vulnerability in their treatment of the 'sink' direction (i.e. downloading from server to client) of the old-style SCP protocol. In order for this vulnerability to be exploited, the user must connect to a malicious server and attempt to download any file (CVE-2016-2563).
FileZilla was vulnerable to this issue as it bundles a copy of PuTTY. The filezilla package has been updated to version 3.16.1, which fixes this issue and has many other fixes and enhancements.
- Record
MGASA-2016-0118- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
puttyDebian:12 |
before 0.67-1 | 0.67-1 |
puttyDebian:13 |
before 0.67-1 | 0.67-1 |
puttyDebian:14 |
before 0.67-1 | 0.67-1 |
halibutMageia:5 |
before 1.1-2.mga5 | 1.1-2.mga5 |
puttyMageia:5 |
before 0.67-1.mga5 | 0.67-1.mga5 |
filezillaMageia:5 |
before 3.16.1-1.mga5 | 3.16.1-1.mga5 |
libfilezillaMageia:5 |
before 0.4.0.1-1.mga5 | 0.4.0.1-1.mga5 |
pugixmlMageia:5 |
before 1.7-1.mga5 | 1.7-1.mga5 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Putty pscp 0.66 - Stack Buffer Overwrite | 2016-03-10 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-2563 is a critical vulnerability (CVSS 9.8) in 9bis Kitty, published March 16, 2016. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 32.8%, the 98th percentile. Fixed in putty 0.67-1.
References
lists.opensuse.org/opensuse-updates/2016-05/msg00131.html
securitytracker.com/id/1035257
security.gentoo.org/glsa/201606-01
securityfocus.com/bid/84296
chiark.greenend.org.uk/~sgtatham/putty/wishlist/vuln-pscp-sink-sscanf.html
github.com/tintinweb/pub/tree/master/pocs/cve-2016-2563
Show 13 moreShow less
seclists.org/fulldisclosure/2016/Mar/22
nvd.nist.gov/vuln/detail/CVE-2016-2563
github.com/advisories/GHSA-4hmm-v4j9-3hw2
security-tracker.debian.org/tracker/CVE-2016-2563
advisories.mageia.org/MGASA-2016-0112.html
bugs.mageia.org/show_bug.cgi?id=17942
chiark.greenend.org.uk/~sgtatham/putty/changes.html
advisories.mageia.org/MGASA-2016-0118.html
bugs.mageia.org/show_bug.cgi?id=17943
filezilla-project.org
ubuntu.com/security/CVE-2016-2563
tartarus.org/~simon-git/gitweb?p=putty.git;a=commitdiff;h=bc6c15ab5f636e05b7e91883f0031a7e06117947
cve.org/CVERecord?id=CVE-2016-2563