CVE-2016-3090
Apache Struts RCE Vulnerability
The TextParseUtil.translateVariables method in Apache Struts 2.x before 2.3.20 allows remote attackers to execute arbitrary code via a crafted OGNL expression with ANTLR tooling.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
The TextParseUtil.translateVariables method in Apache Struts 2.x before 2.3.20 allows remote attackers to execute arbitrary code via a crafted OGNL expression with ANTLR tooling.
- Record
CVE-2016-3090- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
The TextParseUtil.translateVariables method in Apache Struts 2.x before 2.3.20 allows remote attackers to execute arbitrary code via a crafted OGNL expression with ANTLR tooling.
- Record
CVE-2016-3090- Updated
- 2026-11-02
EUVDEUVD-2022-3954 No score
The TextParseUtil.translateVariables method in Apache Struts 2.x before 2.3.20 allows remote attackers to execute arbitrary code via a crafted OGNL expression with ANTLR tooling.
- Record
EUVD-2022-3954- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-ggmp-fxfg-277r
8.8
Apache Struts RCE Vulnerability
The TextParseUtil.translateVariables method in Apache Struts 2.x before 2.3.20 allows remote attackers to execute arbitrary code via a crafted OGNL expression with ANTLR tooling.
- Record
GHSA-ggmp-fxfg-277r- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
8.8
The TextParseUtil.translateVariables method in Apache Struts 2.x before 2.3.20 allows remote attackers to execute arbitrary code via a crafted OGNL expression with ANTLR tooling.
- Record
CVE-2016-3090- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-ggmp-fxfg-277r
8.8
Apache Struts RCE Vulnerability
The TextParseUtil.translateVariables method in Apache Struts 2.x before 2.3.20 allows remote attackers to execute arbitrary code via a crafted OGNL expression with ANTLR tooling.
- Record
GHSA-ggmp-fxfg-277r- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.struts:struts2-parentMaven |
2.0.0 up to 2.3.20 | 2.3.20 |
org.apache.struts:struts2-parentMaven |
2.0.0 up to 2.3.20, plus listed versions 2.0.112.0.11.12.0.11.22.0.122.0.14 Show 33 moreShow less2.0.52.0.62.0.82.0.92.1.22.1.62.1.82.1.8.12.2.12.2.1.12.2.32.2.3.12.3.12.3.1.12.3.1.22.3.122.3.142.3.14.12.3.14.22.3.14.32.3.152.3.15.12.3.15.22.3.15.32.3.162.3.16.12.3.16.22.3.16.32.3.32.3.42.3.4.12.3.72.3.8 |
2.3.20 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-3090 is a high vulnerability (CVSS 8.8) in Apache Struts, published October 30, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.71%, the 93rd percentile. Fixed in org.apache.struts:struts2-parent 2.3.20.
References
securityfocus.com/bid/85131
struts.apache.org/docs/s2-027.html
securitytracker.com/id/1035267
security.netapp.com/advisory/ntap-20180629-0005
nvd.nist.gov/vuln/detail/CVE-2016-3090
web.archive.org/web/20210123095942/http://www.securityfocus.com/bid/85131
web.archive.org/web/20211206100940/https://www.securitytracker.com/id/1035267
github.com/advisories/GHSA-ggmp-fxfg-277r
github.com/apache/struts