Every CVE Search/ Get API key

CVE-2016-3098

administrate vulnerable to Cross-Site Request Forgery

5.4 MediumFix available

CVE-2016-3098 is a medium vulnerability (CVSS 5.4) in Thoughtbot Administrate, published August 5, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.37%, the 30th percentile. Fixed in administrate 0.1.5.

Cross-site request forgery (CSRF) vulnerability in administrate 0.1.4 and earlier allows remote attackers to hijack the user's OAuth autorization code.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.37%Down 0.7 points since Aug 6, 2022
90%50%10%1%

What each source reports

NVD Score used 5.4

Cross-site request forgery (CSRF) vulnerability in administrate 0.1.4 and earlier allows remote attackers to hijack the user's OAuth autorization code.

Record
CVE-2016-3098
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Weakness
CWE-352
Updated
2026-11-02
CVE List No score

Cross-site request forgery (CSRF) vulnerability in administrate 0.1.4 and earlier allows remote attackers to hijack the user's OAuth autorization code.

Record
CVE-2016-3098
Weakness
CWE-352
Updated
2026-11-02
EUVDEUVD-2022-6534 No score

Cross-site request forgery (CSRF) vulnerability in administrate 0.1.4 and earlier allows remote attackers to hijack the user's OAuth autorization code.

Record
EUVD-2022-6534
Updated
2026-11-03
GitHub AdvisoriesGHSA-cc8c-26rj-v2vx 5.4

administrate vulnerable to Cross-Site Request Forgery

Cross-site request forgery (CSRF) vulnerability in administrate 0.1.4 and earlier allows remote attackers to hijack the user's OAuth autorization code.

Record
GHSA-cc8c-26rj-v2vx
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Weakness
CWE-352
Updated
2026-11-02
OSV 5.4

Cross-site request forgery (CSRF) vulnerability in administrate 0.1.4 and earlier allows remote attackers to hijack the user's OAuth autorization code.

Record
CVE-2016-3098
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-cc8c-26rj-v2vx 5.4

administrate vulnerable to Cross-Site Request Forgery

Cross-site request forgery (CSRF) vulnerability in administrate 0.1.4 and earlier allows remote attackers to hijack the user's OAuth autorization code.

Record
GHSA-cc8c-26rj-v2vx
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Weakness
CWE-352
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
administrate
RubyGems
before 0.1.5
0.1.5
administrate
RubyGems
before 0.1.5, plus listed versions
0.0.100.0.110.0.120.0.20.0.3
Show 10 moreShow less
0.0.40.0.60.0.70.0.80.0.90.1.00.1.10.1.20.1.30.1.4
0.1.5

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open