Every CVE Search/ Get API key

CVE-2016-3105

Mercurial vulnerable to arbitrary code execution when converting Git repos

8.8 HighFix available

CVE-2016-3105 is a high vulnerability (CVSS 8.8) in Mercurial, published May 5, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.75%, the 86th percentile. Fixed in mercurial 3.8.

The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.75%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.

Record
CVE-2016-3105
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-284
Updated
2026-11-02
CVE List No score

The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.

Record
CVE-2016-3105
Updated
2026-11-02
EUVDEUVD-2016-0016 No score

The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.

Record
EUVD-2016-0016
Updated
2026-11-03
GitHub AdvisoriesGHSA-49cw-434h-qc57 8.7

Mercurial vulnerable to arbitrary code execution when converting Git repos

The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.

Record
GHSA-49cw-434h-qc57
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-284
Updated
2026-11-02
OSV 8.8

The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.

Record
CVE-2016-3105
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-3105 8.8

The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.

Record
DEBIAN-CVE-2016-3105
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 7 moreShow less
OSVGHSA-49cw-434h-qc57 8.7

Mercurial vulnerable to arbitrary code execution when converting Git repos

The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.

Record
GHSA-49cw-434h-qc57
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-284
Updated
2026-11-02
OSVUBUNTU-CVE-2016-3105 8.8

The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.

Record
UBUNTU-CVE-2016-3105
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2016-0172 No score

Updated mercurial packages fix security vulnerability

This update fixes possible arbitrary code execution when converting Git repos. Mercurial prior to 3.8 allowed arbitrary code execution when using the convert extension on Git repos with hostile names. This could affect automated code conversion services that allow arbitrary repository names. This is a further side-effect of Git CVE-2015-7545. Reported and fixed by Blake Burkhart.

Record
MGASA-2016-0172
Updated
2026-11-02
OSVopenSUSE-SU-2024:10070-1 No score

mercurial-4.0-1.1 on GA media

These are all security issues fixed in the mercurial-4.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10070-1
Updated
2026-11-02
OSVPYSEC-2016-28 No score

The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.

Record
PYSEC-2016-28
Updated
2026-11-02
OSVSUSE-SU-2016:1442-1 No score

Security update for mercurial

This update for mercurial fixes the following issues:

Security issues fixed:

  • CVE-2016-3105: Versionsprior to 3.8 allowed arbitrary code execution when using the convert extension on Git repo. (bsc#978391)
Record
SUSE-SU-2016:1442-1
Updated
2026-11-02
OSVSUSE-SU-2016:1443-1 No score

Security update for mercurial

This update for mercurial fixes the following issues:

Security issues fixed:

  • CVE-2016-3105: Versionsprior to 3.8 allowed arbitrary code execution when using the convert extension on Git repo. (bsc#978391)
Record
SUSE-SU-2016:1443-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mercurial
PyPI
before 3.8
3.8
mercurial
Debian:12
before 3.8.1-1
3.8.1-1
mercurial
Debian:13
before 3.8.1-1
3.8.1-1
mercurial
Debian:14
before 3.8.1-1
3.8.1-1
mercurial
Debian:7
before 2.2.2-4+deb7u3, plus listed versions
2.2.2-32.2.2-42.2.2-4+deb7u12.2.2-4+deb7u2
2.2.2-4+deb7u3
mercurial
Debian:8
before 3.1.2-2+deb8u3, plus listed versions
3.1.2-23.1.2-2+deb8u13.1.2-2+deb8u2
3.1.2-2+deb8u3
mercurial
PyPI
before 3.8, plus listed versions
0.8.10.90.9.10.9.20.9.3
Show 45 moreShow less
0.9.40.9.51.01.0.11.0.21.11.1.11.1.21.21.2.11.31.3.11.41.4.11.4.21.4.31.51.5.11.5.21.5.31.5.41.61.6.11.6.21.6.31.6.41.71.7.11.7.21.7.31.7.51.81.8.11.8.21.8.31.8.41.91.9.11.9.21.9.32.02.0.12.0.22.12.1.1
3.8
mercurial
Mageia:5
before 3.1.1-5.2.mga5
3.1.1-5.2.mga5
mercurial
PyPI
before 3.8-rc, plus listed versions
0.8.10.90.9.10.9.20.9.3
Show 45 moreShow less
0.9.40.9.51.01.0.11.0.21.11.1.11.1.21.21.2.11.31.3.11.41.4.11.4.21.4.31.51.5.11.5.21.5.31.5.41.61.6.11.6.21.6.31.6.41.71.7.11.7.21.7.31.7.51.81.8.11.8.21.8.31.8.41.91.9.11.9.21.9.32.02.0.12.0.22.12.1.1
3.8-rc
mercurial
SUSE:Linux Enterprise Software Development Kit 12
before 2.8.2-9.1
2.8.2-9.1
Show 5 moreShow less
Affected packages
PackageAffectedFixed
mercurial
SUSE:Linux Enterprise Software Development Kit 12 SP1
before 2.8.2-9.1
2.8.2-9.1
mercurial
SUSE:Linux Enterprise Software Development Kit 11 SP4
before 2.3.2-0.14.2
2.3.2-0.14.2
mercurial
Ubuntu:14.04:LTS
before 2.8.2-1ubuntu1.4, plus listed versions
2.6.3-12.7.2-12.8.1-22.8.2-1ubuntu12.8.2-1ubuntu1.3
2.8.2-1ubuntu1.4
mercurial
Ubuntu:16.04:LTS
before 3.7.3-1ubuntu1.1, plus listed versions
3.4-1ubuntu23.6.2-1ubuntu23.7.3-1ubuntu1
3.7.3-1ubuntu1.1
mercurial
openSUSE:Tumbleweed
before 4.0-1.1
4.0-1.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 19 moreShow less
This page doesn't list everything

Left out here: 107 versions. The JSON record has them.

MoveEnter Open