Every CVE Search/ Get API key

CVE-2016-3125

The mod_tls module in ProFTPD before 1.3.5b and 1.3.6 before 1.3.6rc2 does not properly handle...

7.5 HighFix available

The mod_tls module in ProFTPD before 1.3.5b and 1.3.6 before 1.3.6rc2 does not properly handle the TLSDHParamFile directive, which might cause a weaker than intended Diffie-Hellman (DH) key to be used and consequently allow attackers to have unspecified impact via unknown vectors.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

6.98%Up 5.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The mod_tls module in ProFTPD before 1.3.5b and 1.3.6 before 1.3.6rc2 does not properly handle the TLSDHParamFile directive, which might cause a weaker than intended Diffie-Hellman (DH) key to be used and consequently allow attackers to have unspecified impact via unknown vectors.

Record
CVE-2016-3125
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-254, CWE-310
Updated
2026-11-02
CVE List No score

The mod_tls module in ProFTPD before 1.3.5b and 1.3.6 before 1.3.6rc2 does not properly handle the TLSDHParamFile directive, which might cause a weaker than intended Diffie-Hellman (DH) key to be used and consequently allow attackers to have unspecified impact via unknown vectors.

Record
CVE-2016-3125
Updated
2026-11-02
EUVDEUVD-2016-4177 No score

The mod_tls module in ProFTPD before 1.3.5b and 1.3.6 before 1.3.6rc2 does not properly handle the TLSDHParamFile directive, which might cause a weaker than intended Diffie-Hellman (DH) key to be used and consequently allow attackers to have unspecified impact via unknown vectors.

Record
EUVD-2016-4177
Updated
2026-11-03
GitHub AdvisoriesGHSA-j9wr-gwc4-26xh 7.5

The mod_tls module in ProFTPD before 1.3.5b and 1.3.6 before 1.3.6rc2 does not properly handle...

The mod_tls module in ProFTPD before 1.3.5b and 1.3.6 before 1.3.6rc2 does not properly handle the TLSDHParamFile directive, which might cause a weaker than intended Diffie-Hellman (DH) key to be used and consequently allow attackers to have unspecified impact via unknown vectors.

Record
GHSA-j9wr-gwc4-26xh
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSV 7.5

The mod_tls module in ProFTPD before 1.3.5b and 1.3.6 before 1.3.6rc2 does not properly handle the TLSDHParamFile directive, which might cause a weaker than intended Diffie-Hellman (DH) key to be used and consequently allow attackers to have unspecified impact via unknown vectors.

Record
CVE-2016-3125
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2016-3125 7.5

The mod_tls module in ProFTPD before 1.3.5b and 1.3.6 before 1.3.6rc2 does not properly handle the TLSDHParamFile directive, which might cause a weaker than intended Diffie-Hellman (DH) key to be used and consequently allow attackers to have unspecified impact via unknown vectors.

Record
DEBIAN-CVE-2016-3125
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2016-3125 7.5

The mod_tls module in ProFTPD before 1.3.5b and 1.3.6 before 1.3.6rc2 does not properly handle the TLSDHParamFile directive, which might cause a weaker than intended Diffie-Hellman (DH) key to be used and consequently allow attackers to have unspecified impact via unknown vectors.

Record
UBUNTU-CVE-2016-3125
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVMGASA-2016-0128 No score

Updated proftpd packages fix security vulnerability

A bug with security implications was found in the mod_tls module in ProFTPD before 1.3.5b. This module has a configuration option TLSDHParamFile to specify user-defined Diffie Hellman parameters. The software would ignore the user-defined parameters and use Diffie Hellman key exchanges with 1024 bits (CVE-2016-3125).

The proftpd package has been updated to version 1.3.5b, which fixes this issue and other bugs, including:

  • SSH RSA hostkeys smaller than 2048 bits now work properly.
  • MLSD response lines are now properly CRLF terminated.
Record
MGASA-2016-0128
Updated
2026-11-02
OSVopenSUSE-SU-2024:10048-1 No score

proftpd-1.3.5b-2.5 on GA media

These are all security issues fixed in the proftpd-1.3.5b-2.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10048-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
proftpd-dfsg
Debian:12
before 1.3.5b-1
1.3.5b-1
proftpd-dfsg
Debian:13
before 1.3.5b-1
1.3.5b-1
proftpd-dfsg
Debian:14
before 1.3.5b-1
1.3.5b-1
proftpd
Mageia:5
before 1.3.5b-1.mga5
1.3.5b-1.mga5
proftpd-dfsg
Ubuntu:16.04:LTS
All versions, plus listed versions
1.3.5-21.3.5a-11.3.5a-1build11.3.5a-1ubuntu0.1
None known
proftpd
openSUSE:Tumbleweed
before 1.3.5b-2.5
1.3.5b-2.5

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-3125 is a high vulnerability (CVSS 7.5) in Proftpd, published March 31, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.98%, the 94th percentile. Fixed in proftpd-dfsg 1.3.5b-1.

References

Show 20 moreShow less
MoveEnter Open