Every CVE Search/ Get API key

CVE-2016-3624

The cvtClump function in the rgb2ycbcr tool in LibTIFF 4.0.6 and earlier allows remote attackers...

7.5 HighFix available

The cvtClump function in the rgb2ycbcr tool in LibTIFF 4.0.6 and earlier allows remote attackers to cause a denial of service (out-of-bounds write) by setting the "-v" option to -1.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

4.45%Up 3.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The cvtClump function in the rgb2ycbcr tool in LibTIFF 4.0.6 and earlier allows remote attackers to cause a denial of service (out-of-bounds write) by setting the "-v" option to -1.

Record
CVE-2016-3624
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

The cvtClump function in the rgb2ycbcr tool in LibTIFF 4.0.6 and earlier allows remote attackers to cause a denial of service (out-of-bounds write) by setting the "-v" option to -1.

Record
CVE-2016-3624
Updated
2026-11-02
EUVDEUVD-2016-4650 No score

The cvtClump function in the rgb2ycbcr tool in LibTIFF 4.0.6 and earlier allows remote attackers to cause a denial of service (out-of-bounds write) by setting the "-v" option to -1.

Record
EUVD-2016-4650
Updated
2026-11-03
GitHub AdvisoriesGHSA-g6q5-rqfh-3jr6 7.5

The cvtClump function in the rgb2ycbcr tool in LibTIFF 4.0.6 and earlier allows remote attackers...

The cvtClump function in the rgb2ycbcr tool in LibTIFF 4.0.6 and earlier allows remote attackers to cause a denial of service (out-of-bounds write) by setting the "-v" option to -1.

Record
GHSA-g6q5-rqfh-3jr6
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-787
Updated
2026-11-02
OSVALPINE-CVE-2016-3624 7.5

The cvtClump function in the rgb2ycbcr tool in LibTIFF 4.0.6 and earlier allows remote attackers to cause a denial of service (out-of-bounds write) by setting the "-v" option to -1.

Record
ALPINE-CVE-2016-3624
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

The cvtClump function in the rgb2ycbcr tool in LibTIFF 4.0.6 and earlier allows remote attackers to cause a denial of service (out-of-bounds write) by setting the "-v" option to -1.

Record
CVE-2016-3624
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-3624 7.5

The cvtClump function in the rgb2ycbcr tool in LibTIFF 4.0.6 and earlier allows remote attackers to cause a denial of service (out-of-bounds write) by setting the "-v" option to -1.

Record
DEBIAN-CVE-2016-3624
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-3624 7.5

The cvtClump function in the rgb2ycbcr tool in LibTIFF 4.0.6 and earlier allows remote attackers to cause a denial of service (out-of-bounds write) by setting the "-v" option to -1.

Record
UBUNTU-CVE-2016-3624
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUSN-3212-1 No score

tiff vulnerabilities

It was discovered that LibTIFF incorrectly handled certain malformed images. If a user or automated system were tricked into opening a specially crafted image, a remote attacker could crash the application, leading to a denial of service, or possibly execute arbitrary code with user privileges.

Record
USN-3212-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
tiff
Alpine:v3.2
before 4.0.7-r0
4.0.7-r0
tiff
Alpine:v3.3
before 4.0.7-r0
4.0.7-r0
tiff
Alpine:v3.4
before 4.0.7-r0
4.0.7-r0
tiff
Debian:12
before 4.0.6-3
4.0.6-3
tiff
Debian:13
before 4.0.6-3
4.0.6-3
tiff
Debian:14
before 4.0.6-3
4.0.6-3
tiff
Debian:7
before 4.0.2-6+deb7u9, plus listed versions
4.0.2-64.0.2-6+deb7u14.0.2-6+deb7u24.0.2-6+deb7u34.0.2-6+deb7u4
Show 4 moreShow less
4.0.2-6+deb7u54.0.2-6+deb7u64.0.2-6+deb7u74.0.2-6+deb7u8
4.0.2-6+deb7u9
tiff
Debian:8
before 4.0.3-12.3+deb8u2, plus listed versions
4.0.3-12.34.0.3-12.3+deb8u1
4.0.3-12.3+deb8u2
tiff
Ubuntu:14.04:LTS
before 4.0.3-7ubuntu0.6, plus listed versions
4.0.2-4ubuntu34.0.3-5ubuntu14.0.3-64.0.3-6ubuntu14.0.3-7
Show 4 moreShow less
4.0.3-7ubuntu0.14.0.3-7ubuntu0.24.0.3-7ubuntu0.34.0.3-7ubuntu0.4
4.0.3-7ubuntu0.6
tiff
Ubuntu:16.04:LTS
before 4.0.6-1ubuntu0.1, plus listed versions
4.0.3-12.3ubuntu24.0.5-14.0.6-1
4.0.6-1ubuntu0.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-3624 is a high vulnerability (CVSS 7.5) in Libtiff, published October 3, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.45%, the 91st percentile. Fixed in tiff 4.0.7-r0.

References

Show 46 moreShow less
MoveEnter Open